Вход | Регистрация
 

Построить график "воронка" на форме

Построить график "воронка" на форме
Я
   ArturDoo
 
10.12.20 - 15:53
В каком порядке нужно вводить данные в этот чертов график, чтоб он рисовал что-то кроме цилиндра???!!!
Я это делаю так, но ничего не выходит:
МассивДанныеГрафикаДеньги = ПолучитьДанныеГрафикаДеньги();
    ТочкаЗнач = 1;
    Для Каждого Элемент ИЗ МассивДанныеГрафикаДеньги Цикл
    //    
        Серия = ГрафикДеньги.УстановитьСерию(Элемент.ЭтапПроцесса);
        Серия.Раздвигать = Истина;
        
        Точка = График.УстановитьТочку(ТочкаЗнач);

        График.УстановитьЗначение(Точка, Серия, Элемент.Потенциал);
        ТочкаЗнач = ТочкаЗнач+1;
        КонецЦикла;
   Dmitry1c
 
1 - 10.12.20 - 16:07
(0) надо сначала матчасть изучить на простых примерах, а потом браться за дело.
   ArturDoo
 
2 - 10.12.20 - 16:10
(1) Ты изучил? Есть совет?
   ArturDoo
 
3 - 10.12.20 - 16:11
(1) Это и есть простой пример. Но я не могу найти мат часть по нему, в поисковике всё время лезет воронка продаж
   ArturDoo
 
4 - 10.12.20 - 16:17
И я уже строил график "График", выглядит это так, но этот вариант не подходит для "воронки"

Пока Выборка.Следующий() Цикл
        
        Серия = График.УстановитьСерию(Выборка.Сделка);
        Серия.Раздвигать = Истина;
        
        ВыборкаТочки = Выборка.Выбрать();
        Пока ВыборкаТочки.Следующий() Цикл
            Точка = График.УстановитьТочку(ВыборкаТочки.ЭтапПроцесса); 
            НазваниеЭтапа = Точка.Значение.Наименование;
            НайденнаяСтрока = ТЗ.Найти(НазваниеЭтапа, "ЭтапПроцесса");
            ПЭтапа = Окр (НайденнаяСтрока.ПродолжительностьЭтапа,1);
            Точка.Текст = НазваниеЭтапа +"  "+ ПЭтапа;
            Если ВыборкаТочки.ДатаОкончания <> ДАТА(1, 1, 1, 0, 0, 0) Тогда
                График.УстановитьЗначение(Точка, Серия, ВыборкаТочки.Продолжительность);
            КонецЕсли;
        КонецЦикла;
    КонецЦикла;
   Dmitry1c
 
5 - 10.12.20 - 16:53
(2) это и был совет
   ArturDoo
 
6 - 10.12.20 - 22:21
(5) Зачем писать, если можешь сказать что-то дельное?

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.