Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Список документов (обновление)

Список документов (обновление)
Я
   Snail
 
09.12.20 - 16:46
Как после записи документа обновить (у всех ползователей) открытый список этих документов ? (типа автообновление через N- секунд)
   Beduin
 
1 - 09.12.20 - 16:47
оповещение
   Snail
 
2 - 09.12.20 - 16:52
&НаКлиенте
Процедура ПослеЗаписи(ПараметрыЗаписи)
    Оповестить("Запись_Реализация", ПараметрыЗаписи, Объект.Ссылка);
КонецПроцедуры


&НаСервере
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
    ИмяСобытия = "Запись_Реализация";
КонецПроцедуры

Так не катит :(
   Snail
 
3 - 09.12.20 - 17:00
Если ИмяСобытия = "Запись_Реализация" Тогда
   что тут прописать для обновления?
КонецЕсли
   Serg_1960
 
4 - 09.12.20 - 17:07
&НаКлиенте
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
   Если ИмяСобытия = "Запись_Реализация" Тогда
      Элементы.Список.Обновить();
   Serg_1960
 
5 - 09.12.20 - 17:09
А для управляемых форм, имхо, лучше ОбработкаКоманды() и в ней ОповеститьОбИзменении(ОбъектСсылка);
   Snail
 
6 - 09.12.20 - 17:10
Serg_1960, спасибо, но что-то для второго пользователя список не обновляется ((
   youalex
 
7 - 09.12.20 - 17:12
у всех ползователей - не прокатит, пмсм
   polosov
 
8 - 09.12.20 - 17:12
(6) потому что Оповестить() оповещает только открытые окна текущего сеанса.
   Snail
 
9 - 09.12.20 - 17:12
&НаКлиенте
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
   Если ИмяСобытия = "Запись_Реализация" Тогда
      Элементы.Список.Обновить();

Эта процедура  в ФормеСписка? Правильно?
   polosov
 
10 - 09.12.20 - 17:15
(0) а твой список это ДС?
   youalex
 
11 - 09.12.20 - 17:18
типа автообновление через N- секунд - не вариант?
   Snail
 
12 - 09.12.20 - 17:19
Это не нагружает систему?
   Serg_1960
 
13 - 09.12.20 - 17:20
(6) Sorry, Ваше примечание "у всех пользователей" меж ушей пропустил :(
Оповещение работает в пределах одного сеанса для всех открытых форм.
(9) Да.
   Snail
 
14 - 09.12.20 - 17:25
автообновление через N-секунд  - это единственый выход?
   mistеr
 
15 - 09.12.20 - 17:29
(14) Не единственный, но самый простой в реализации.
   mistеr
 
16 - 09.12.20 - 17:29
(15) Ибо уже реализован.
   Snail
 
17 - 09.12.20 - 17:30
Тормозить не будет, если поставлю 3 секунды?
   mistеr
 
18 - 09.12.20 - 17:37
(17) Ты меня спрашиваешь? Мне откуда знать, какое у вас железо?

Но я бы поставил 5.
   Serg_1960
 
19 - 09.12.20 - 17:41
(14) Нет, не единственный. У 1С есть решение "сервер взаимодействия" - дорого/богато :)
Рассуждая чисто теоретически, можно события оповещения из одного сеанса в другие сеансы "транслировать" через запись в специально созданный регистр сведений. Потребуются фоновые задания других сеансов, которые будут контролировать этот регистр и "дублировать" события из других сеансов. Не оптимальный и затратный механизм :(
(17) Естественно будет подтормаживать - это же обращение к базе данных.
   Snail
 
20 - 09.12.20 - 17:42
Всем огромное спасибо! Поставил 25 сек. Нормально )
   Snail
 
21 - 09.12.20 - 17:43
Serg_1960 отдельное спасибо!


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.