Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Отключить быстрый выбор форма выбора

Отключить быстрый выбор форма выбора
Я
   BoiSaOne
 
09.12.20 - 16:27
Здраствуйте у меня проблема как убрать "Быстрый выбор" при нажатии кнопки "Выбрать" у поля выбора в таблице значения.
Т.е. при нажатии на кнопку добавить у меня открывается форма выбора с отбором после выбранный элемент добавляется в таблицу значений, но при изменении этого элемента (Выбрать F4)  у меня открывается эта же форма выбора с отбором, но у меня также появляется быстрый выбор элемента, как вот это быстрый выбор можно убрать у свойства поля "Номенклатура" БыстрыйВыбор выбрано значение Нет.
Вот ссылка на скрин:https://priscree.ru/img/26325861eeb375.jpg
 
 Партнерская программа EFSOL Oblako
   vicof
 
1 - 09.12.20 - 16:44
Отказ = Истина;
   vicof
 
2 - 09.12.20 - 16:44
тьфу
СтандартнаяОбработка = Истина
   vicof
 
3 - 09.12.20 - 16:44
тьфу = ЛОжь
   vicof
 
4 - 09.12.20 - 16:44
Пальцы и мозги не слушаются)
   BoiSaOne
 
5 - 09.12.20 - 16:59
Хорошо, но у меня в модуле формы уже стоит СтандартнаяОбработка = Ложь;
   vicof
 
6 - 09.12.20 - 17:20
Ну я не вижу, что у тебя там в коде написано
   BoiSaOne
 
7 - 09.12.20 - 17:43
Вот код:
Процедура ТаблицаНоменклатураНоменклатураНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка//Обработка начало выбора

    СтандартнаяОбработка = Ложь;
    Если НЕ ЗначениеЗаполнено(Цех) Тогда
        Сообщение = Новый СообщениеПользователю;
        Сообщение.Текст = "Необходимо выбрать цех!";
        Сообщение.Поле = "Цех";
        Сообщение.УстановитьДанные(ЭтотОбъект);
        Сообщение.Сообщить();
        Возврат;
    КонецЕсли;
    НачалоВыбораНаСервере(ДанныеВыбора);
    ФормаВыбора = ПолучитьФорму("Справочник.Номенклатура.ФормаВыбора",,Элемент);
    ФормаВыбора.Масштаб = ЭтаФорма.Масштаб;
    эОтбор = ФормаВыбора.Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    эОтбор.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Ссылка");
    эОтбор.ВидСравнения = ВидСравненияКомпоновкиДанных.ВСписке;
    эОтбор.ПравоеЗначение = ДанныеВыбора;
    эОтбор.Использование = Истина;
    эОтбор.РежимОтображения = РежимОтображенияЭлементаНастройкиКомпоновкиДанных.Недоступный;
    ФормаВыбора.Элементы.Список.Отображение = ОтображениеТаблицы.Список;
    ФормаВыбора.Открыть(); 
КонецПроцедуры


&НаСервере
Процедура НачалоВыбораНаСервере(ДанныеВыбора//Отбираем данные выбора 

    Запрос = Новый Запрос;
    Запрос.Текст = 
    "ВЫБРАТЬ
    |    ЗначенияСвойствОбъектов.Объект КАК Объект
    |ИЗ
    |    РегистрСведений.ЗначенияСвойствОбъектов КАК ЗначенияСвойствОбъектов
    |ГДЕ
    |    ЗначенияСвойствОбъектов.Свойство В
    |            (ВЫБРАТЬ
    |                СвойстваОбъектов.Ссылка КАК Ссылка
    |            ИЗ
    |                ПланВидовХарактеристик.СвойстваОбъектов КАК СвойстваОбъектов
    |            ГДЕ
    |                СвойстваОбъектов.Код = ""00000000004"")
    |    И ЗначенияСвойствОбъектов.Значение = &Значение";
    Запрос.УстановитьПараметр("Значение", Цех);
    
    Результат = Запрос.Выполнить().Выгрузить();
    ДанныеВыбора = Новый СписокЗначений;
    Если Результат.Количество() > 0 Тогда
        ДанныеВыбора.ЗагрузитьЗначения(Результат.ВыгрузитьКолонку("Объект"));
    КонецЕсли;
КонецПроцедуры
   Дык ё
 
8 - 09.12.20 - 17:51
так ты определись - или данные выбора или форма

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.