Вход | Регистрация
 

Удалить документ механически

Удалить документ механически
Я
   НатГолубева777
 
09.12.20 - 15:28
Подскажите, пожалуйста, как сделать чтобы на моменте строки кода "ЭтотОбъект.Удалить();" не выдавало ошибку?

Вот код:
Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка)
    //{{__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    |    РезервированиеТоваровСЯчеек.Заказ.Ссылка
    |ИЗ
    |    Документ.РезервированиеТоваровСЯчеек КАК РезервированиеТоваровСЯчеек
    |ГДЕ
    |    РезервированиеТоваровСЯчеек.Заказ.Ссылка = &Заказ";
    Запрос.УстановитьПараметр("Заказ", ДанныеЗаполнения.Ссылка);
    РезультатЗапроса = Запрос.Выполнить();
        Если РезультатЗапроса.Пустой() Тогда     

            Если ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.ЗаказПокупателя") Тогда
                // Заполнение шапки
                Комментарий = ДанныеЗаполнения.Комментарий;
                Контрагент = ДанныеЗаполнения.Контрагент;
                НомерЗаказа = ДанныеЗаполнения.Номер;
                Заказ = ДанныеЗаполнения.Ссылка;
                Для Каждого ТекСтрокаТовары Из ДанныеЗаполнения.Товары Цикл
                    НоваяСтрока = ТоварыПоЗаказу.Добавить();
                    НоваяСтрока.ЕдИзм = ТекСтрокаТовары.ЕдиницаИзмерения;
                    НоваяСтрока.Количество = ТекСтрокаТовары.Количество;
                    НоваяСтрока.Номенклатура = ТекСтрокаТовары.Номенклатура;
                    НоваяСтрока.Скидка = ТекСтрокаТовары.ПроцентСкидкиНаценки;
                    НоваяСтрока.Сумма = ТекСтрокаТовары.Сумма;
                    НоваяСтрока.Характеристика = ТекСтрокаТовары.ХарактеристикаНоменклатуры;
                    НоваяСтрока.Цена = ТекСтрокаТовары.Цена;
        //            НоваяСтрока.Ячейка = ТекСтрокаТовары.Ячейка;
                КонецЦикла;
            КонецЕсли;
        Иначе    Предупреждение ("На основании этого заказа уже был создан документ *Резервирование товаров по ячейкам*!");
            
            ЭтотОбъект.Удалить();
        КонецЕсли;    
    //}}__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ
КонецПроцедуры
   Fragster
 
1 - 09.12.20 - 15:30
ВызватьИсключение
   Злопчинский
 
2 - 09.12.20 - 15:30
(0) обернуть в исключение, в обработке исключения ошибку не выдавать. ПРОФИТ!
   ДенисЧ
 
3 - 09.12.20 - 15:32
Ммм.... В обработке заполнения ЭтотОбъект.Удалить() ???
Это что, как Мюнхгаузен, только наоборот?
   Fragster
 
4 - 09.12.20 - 15:33
   Злопчинский
 
5 - 09.12.20 - 15:33
(3) не! вытащить себя - это проблематично, а вот утопиться - это нараз!
   Fragster
 
6 - 09.12.20 - 15:33
но вообще название темы доставляет, да :)
   Fragster
 
7 - 09.12.20 - 15:34
   dmpl
 
8 - 09.12.20 - 15:38
(0) Во-первых, если документ создавать не надо - это делается через Отказ при создании документа. Во-вторых, такой запрет - это костыли. А если в первом документе не все зарезервировали по заказу? Ну не все пришло, например. Что, давать доступ на неоперативное проведение и править старый документ? А он проведется старой датой?
   НатГолубева777
 
9 - 09.12.20 - 15:45
СПАСИБО...  вызвала исключение...
   polosov
 
10 - 09.12.20 - 16:06
Вам смешно, а кто-то за такое деньги платит.
   Гений 1С
 
11 - 09.12.20 - 16:16
обменданными.загрузка = истина? не
   youalex
 
12 - 09.12.20 - 16:22
(11) не
   Serg_1960
 
13 - 09.12.20 - 16:27
Что автор собирается удалять, если объект ещё не записан в базу?
Если Не ЭтотОбъект.ЭтоНовый() Тогда
   ЭтотОбъект.Удалить();
КонецЕсли:
   trad
 
14 - 09.12.20 - 16:28
(9) можно еще так сделать
//ЭтотОбъект.Удалить();
   Serg_1960
 
15 - 09.12.20 - 16:34
(14) Не корректно если обработчик был вызван через ЭтотОбъект.Заполнить()
PS: имхо, хотелки у автора странные.
   Fragster
 
16 - 09.12.20 - 16:36
(15) нормальные хотелки, проблема с формулировкой. вон, даже в стандартах разработки есть, см. (4)
   Serg_1960
 
17 - 09.12.20 - 16:39
(16) Я про саму попытку удаления, а не про вызов исключения.
   Джинн
 
18 - 09.12.20 - 17:29
Механически - это поверхность жесткого диска наждачной бумагой снять.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.