Вход | Регистрация
 

Создание веб сервиса и отправка номенклатуры в другую базу по http

Создание веб сервиса и отправка номенклатуры в другую базу по http
Я
   Простенький вопросик
 
06.12.20 - 17:09
Дайте ссылку на грамотный пример без глюков
   ДенисЧ
 
1 - 06.12.20 - 17:16
Веб-сервис не предназначен для передачи данных.
Он отдаёт данные в ответ на запрос.

Так что - сначала матчасть поучи. Там делается в 1с за 2 минуты + 5 минут на публикацию (не считая времени на поиск, скачивание и установку апача)
   Garykom
 
2 - 06.12.20 - 18:12
(1) С фига ли? Веб или http (лучше http оно проще) предназначено для передачи в обе стороны.

Данные можно как вытягивать так и заталкивать
   ДенисЧ
 
3 - 06.12.20 - 18:15
(2) Ты можешь самостоятельно именно веб-сервис заставить передавать данные?
И да, не путай с .ОтправитьДляОбработки(). Это не веб-сервис.
   Гений 1С
 
4 - 06.12.20 - 18:42
(0) о, я так контрагентов гонял
   Гений 1С
 
5 - 06.12.20 - 18:42
(0) Еще актуально? Могу набросать кода
   ДедМорроз
 
6 - 06.12.20 - 18:48
Web или http сервис отвечает на полученный запрос,то есть инициатором выступает тот,кто к нему обращается,а уж направление передачи данных определяется логикой
По сути,запрос к сервису,это входящие данные,а ответ сервиса - исходящие.
   Гений 1С
 
7 - 06.12.20 - 18:53
Кароче, вот тебе пример для затравки.

Функция    ПодключитьсяКСервисуФормированияПродаж() Экспорт
    СтруктураСервиса = Новый Структура("ОК, Ошибки", истина, ложь);
    
    Логин = Константы._СервисФормированияПродаж_Логин.Получить();
    Пароль = Константы._СервисФормированияПродаж_Пароль.Получить();;
    WSDLТекст = СокрЛП(Константы._СервисФормированияПродаж_WSDLТекст.Получить());
    
    
    Попытка
        Если ЗначениеЗаполнено(WSDLТекст) Тогда
            //WSDL файл локальный, если нужно менять порты
            ИмяВременногоФайла = ПолучитьИмяВременногоФайла("xml");
            Адрес = ИмяВременногоФайла;
            Адрес = СтрЗаменить(Адрес, "\", "/");
            Адрес = "file://" + Адрес;
            Т = Новый ТекстовыйДокумент();
            Т.УстановитьТекст(WSDLТекст);
            Т.Записать(ИмяВременногоФайла);
        Иначе
            //Пример адреса: "http://127.0.0.1/my1s/ws/ws_cliex.1cws?wsdl";
            Адрес = Константы._СервисФормированияПродаж_Адрес.Получить();
        КонецЕсли;
    
    
        Определение = Новый WSОпределения(Адрес, Логин, Пароль);
        
        ПространствоИмен = "http://www.geniy1s.ru/CliEx";;
        Сервис = Новый WSПрокси(Определение,
        ПространствоИмен,
        "_ФормированиеПродаж",
        "_ФормированиеПродажSoap"
        );
        
        Сервис.Пользователь = Логин;
        Сервис.Пароль = Пароль;
        СтруктураСервиса.Вставить("Сервис", Сервис);
    Исключение
        СтруктураСервиса.ОК = ложь;
        СтруктураСервиса.Ошибки = ОписаниеОшибки();
    КонецПопытки;
    
    Возврат СтруктураСервиса;    
КонецФункции

Функция ПолучитьТовар(СтруктураПоиска) Экспорт
    УстановитьПривилегированныйРежим(Истина);
    
    Результат = Новый Структура();
    СтруктураСервиса = _ФормированиеПродаж.ПодключитьсяКСервисуФормированияПродаж();
        
    Если СтруктураСервиса.ОК = ложь Тогда
        Результат.Вставить("ОК", ложь);
        Результат.Вставить("Ошибки", "Не удалось подключиться к базе, ошибка: " + СтруктураСервиса.Ошибки);
        Возврат Результат;
    КонецЕсли;
    

    СтруктураПоиска.Вставить("ИмяКомпьютера", ПараметрыСеанса._ИмяКомпьютераПользователя);        

    
    РезультатВнутр = СтруктураСервиса.Сервис.GetGoods(ЗначениеВСтрокуВнутр(СтруктураПоиска));
    Результат = ЗначениеИзСтрокиВнутр(РезультатВнутр);
    Возврат Результат;
КонецФункции
   Cthulhu
 
8 - 06.12.20 - 18:57
а можно просто опубликовать - и сразу кодить дергание-запись чего надо через oData...
   Гений 1С
 
9 - 06.12.20 - 19:00
(1) Хахаха, Горе-Teacher пришел
   ДенисЧ
 
10 - 06.12.20 - 19:02
(9) Ну не всем же баптистами быть. Некоторым нужно ещё чайников учить
   Гений 1С
 
11 - 06.12.20 - 19:03
(10) чему ты пытаешься научить?
   ДенисЧ
 
12 - 06.12.20 - 19:05
(11) Тебе всё равно не понять, поэтому я не буду тратить время
   Бишбармак
 
13 - 07.12.20 - 05:18

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.