Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Не удалось подключить устройство сбрф эквайринговые терминалы

Не удалось подключить устройство сбрф эквайринговые терминалы
Я
   John83
 
05.12.20 - 09:17
Обновил УТ 11.4 до 11.4.13.71
При открытии рабочего места кассира выдает
Не удалось подключить устройство сбрф эквайринговые терминалы ... Ошибка обращения к драйверу.
Попробовал в драйвере убрать "снят с поддержки" - не помогло.
Как лечить? Где этот драйвер найти?
   Cypher
 
1 - 05.12.20 - 10:54
Здравствуйте, перенастройте торговое оборудование (Эквайринговые терминалы) в программе!
Вот драйвер, по ссылке: https://cloud.mail.ru/public/3jXE/4JLJeq5kf
   Cypher
 
2 - 05.12.20 - 10:56
Привет, что-то сразу не обратила внимание, что это Ты!!!
Как дела!? Что за проблема с Эквайрингом!?
   John83
 
3 - 05.12.20 - 10:59
(2) привет-привет
я тоже несколько удивился :)
Да что-то терминал перестал работать, а я всего час поспал - голова вообще не варит.
Сейчас попробую по новой создать.
   Cypher
 
4 - 05.12.20 - 11:03
Что себя не жалеешь, всего час поспал, это что такое!???
Я вот возьмусь за Твое воспитание!!!
   Cypher
 
5 - 05.12.20 - 11:15
После перенастройки торгового оборудования, очисти КЕШ в программе 1С, перезагрузи программу и компьютер!!!
   Cypher
 
6 - 05.12.20 - 11:17
Ну что, получается!?
   John83
 
7 - 05.12.20 - 11:20
(5) кэш чистить нельзя - там еще другое оборудование установлено
   John83
 
8 - 05.12.20 - 11:20
(6) пока не очень
   John83
 
9 - 05.12.20 - 11:21
(4) дык обновлением всю ночь занимался
не надо меня перевоспитывать - лучше принять таким, какой есть :)
   Cypher
 
10 - 05.12.20 - 11:26
У меня девять магазинов на обслуживании, довольно часто без предупреждения вырубают свет, в некоторых из них летит база, Ошибка: Неверный формат хранилища данных, на всех магазинах подключено не одно торговое оборудование, чистю КЕШ, без проблем программа запускается и работает все торговое оборудование!!! С чего Ты взял, что нельзя чистить КЕШ!???
   Cypher
 
11 - 05.12.20 - 11:28
Человек формируется до 25 лет, Тебе 37, я так понимаю воспитывать Тебя уже поздно!!!
   John83
 
12 - 05.12.20 - 11:30
(10) потому что слетает все оборудование
хотя можно чистить по-хитрому и тогда не слетит
   John83
 
13 - 05.12.20 - 11:30
(11) сам себя перевоспитываю по мере необходимости :)
   Cypher
 
14 - 05.12.20 - 11:36
Тебя в Санкт-Петербурге нужно определить в теплые любящие руки, женат!?
   Cypher
 
15 - 05.12.20 - 11:38
Ладно, а то мы тут с Тобой устроили сайт знакомств, пока нас не забанили, давай по существу!!!
   Cypher
 
16 - 05.12.20 - 11:41
Я уеду на некоторое время по делам, пиши по проблеме Эквайринга, разберемся!!!
   John83
 
17 - 05.12.20 - 13:13
не выходит каменный цветок...
Если открыть встроенный драйвер, то типа установлен
https://b.radikal.ru/b27/2012/bd/88cdff9131b1.png
А добавленный никак не устанавливается, хотя библиотеку зарегал
https://b.radikal.ru/b35/2012/4c/46f7fd0aa312.png

При нажатии "настроить" в оборудовании изначально установленного, выдает
Метод объекта не обнаружен (УстановитьПараметр)
{ОбщийМодуль.ПодключаемоеОборудованиеУниверсальныйДрайверКлиент.Модуль(3108)}:        ОбъектДрайвера.УстановитьПараметр("EquipmentType", ТипОборудования) 
{ОбщийМодуль.ПодключаемоеОборудованиеУниверсальныйДрайверКлиент.Модуль(210)}:        Результат = ПолучитьОписаниеДрайвера(ОбъектДрайвера, Параметры, ПараметрыПодключения, ВыходныеПараметры);
{ОбщийМодуль.МенеджерОборудованияКлиент.Модуль(1836)}:                Результат = ОбработчикДрайвераМодуль.ВыполнитьКоманду(ПараметрыКоманды.Команда, ПараметрыКоманды.ВходныеПараметры,
{ОбщийМодуль.МенеджерОборудованияКлиент.Модуль(1634)}:            ВыполнитьОбработкуОповещения(ОповещениеПриЗавершении, ОбъектДрайвера);
{ОбщийМодуль.МенеджерОборудованияКлиент.Модуль(1776)}:        НачатьПолучениеОбъектаДрайвера(Оповещение, ДанныеОборудования);
{ОбщаяФорма.ФормаНастройкиУниверсальныйДрайвер.Форма(629)}:    МенеджерОборудованияКлиент.НачатьВыполнениеДополнительнойКоманды(Оповещение, "ПолучитьОписаниеДрайвера", ВходныеПараметры, Идентификатор, ПараметрыУстройства);
{ОбщаяФорма.ФормаНастройкиУниверсальныйДрайвер.Форма(70)}:    ОбновитьИнформациюОДрайвере(Истина);
{ОбщийМодуль.МенеджерОборудованияКлиент.Модуль(115)}:        ОткрытьФорму("ОбщаяФорма." + ФормаНастройки, ПараметрыФормы,,,  ,, Обработчик, РежимОткрытияОкнаФормы.БлокироватьВесьИнтерфейс);
{Справочник.ПодключаемоеОборудование.Форма.ПодключениеИНастройкаОборудования.Форма(169)}:    МенеджерОборудованияКлиент.ВыполнитьНастройкуОборудования(Элементы.СписокУстройств.ТекущиеДанные.Ссылка);
   John83
 
18 - 05.12.20 - 13:13
если добавить новое оборудование, то тоже самое
   John83
 
19 - 05.12.20 - 13:15
   John83
 
20 - 05.12.20 - 13:16
(14) готов рассмотреть кандидаток с теплыми руками ;)
   John83
 
21 - 05.12.20 - 13:21
(10) хотя ты наверное его чистишь через /клиркэш
   Mihasya
 
22 - 05.12.20 - 13:27
(0) УТ 11.4.9.98 и эквайринг сбера не твоя ситуация?
   John83
 
23 - 05.12.20 - 13:40
(22) похоже
я обновлял с версии 11.4.6.188
Так что, там перенести общую форму?
   Garykom
 
24 - 05.12.20 - 13:46
(0) Драйвер тока 32 битный
   Mihasya
 
25 - 05.12.20 - 13:48
в расширении в модуле МенеджерОборудованияКлиент заменил процедуру ВыполнитьНастройкуОборудования

&Вместо("ВыполнитьНастройкуОборудования")
Процедура РАСШ_ВыполнитьНастройкуОборудования(Идентификатор, ОповещениеПриЗавершении)

    Результат = Истина;
    
    ДанныеУстройства = МенеджерОборудованияКлиентПовтИсп.ПолучитьДанныеУстройства(Идентификатор);
    ПараметрыФормы = Новый Структура("ПараметрыОборудования", ДанныеУстройства.Параметры);
    ПараметрыФормы.Вставить("Идентификатор", Идентификатор);
    ПараметрыФормы.Вставить("ДрайверОборудования", ДанныеУстройства.ДрайверОборудования);
    
    ФормаНастройки = "ФормаНастройкиУниверсальныйДрайвер";
    
    ОбработчикДрайвера = МенеджерОборудованияКлиентПовтИсп.ПолучитьОбработчикДрайвера(ДанныеУстройства.ОбработчикДрайвера, Не ДанныеУстройства.ВСоставеКонфигурации, ДанныеУстройства.ТипОборудованияИмя);
        
    Если Не ОбработчикДрайвера = ПодключаемоеОборудованиеУниверсальныйДрайверКлиент 
        И Не ОбработчикДрайвера = ПодключаемоеОборудованиеУниверсальныйДрайверАсинхронноКлиент Тогда
            ФормаНастройки = СтрЗаменить(ДанныеУстройства.ОбработчикДрайвераИмя, "Обработчик", "ФормаНастройки");
    КонецЕсли;
        
    Если ДанныеУстройства.ОбработчикДрайвераИмя = "ОбработчикСБРФЭквайринговыеТерминалы" Тогда
        //Попытка

        //    ПодключитьВнешнююКомпоненту("AddIn.SBRFCOMObject");

        //Исключение

        //    ОбщегоНазначенияКлиентСервер.СообщитьПользователю(НСтр("ru='Произошла ошибка при подключении компоненты AddIn.SBRFCOMObject'")); 

        //Конецпопытки;

        ФормаНастройки = "ФормаНастройкиСБРФЭквайринговыеТерминалы";
    КонецЕсли;
        
    Если НЕ ПустаяСтрока(ФормаНастройки) Тогда
        ПараметрыКоманды = Новый Структура("ОповещениеПриЗавершении", ОповещениеПриЗавершении);
        Обработчик = Новый ОписаниеОповещения("ВыполнитьНастройкуОборудования_Завершение", ЭтотОбъект, ПараметрыКоманды);
        ОткрытьФорму("ОбщаяФорма." + ФормаНастройки, ПараметрыФормы,,,  ,, Обработчик, РежимОткрытияОкнаФормы.БлокироватьВесьИнтерфейс);
    Иначе
        ОбщегоНазначенияКлиентСервер.СообщитьПользователю(НСтр("ru='Произошла ошибка инициализации формы настройки драйвера.'")); 
    КонецЕсли;
    
КонецПроцедуры
 
и из старой конвы перетащил в новую общую форму "ФормаНастройкиСБРФЭквайринговыеТерминалы" и общий модуль "ПодключаемоеОборудованиеСБРФЭквайринговыеТерминалыКлиент"

вроде так
но у меня конфа была с возможностью изменений...
   Mihasya
 
26 - 05.12.20 - 13:52
(24) это само собой
   John83
 
27 - 05.12.20 - 13:52
(25) в предыдущей версии у меня нет
ПодключаемоеОборудованиеСБРФЭквайринговыеТерминалыКлиент
думаю, что из БП3 тоже пойдет
Буду пробовать.
   Garykom
 
28 - 05.12.20 - 13:53
(26) Не увидел что 1С на клиенте 32 а не 64 ))
   Mihasya
 
29 - 05.12.20 - 13:54
(27) странно, ну пробуй ))
   John83
 
30 - 05.12.20 - 14:48
(29) это ты на серверной или файловой базе делал?
 
 
   John83
 
31 - 05.12.20 - 14:48
+30 при таких доработках на локальной базе проблем нет, а на серверной ошибки сыпятся
   Cypher
 
32 - 05.12.20 - 14:51
Какая платформа 1С на данный момент стоит в работе после обновления?
   Mihasya
 
33 - 05.12.20 - 14:52
(30) серверная
   John83
 
34 - 05.12.20 - 14:55
(32) 1С:Предприятие 8.3 (8.3.15.1534)
   Mihasya
 
35 - 05.12.20 - 14:56
(32) в моем случае от платформы не зависело...
   Cypher
 
36 - 05.12.20 - 14:57
Попробуй скачать на релиз выше, установить и запустить все это дело!!!
   Cypher
 
37 - 05.12.20 - 15:03
Очистить КЕШ, я имела ввиду, удалить из списка запуска конфигурацию, и добавить ее заново, сделай это!!!
   Mihasya
 
38 - 05.12.20 - 15:06
(37) бесполезно ))
   John83
 
39 - 05.12.20 - 15:08
(37) пробовал
и если так сделать, то оборудование нужно по новой прописывать
   John83
 
40 - 05.12.20 - 15:09
(36) тоже попробую, но пока отладчиком поковыряю
   Mihasya
 
41 - 05.12.20 - 15:16
(39) ты видимо не правильно кэш чистишь... оборудование слетать не должно! за подключение оборудования отвечает вроде файл  1cv8.pfl (точнее не отвечает, а в нем храниться идентификатор рабочего места к которому подключено оборудование), находится в папке C:\Users\<ИМЯ ПОЛЬЗОВАТЕЛЯ>\AppData\Roaming\1C\1cv8, вот если его удалить, то да, оборудование слетает...
   Mihasya
 
42 - 05.12.20 - 15:21
+41 скорее всего этот файл C:\Users\<ИМЯ ПОЛЬЗОВАТЕЛЯ>\\AppData\Local\1C\1cv8\1cv8u.pfl
   John83
 
43 - 05.12.20 - 15:27
(42) вот тут в последнем сообщении я описал свой способ
Почистить кэш НЕ удаляя драйвера фискальника.
   Mihasya
 
44 - 05.12.20 - 15:33
еще раз, оборудование подключается к рабочему месту, рабочее место идентифицируется уникальным идентификатором, этот идентификатор хранится в файле из (42), перед чисткой кэша сохраняешь этот файл, удаляешь все тэмпы, файл возвращаешь на место, оборудование не слетает, проверь
   John83
 
45 - 05.12.20 - 15:36
(44) как раз я пробовал удалять все внутри папок пользователей - ничего не слетает
   John83
 
46 - 05.12.20 - 15:38
в общем окно с настройкой терминала появилось, но тест не проходит и в рабочем месте драйвера не видит.
От админа 1С запускал.
Какие еще есть идеи?
   Mihasya
 
47 - 05.12.20 - 15:51
(45) не надо все удалять, удали тока файл из (42) и проверь ))
(46) ну я возможно уже и что-то подзабыл (год назад дело было), может еще что-то нужно перенести, лезь в отладчик старой базы и смотри  как там подключается этот терминал
   John83
 
48 - 05.12.20 - 15:58
интересное дело
В списке находится терминал с драйвером "1С:Эквайринговые терминалы Сбербанк". Но до обновления не использовался.
И это оборудование проходит тест, но при печати выдает "эквайринговый терминал не подключен".
Может я вообще не в те ворота долблюсь?
   Cypher
 
49 - 06.12.20 - 10:38
John83, Доброе утро! Решил проблему с Эквайрингом!?
   Mihasya
 
50 - 23.12.20 - 16:07
(49) тож интересно, автор пропал что-то... ))
   twiny
 
51 - 04.01.21 - 13:36
тоже попался
нужно новые дрова для терминала СБ использовать: "1С:Эквайринговые терминалы Сбербанк"
также в настройках на него путь к программе терминала прописать, что-то типа c:\sc552
Один раз возможно платформу стартануть под правами Админа нужно будет
   John83
 
52 - 06.01.21 - 03:48
(51) это я учту на след. попытку обновления
спасибо!
   John83
 
53 - 06.01.21 - 03:48
а так я совсем забыл, что надо еще прописывать терминал в настройках раб. места - скорее всего из-за этого тогда и не взлетело


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.