Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

ERP интеграция с ДО . Очередь сообщений в 1С Документооборот

ERP  интеграция с ДО .  Очередь сообщений в 1С Документооборот
Я
   Юзер123
 
04.12.20 - 15:09
Доброй пятницы.

Периодически при бесшовном обмне между ЕРП и ДО стали проскакивать ошибки следующего содержания.

https://i.gyazo.com/127ccbdf52251b10cef36ddcb2a18a8a.png

Залез в  РС  Очередь сообщений в 1С Документооборот и увил там кучу строк с количеством попыток от 1 до 1к+

И как я понял  когда накапливается много записей в этом регистре возникают подобные ошибки.  Записи в регистре висят за прошлые месяца.  

Вопрос.  Почему там появляются записи и почему они не уходят после обмена? Норма это? как с этим жить?)
   Юзер123
 
1 - 04.12.20 - 15:19
хельп
   Dmitry1c
 
2 - 04.12.20 - 15:26
(0) люди, которые могут ответить на этот вопрос, сейчас бабки зашибают ;)
   Юзер123
 
3 - 07.12.20 - 12:06
актуально(
   s-n-a-y
 
4 - 07.12.20 - 13:37
Если у вас IIS, попробуйте где-нибудь в тестовой среде развернуть апач и проверить на нем
   s-n-a-y
 
5 - 07.12.20 - 13:41
IIS от греха лучше не трогайте
   DionisSergeevich
 
6 - 07.12.20 - 13:49
Измените максимальный размер сообщения. Но все равно большие не сможет передавать.
Появится время - буду что нибудь придумывать - например дробить сообщения обмена, но пока руки не дошли
   DionisSergeevich
 
7 - 07.12.20 - 13:49
(2) нет
   Юзер123
 
8 - 07.12.20 - 13:52
тут еще новая беда.  В виде новой ошибки следующего содержания

В строке 0 для стороны "" не указан подписант.

Нашел в ДО проверку эту
        Если ВестиУчетСторон Тогда
            Для Каждого Строка Из Объект.Стороны Цикл
                Если Строка.Подписан И Не ЗначениеЗаполнено(Строка.Подписал) Тогда
                    Если ЗначениеЗаполнено(Строка.Сторона) И ТипЗнч(Строка.Сторона) = Тип("СправочникСсылка.Контрагенты")
                        И ОбщегоНазначения.ЗначениеРеквизитаОбъекта(Строка.Сторона, "ЮрФизЛицо") = Перечисления.ЮрФизЛицо.ФизЛицо Тогда
                        Продолжить;
                    Иначе
                        НомерСтроки = Объект.Стороны.Индекс(Строка);
                        ТекстСообщения = ТекстСообщения 
                            + СтрШаблон(НСтр("ru = 'В строке %1 для стороны ""%2"" не указан подписант'"), НомерСтроки, Строка.Сторона)
                            + Символы.ПС;
                        ЕстьОшибки = Истина;
                    КонецЕсли;
                КонецЕсли;
            КонецЦикла;
        КонецЕсли;


В модуле ОбработкаЗапросовXDTO  

как там  отладчиком остановиться? посмотреть что и как.



ВестиУчетСторон   - этот признак для текущего вида документа стоит ЛОЖЬ
   DionisSergeevich
 
9 - 07.12.20 - 13:54
Значит есть шаблон, где ведётся учёт сторон. Отладчиком нужно подключаться к веб сервису
   Юзер123
 
10 - 07.12.20 - 14:44
(9) спс

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.