Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

HTTP сервисы 1С через CentOS и Apache 2.2

HTTP сервисы 1С через CentOS и Apache 2.2
Я
   fantomrik
 
03.12.20 - 18:22
Коллеги, привет!

Когда то делал http сервисы, но веб сервер стоял на машине, где и 1С.
Сейчас 1С в обном месте, а веб сервер поднят администратором в другом, на CentOS и Apache 2.2
Доступ просто к базе по веб есть. Но я не понимаю, после создания http сервисов, как их опубликовать?
Просто после обновления базы они не работают, а в конфигураторе доступа к "Опубликовать" нет, так как вебсервер на другой машине.
Подскажите пожалуйста, кто сталкивался.
   ДенисЧ
 
1 - 03.12.20 - 18:25
руками vrd поправить - не предлагать?
   fantomrik
 
2 - 03.12.20 - 18:33
(1) А есть информация где он лежит и что там нужно править в нем?
   Cyberhawk
 
3 - 03.12.20 - 18:41
webinst
   ansh15
 
4 - 03.12.20 - 19:06
>> так как вебсервер на другой машине
На той же машине установить серверную часть платформы(клиент не нужен), запускать ничего не надо.
А дальше - (3)
   fantomrik
 
5 - 03.12.20 - 19:12
(3) После каждого изменения сервисов, нужно через него публиковать сервисы заного? Или единожды публикуются?
   Uragan_a
 
6 - 04.12.20 - 02:06
   fantomrik
 
7 - 04.12.20 - 20:43
Коллеги, все заработало, спасибо!
А подскажите по отладке по http, в конфигураторе для отладки надо выбрать отладка по http и указать адрес web сервера моего на CentOS или адрес сервера 1с?
Чет и так и так пробовал, ошибка "не удалось соединиться с сервером отладки"
   fantomrik
 
8 - 04.12.20 - 20:55
Указал в конфигураторе - использовать локальный сервер отладки, указал ip сетевой карты и порт 4000. В браузере если перехожу по ip:4000 то вижу 1C:Enterprise 8.3 Debug Server (8.3.10.2580) © 1C-Soft LLC 1996-2017 - it works!
Но если дергаю какой то http сервис через postman, ответ приходит, но в процедуре сервиса точка останова не действует. В конфигураторе Отладка -Подключение - автоматическое подключение все галки поставил.
   fantomrik
 
9 - 05.12.20 - 10:00
Подниму тему
   fantomrik
 
10 - 07.12.20 - 11:52
Может в понедельник епоявились знающие?)
   fantomrik
 
11 - 10.12.20 - 13:21
Камрады, помогите, как включить отладку HTTP когда конфигуратор на одной машине, сервер 1С на другой под виндовс, веб сервер апач на 3ей машине под CentOS?
НА сервер 1С отладка в служюе включена -debug -http, на веб сервере в default.vrd прописал откладку
<?xml version="1.0" encoding="UTF-8"?>
<point xmlns="http://v8.1c.ru/8.2/virtual-resource-system";
    xmlns:xs="http://www.w3.org/2001/XMLSchema";
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance";
    base="/utkink"
    ib="Srvr=***.spb.ru:1541;Ref=UT_***;">
     <debug enable="true"
            url="***.spb.ru:1541:1541"/>
  <standardOdata enable="false"
      reuseSessions="autouse"
      sessionMaxAge="20"
      poolSize="10"
      poolTimeout="5"/>
</point>
В конфигураторе пробовал вкл http откладку и с указанием севрера отладки ***.spb.ru:1541, и с ip своей сетьевой карты - не удается подклюситься к серверу отладки...
   arsik
 
12 - 10.12.20 - 14:08
У службы 1С параметр -debug то установил?
   fantomrik
 
13 - 10.12.20 - 14:10
(12) Да, обычная серверная отладка работает, но как http сделать отладку не могу понять ни как
   arsik
 
14 - 10.12.20 - 14:11
Так тебе нужно  ***.spb.ru:4000
   arsik
 
15 - 10.12.20 - 14:11
Или даже так  http://***.spb.ru:1541
   arsik
 
16 - 10.12.20 - 14:12
   fantomrik
 
17 - 10.12.20 - 14:16
(16) в default.vrd?

<debug enable="true"
            url="http://***.spb.ru:4000"/>;

И почему 4000порт?
   arsik
 
18 - 10.12.20 - 14:22
Ну суть там такая.
На вебсервере (http://***.spb.ru) публикуешь сервер отладки на 4000 порту, на сервере приложения 1с указываешь что сервер отладки находится на http://***.spb.ru:4000.
При отладке из конфигуратора указываешь что сервер отладки на http://***.spb.ru:4000
   arsik
 
19 - 10.12.20 - 14:25
По сути http://***.spb.ru:4000 будет у тебя прокладкой между сервером приложения и конфигуратором
   fantomrik
 
20 - 10.12.20 - 14:28
(18) Так, мне получется надо в default.vrd исправить порт на 4000

<debug enable="true" url="http://***.spb.ru:4000"/>;;

на вебсервере перезапустить апатч и в конфигураторе ппрописать http подключение через http://***.spb.ru:4000 ? Все верно понял?
   fantomrik
 
21 - 10.12.20 - 14:29
(19) Тут http://catalog.mista.ru/1c/articles/303420/ просто указан адрес сервера без портов в default.vrd
   arsik
 
22 - 10.12.20 - 14:35
   fantomrik
 
23 - 11.12.20 - 23:00
Вобщем может читал плохо, может чего то не то делал, но сейчас завел методом тыка и со словами е.. твою м...
Отпишусь, возможно кому то пригодится.

На сервере 1С просто должна быть включена отладка -debug
"C:\Program Files\1cv8\8.3.10.2580\bin\ragent.exe" -srvc -agent -regport 1541 -port 1540 -range 1560:1591 -d "C:\Program Files\1cv8\srvinfo" -debug
до этого прописывал
"C:\Program Files\1cv8\8.3.10.2580\bin\ragent.exe" -srvc -agent -regport 1541 -port 1540 -range 1560:1591 -d "C:\Program Files\1cv8\srvinfo" -debug -http
и с таким ключом не работало у меня ни как.

На веб сервере на CentOS в default.vrd 

<?xml version="1.0" encoding="UTF-8"?>
<point xmlns="http://v8.1c.ru/8.2/virtual-resource-system";
    xmlns:xs="http://www.w3.org/2001/XMLSchema";
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance";
    base="/utkink"
    ib="Srvr=***.spb.ru:1541;Ref=UT;">
     <debug enable="true" protocol="tcp" url="***.spb.ru:1541"/>
  <standardOdata enable="false"
      reuseSessions="autouse"
      sessionMaxAge="20"
      poolSize="10"
      poolTimeout="5"/>
</point>

С параметром protocol="http" у меня не взлетело тоже почему то.

Ну и на локальной машине в конфигураторе Сервис - Параметры - Отладка - Отладка по протоколу TCP/IP и в Отладка - Подключение - Автоматическое подключение - HTTP сервисы.

Я изначально пытался во всехз местах настроить отладку с параметрами HTTP и не вышло, а на TCP все заработало.
Спасибо всем за помощь!


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.