Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Запись табличного объекта в файл

Запись табличного объекта в файл
Я
   FoxPilot
 
03.12.20 - 15:32
&НаСервере
Процедура НастройкиСохранитьФайлСервер(ИмяФайлаНастроек)    
    
    Настройки = Новый Соответствие;
    
    Настройки.Вставить("Партнер",Объект.Партнер);
    Настройки.Вставить("ВидЦенНоменклатурыПродажи",Объект.ВидЦенНоменклатурыПродажи);
    Настройки.Вставить("ВидЦенНоменклатурыПродажи",Объект.ВидЦенНоменклатурыЗакупочная);
    Настройки.Вставить("ФайлПутьКФайлу",Объект.ФайлПутьКФайлу);
    Настройки.Вставить("СпособНахожденияГрупп",Объект.СпособНахожденияГрупп);
    Настройки.Вставить("мегапрайсВалютаНаходитсяВКолонкеСЦеной",Число(Объект.мегапрайсВалютаНаходитсяВКолонкеСЦеной));
    Настройки.Вставить("НастройкиКолонокЛиста",Объект.НастройкиКолонокЛиста.Выгрузить());
    Настройки.Вставить("НастройкаПоиска",Объект.НастройкаПоиска.Выгрузить());
    Настройки.Вставить("ТаблицаЛистовФайла",Объект.ТаблицаЛистовФайла.Выгрузить());
    Настройки.Вставить("АлгоритмыКлючевыхСлов",Объект.АлгоритмыКлючевыхСлов.Выгрузить());
    
    Если Не ЗначениеВФайл(ИмяФайлаНастроек,Настройки) Тогда
        Сообщить("НЕ Записала");    
    КонецЕсли;
    
КонецПроцедуры

&НаКлиенте
Процедура НастройкиСохранитьФайл(Команда)    
    
    ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Сохранение);
    ДиалогОткрытияФайла.ПолноеИмяФайла = ?(ЗначениеЗаполнено(ИмяФайлаНастроек),ИмяФайлаНастроек,"МЗД_Настройки "+глУбратьСимволыСтроки(Объект.Партнер));
    ДиалогОткрытияФайла.Фильтр = "Файлы TXT|*.txt|Все файлы|*.*";
    ДиалогОткрытияФайла.МножественныйВыбор = Ложь;
    ДиалогОткрытияФайла.Заголовок = НСтр("ru = 'Выберите файл настроек'");
    
    Если ДиалогОткрытияФайла.Выбрать() Тогда
        ИмяФайлаНастроек = ДиалогОткрытияФайла.ПолноеИмяФайла;
        Сообщить(ИмяФайлаНастроек)    ;
        
    КонецЕсли;
       НастройкиСохранитьФайлСервер(ИмяФайлаНастроек);
      
КонецПроцедуры
   FoxPilot
 
1 - 03.12.20 - 15:32
Не записывает в файл.
   ДенисЧ
 
2 - 03.12.20 - 15:35
Я бы тоже не сохранял.
Файл ты выбираешь на клиенте, а записываешь на сервере...
   Малыш Джон
 
3 - 03.12.20 - 15:35
Сообщения с неизвестного номера:

Овощи
Яйца
Хлеб
Сыр
Чай
      Что это?? Вы кто??

Отстань, не мешай.
   FoxPilot
 
4 - 03.12.20 - 15:36
Так там же значение передается на сервер
   FoxPilot
 
5 - 03.12.20 - 15:37
Вообще все работало пока 1с не обновили
   FoxPilot
 
6 - 03.12.20 - 15:38
Не хочет записывать объект типа Соответствие
   youalex
 
7 - 03.12.20 - 15:40
(6) Так и говорит? Не хочу, мол
   Kassern
 
8 - 03.12.20 - 15:42
(6) Записывайте во временный файл на стороне сервера, двоичные данные этого файла возвращайте на клиент через временное хранилище, далее их уже сохраняйте на клиенте куда нужно. Не получается соответствием, попробуйте структурой. Судя по ключам, разницы для вас никакой не будет.
Если сервер не имеет доступа к файлу сохранения, то ваш код, в не зависимости от содержания записи, не даст записаться.
   МихаилМ
 
9 - 03.12.20 - 15:52
Сообщить на сервере не работает.
   Kassern
 
10 - 03.12.20 - 15:53
(9) Да ладно?
Доступность:
Тонкий клиент, веб-клиент, мобильный клиент, сервер, толстый клиент, внешнее соединение, мобильное приложение (клиент), мобильное приложение (сервер), мобильный автономный сервер.
   ДенисЧ
 
11 - 03.12.20 - 15:54
(9) Давно? Наверное, уже пару часов как... Новую платформу, что ли, выпустили?
   kzot
 
12 - 03.12.20 - 16:14
наверно когда ларьки разогнали и ввели стандарты... ну и после #std418

Ограничение на использование метода Сообщить
Область применения: управляемое приложение.
Для вывода сообщений пользователю во всех случаях следует использовать объект СообщениеПользователю, даже когда сообщение не «привязывается» к некоторому элементу управления формы. Метод Сообщить применять не следует.

кошерно так.
   ДенисЧ
 
13 - 03.12.20 - 16:16
(12) "Следует использовать" и "не работает" - это две большие разницы, как говорят кошерные (с) раввины.
   mikecool
 
14 - 03.12.20 - 16:17
Маня новый акк завел?
   trooba
 
15 - 03.12.20 - 16:41
(0)      Сообщить("НЕ Записала");   Огонь батарея, огонь батальон
   FoxPilot
 
16 - 03.12.20 - 16:43
Здесь на форуме только хамить умеют. Или есть кто может помочь. Я не программист 1с. Когда-то занимался писал коды. Этот код из внешней обработки. Он работал пока не обновили платформу 1с.
Сообщить как раз работает и выдает сообщение выдает. А вот структуру не записывает.
   FoxPilot
 
17 - 03.12.20 - 16:44
Если вы такие крутые программисты помогите разобраться пожалуйста.
   youalex
 
18 - 03.12.20 - 16:46
опять нейронка? ну, уже почти)
   Малыш Джон
 
19 - 03.12.20 - 16:50
(12) страшно представить на что способны разогнанные ларьки, если после этого запретили "Сообщить" на сервере
   runoff_runoff
 
20 - 03.12.20 - 16:50
(17) в (8) ответ
   acht
 
21 - 03.12.20 - 16:52
(16) Это же форум о политике и утренней зарядке, помилуйте!
   FoxPilot
 
22 - 03.12.20 - 16:52
Ну я так и думал
   Малыш Джон
 
23 - 03.12.20 - 16:53
(22) ну тут вся помощь в формате Sapienti sat
   FoxPilot
 
24 - 03.12.20 - 16:54
Хамить у нас в стране все умею. Или человека помоями облить. Это же проще
   acht
 
25 - 03.12.20 - 16:57
(24) Продемонстируете?
Вот сюда вот загляните, это вам точно поможет - https://1c.ru/cso-part/rus/partners/training/cso/course?id=127
Ну если, конечно, начальная подготовка позволит.
   kzot
 
26 - 03.12.20 - 16:58
(24) запускаете в толстом клиенте ?
   Малыш Джон
 
27 - 03.12.20 - 16:59
(24) сначала лучше вот сюда заглянуть: https://forum.mista.ru/rules.php#rec
   trooba
 
28 - 03.12.20 - 17:02
(16) Скорее всего не только платформу обновили, но и вместо толстого клиента в тонком запускаетесь, вот и вся отрыжка
   trooba
 
29 - 03.12.20 - 17:03
(26) +1
   FoxPilot
 
30 - 04.12.20 - 09:53
Спасибо  Kassern ваша схема сработала данные сохранил.
 
 


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.