Вход | Регистрация
 

Остатки в УНФ 1,6

Остатки в  УНФ 1,6
Я
   Tarlich
 
03.12.20 - 12:09
В форме списка и в форме подбора информация выводится (в ДС ) из РегистраСведений.ОстаткиТоваров
Возможно из за РиБ или еще чего то есть расхождения с действительностью...
Кто знает как и по каким условиям (расписанию) данный РС перезаполняется?
   Tarlich
 
1 - 03.12.20 - 12:16
Прикольно!

    Для разных режимов по разному :
    Если ОбщегоНазначения.ИнформационнаяБазаФайловая() Тогда
            Запрос.Текст = ТекстЗапросаФайловыйРежим();
        Иначе
            Запрос.Текст = ТекстЗапросаКлиентСерверныйРежим();
    КонецЕсли;
   ИС-2
 
2 - 03.12.20 - 12:27
(1) мда. Жесть что одинэсники удумали
   Галахад
 
3 - 03.12.20 - 12:30
(1) Запросы в студию.
   Tarlich
 
4 - 03.12.20 - 12:32
Расскопал !!!! все проще оказалось -))
в менеджере рег есть ВыполнитьЗаданиеПоЗаписиОстатковВТехническийРегистр()
Посмотрел от куда вызывается 
Форма\Еще\ОбновитьОстатки
   Tarlich
 
5 - 03.12.20 - 12:42
Во избежания ошибок - Сделаю обработку и буду раз в час запускать ....
   Tarlich
 
6 - 03.12.20 - 13:07
Мало ли комУ :

Функция СведенияОВнешнейОбработке() Экспорт
    
    ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке("2.2.2.1");
    ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиДополнительнаяОбработка();
    ПараметрыРегистрации.БезопасныйРежим = Ложь;
    
    НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
    
    //представление команды в пользовательском режиме

    НоваяКоманда.Представление = "ОбновлениеОстатков";
    НоваяКоманда.Идентификатор = НоваяКоманда.Представление;
    НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();
    
    Возврат ПараметрыРегистрации;
    
КонецФункции



Функция ВыполнитьКоманду(ИдентификаторКоманды, ПараметрыКоманды) Экспорт
    
    Если ИдентификаторКоманды = "ОбновлениеОстатков" Тогда
        Рез =   РегистрыСведений.ОстаткиТоваров.ВыполнитьЗаданиеПоЗаписиОстатковВТехническийРегистр();
    КонецЕсли;
    
КонецФункции
   Злопчинский
 
7 - 03.12.20 - 16:24
(0) хм... а нахрена из регистра накоплений 9остатки там ведь хранятся), перекидывать в РС..? в чем смысл? какой профит? или я что-то не тк понимаю?
   hhhh
 
8 - 03.12.20 - 18:03
(7) вроде было такое. В УТ расчет себестоимости запускается в закрытие месяца. Но чтобы в отчетах не было нулей, используют регистр сведений Предварительная себестоимость. То есть сам РН заполняется в конце месяца.
   Злопчинский
 
9 - 03.12.20 - 18:11
в УНФ РН "ЗапасыНаСкладах" - только количество
было бы интересно откуда РегистраСведений.ОстаткиТоваров данными заполняется..?

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.