Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Чеки ККМ по отделам в 1С 7.7

v7: Чеки ККМ по отделам в 1С 7.7
Я
   zenon46
 
01.12.20 - 17:12
Доброго дня!
С НГ организация переходит на патент, причем на 2 один на торговлю другой на услуги. Вопрос : можно ли при этом использовать одну ККМ ? Сможет ли ККМ делать закрытие смены с итогом по каждому отделу (патенту) ?
   zenon46
 
1 - 01.12.20 - 18:23
Еще один вопрос какой код в ПУП передавать при пробитии чека ?
   victuan1
 
2 - 02.12.20 - 07:09
(0)
Одну ККМ можно использовать, разделить чеки по разным номерам отделов. Перед закрытием смены (Z-отчетом) можно печатать Отчет по отделам, который выдаст нужную аналитику.
   Kigo_Kigo
 
3 - 02.12.20 - 08:35
Объект.Department        = НомерСекции;
   Kigo_Kigo
 
4 - 02.12.20 - 08:44
Для штрихов
Функция ЗакрытьСмену(Объект, Пароль, НомерЛенты)
    Рез = 0;
    
    Если ПустоеЗначение(Объект) = 1 Тогда
        ОписаниеРезультата = "устройство не подключено";
    ИначеЕсли ПодключитьсяКФР(Объект, Пароль) = 1 Тогда
        // переключение в режим снятия отчета (нужен пароль администратора)

        Объект.Password = Пароль;
                Объект.PrintDepartmentReport();
                Объект.Password = Пароль;

        Объект.PrintReportWithCleaning();

        Если Объект.ResultCode <> 0 Тогда
            ОписаниеРезультата = ПолучитьОписаниеРезультата(Объект);
            ОтключитьсяОтФР(Объект, Пароль, 0);
            Возврат 0;
        КонецЕсли;

        Объект.Password = Пароль;
        Объект.GetECRStatus();
            
        Если Объект.ResultCode <> 0 Тогда
            ОписаниеРезультата = ПолучитьОписаниеРезультата(Объект);
            ОтключитьсяОтФР(Объект, Пароль, 0);
            Возврат 0;
        КонецЕсли;
        
        НомерЛенты = Объект.SessionNumber+?(Объект.ECRAdvancedMode=5,1,0);

        ОтрезатьЧек(Объект, Пароль);

        Рез = ОтключитьсяОтФР(Объект, Пароль); 
    КонецЕсли;
    
    Возврат Рез;
КонецФункции
   zenon46
 
5 - 02.12.20 - 09:14
(4) смена закрывается через драйвер. сам аппарат ведь выведет итог по номерам секции при закрытии ?
   Kigo_Kigo
 
6 - 02.12.20 - 09:55
(5) При регистрации каждой позиции товара при робитии чека, тебе надо в поле
Объект.Department  = писать номер секции,(1 или 2)

 при закрытии смены я тебе написал код в (4), где с начала у тебя выйдет отчет по секциям

команда
Объект.Password = Пароль;
                Объект.PrintDepartmentReport();

патом закроется смена (Z-отчет)

 Объект.Password = Пароль;

        Объект.PrintReportWithCleaning();



я отлично помню, что есть настройка, выводить (Z-отчет) по секциям, и это работало когда то у кого то, НО в штрих-онлайне я не нашел ее, по этому просто сделал как в (4)
   zenon46
 
7 - 02.12.20 - 10:20
(6) посмотрел стандартное закрытие в обработке у атола другие методы, нужно курить..
   Kigo_Kigo
 
8 - 02.12.20 - 12:08
(7) там что то типОтчета или вид отчета
Надо с начала 7, потом 1
   Kigo_Kigo
 
9 - 02.12.20 - 12:15
Если ПодключитьсяКФР(Объект) = 1 Тогда    
        
        НомерЛенты = Число(Объект.Session) + 1;
        // если смена открыта снимаем Z-отчет

        Если Объект.SessionOpened <> 0 тогда
            // устанавливаем пароль системного администратора ККМ

            Объект.AttrValue = Кассир;
            Объект.AttrNumber = 1021;
            Объект.WriteAttribute();
                   
            Объект.Password = ПарольАдминистратора;

            Объект.Mode = 3;
            Если Объект.SetMode() = 0 тогда
                // снимаем отчет

                Объект.ReportType = 7;
                Если Объект.Report() = 0 тогда
                    Рез = 1;
                КонецЕсли;
            КонецЕсли;

            
            // входим в режим отчетов с гашением

            Объект.Mode = 3;
            Если Объект.SetMode() = 0 тогда
                // снимаем отчет

                Объект.ReportType = 1;
                Если Объект.Report() = 0 тогда
                    Рез = 1;
                КонецЕсли;
            КонецЕсли;
        КонецЕсли;
    КонецЕсли;

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.