Вход | Регистрация
 

Развернуть группировки в таблице с источником динамический список.

Развернуть группировки в таблице с источником динамический список.
Я
   Сметанин
 
01.12.20 - 16:52
Приветствую.

Есть таблица на форме, источник данных - динамический список. У ДС создана группировка. Нужно чтобы при открытии формы раскрывались группировки.
Есть метод Элементы.Таблица.Развернуть(ИД). Но вот как получить идентификаторы строк - корней?
   spiller26
 
1 - 01.12.20 - 17:18
(0) Перебором по верхушкам.
   spiller26
 
2 - 01.12.20 - 17:18
Если точнее рекурсией.
   spiller26
 
3 - 01.12.20 - 17:20
&НаКлиенте
Процедура СвернутьДеревоПоиск()
    
    НайденоПоиском = 0;
    
    Состояние("Сворачивание дерева",,, БиблиотекаКартинок.ДлительнаяОперация48);
    
    КоллекцияЭлементов = ДеревоОстатков.ПолучитьЭлементы();
    Для Каждого ЭлементКоллекции Из КоллекцияЭлементов Цикл
        ВлЭлементКоллекции = ЭлементКоллекции.ПолучитьЭлементы();
        Если ВлЭлементКоллекции.Количество() > 0 Тогда
            Сворачивать = Истина;    
            Для Каждого ВлЭл Из ВлЭлементКоллекции Цикл
                СтрКомментарий = ВлЭл.Комментарий;
                Если СтрНайти(СтрКомментарий, СокрЛП(ПоискКоментарий)) > 0 Тогда
                    Сворачивать = Ложь;    
                    ВлЭл.Красим = Истина;
                    НайденоПоиском = НайденоПоиском + 1;
                КонецЕсли;    
            КонецЦикла;
            Если Сворачивать Тогда
                Элементы.ДеревоОстатков.Свернуть(ЭлементКоллекции.ПолучитьИдентификатор());
            Иначе
                Элементы.ДеревоОстатков.Развернуть(ЭлементКоллекции.ПолучитьИдентификатор(), Истина);
            КонецЕсли;    
        КонецЕсли;    
    КонецЦикла;    
    
    ОбщегоНазначенияКлиентСервер.СообщитьПользователю("Найдено = " + ?(НайденоПоиском = 0, "НИЧЕГО", Формат(НайденоПоиском, "ЧЦ=3")));//сообщение пользователю


КонецПроцедуры
   spiller26
 
4 - 01.12.20 - 17:20
Но можно и без неё.
   Fragster
 
5 - 01.12.20 - 17:21
свойства элемента формы "НачальноеОтображениеДерева"
   spiller26
 
6 - 01.12.20 - 17:23
Вот тебе, если нужно раскрыть или нет, при открытии
    Элементы.ДеревоОстатков.НачальноеОтображениеДерева = НачальноеОтображениеДерева.РаскрыватьВсеУровни;
    Элементы.ДеревоОстатков.НачальноеОтображениеДерева = НачальноеОтображениеДерева.НеРаскрывать;
   Сметанин
 
7 - 01.12.20 - 17:37
(6) У меня свойство отображение - иерархический список и эти свойства не работают.
   Сметанин
 
8 - 01.12.20 - 17:41
поменял на дерево - работает. спасибо а то я что-то на ровном месте застрял
   Fragster
 
9 - 01.12.20 - 17:52
(6) это на панели свойств есть

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.