Вход | Регистрация
 

ошибку при вызове клиент-сервер: Отсутствует отображение для типа 'ДанныеФормыЭлементКоллекции'

[Волшебник, 01.12.20 - 10:54]
ошибку при вызове клиент-сервер: Отсутствует отображение для типа 'ДанныеФормыЭлементКоллекции'
Я
   aleks100
 
01.12.20 - 09:34
выдает ошибку при вызове функции ТЗДополнительныеСведенияПриОкончанииРедактированияНаСервере(СтрокаКоллекции);  не могу понять почему, мне надо изменить данные регистра ДополнительныеСведения при изменения данных в таблице

  
&НаСервереБезКонтекста
Процедура ТЗДополнительныеСведенияПриОкончанииРедактированияНаСервере(ТекущаяСтрока)
    // Вставить содержимое обработчика.
    ТекСтрока =  ТекущаяСтрока;
    
    Если ТекСтрока.НаименованиеДопСведения <> Справочники.ЗначенияСвойствОбъектов.ПустаяСсылка() Тогда                  
            НаборЗаписей = РегистрыСведений.ДополнительныеСведения.СоздатьНаборЗаписей();
            НаборЗаписей.Отбор.Объект.Установить(ТекСтрока.Начисление);
            НаборЗаписей.Отбор.Свойство.Установить(ТекСтрока.ДопСведение);  
            
            
            НоваяЗапись = НаборЗаписей.Добавить();                            
            НоваяЗапись.Объект  = ТекСтрока.Начисление;                       
            НоваяЗапись.Свойство = ТекСтрока.ДопСведение;                     
            НоваяЗапись.Значение = ТекСтрока.НаименованиеДопСведения;                 
            
            // Записать набор записей с замещением старого, соответствующего той же грануле
            
            НаборЗаписей.Записать();                                                   
            
    КонецЕсли;

КонецПроцедуры

&НаКлиенте
Процедура ТЗДополнительныеСведенияПриОкончанииРедактирования(Элемент, НоваяСтрока, ОтменаРедактирования)    
    СтрокаКоллекции = ТЗДополнительныеСведения.НайтиПоИдентификатору(Элементы.ТЗДополнительныеСведения.ТекущаяСтрока);
    стр = СтрокаКоллекции.начисление;
    
    ТЗДополнительныеСведенияПриОкончанииРедактированияНаСервере(СтрокаКоллекции);  
    
    
КонецПроцедуры
 
 Партнерская программа EFSOL Oblako
   ДенисЧ
 
1 - 01.12.20 - 09:45
С тебя 100 евро и я не буду тыкать тебя носом в ошибку
   spiller26
 
2 - 01.12.20 - 10:19
(0) Ошибка то какая?
   acht
 
3 - 01.12.20 - 10:20
(2) При вызове. Что непонятного? =)
   Волшебник
 
4 - 01.12.20 - 10:20
Тема не отражает суть сообщения.
Текст ошибки не представлен
   spiller26
 
5 - 01.12.20 - 10:32
(3) Вот тут и непонятно. Тупо "не работает". :(
   spiller26
 
6 - 01.12.20 - 10:33
Может человек сам осознает свою ошибку
   aleks100
 
7 - 01.12.20 - 10:44
Ошибка отображения типов:
Отсутствует отображение для типа 'ДанныеФормыЭлементКоллекции'
{ВнешняяОбработка.ДополнительныеСведенияДляНачислений.Форма.Форма.Форма(412)}:    ТЗДополнительныеСведенияПриОкончанииРедактированияНаСервере(СтрокаКоллекции);  

по причине:
Ошибка передачи данных между клиентом и сервером. Значение недопустимого типа.
по причине:
Ошибка преобразования данных XDTO:
Запись значения свойства 'param':
    форма: Элемент
    имя: {http://v8.1c.ru/8.2/managed-application/modules}param
по причине:
Ошибка отображения типов:
Отсутствует отображение для типа 'ДанныеФормыЭлементКоллекции'
   aleks100
 
8 - 01.12.20 - 10:45
такую ошибку выдает в строке  
ТЗДополнительныеСведенияПриОкончанииРедактированияНаСервере(СтрокаКоллекции);
   acht
 
9 - 01.12.20 - 10:46
Здесь написано, что СтрокаКоллекции имеет тип, который нельзя передавать между клиентом и сервером.
   acht
 
10 - 01.12.20 - 10:48
Передавай через какую-нибудь структуру или сделай контекстный вызов
   aleks100
 
11 - 01.12.20 - 10:50
контекстный вызов не могу сделать для данного события, а как через структуру передать?  или определить  параметр для формы
   aleks100
 
12 - 01.12.20 - 10:51
такое прочитал
При вызове процедуры или функции под директивой «&НаСервереБезКонтекста» из формы со стороны клиента происходит передача на сторону сервера только тех данных, которые были указаны в качестве параметров. Обратно же передаётся только необходимая информация в уже подготовленном виде.
Таким образом, серверный вызов не несёт лишней нагрузки, и для передачи данных между клиентом и сервером потребуется меньше ресурсов.
   acht
 
13 - 01.12.20 - 10:53
Создать, присвоить значения, передать. Впрочем у тебя всего три значения, можно передать их непосредственно каждое.
   aleks100
 
14 - 01.12.20 - 11:16
а примерный код?
   acht
 
15 - 01.12.20 - 11:21
   aleks100
 
16 - 01.12.20 - 11:45
спасибо

Список тем форума
 
Читай всё полезное и впитывай, а нападки игнорируй. Здесь так принято. aka AMIGO
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.