Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

ОбработкаРасшифровки.Выполнить() - Метод контекста недоступен

ОбработкаРасшифровки.Выполнить() - Метод контекста недоступен
Я
   PuhUfa
 
30.11.20 - 16:07
Есть произвольная форма отчета. У формы есть реквизит ТабличныйДокументОжиданиеЗаписи Тип ТабличныйДокумент. Есть связанный с ним элемент формы. Есть реквизит формы ДанныеРасшифровкиОжиданиеЗаписиURL Тип Строка. Есть СКД - ЛистыОжиданияЗаписи.
И есть следующий код:

&НаСервере
Процедура СформироватьОжиданиеЗаписи()
    
    //ОСКД = Отчеты.КалендарьПланирования.ПолучитьМакет("ЛистыОжиданияЗаписи");
    ОСКД = РеквизитФормыВЗначение("Отчет").ПолучитьМакет("ЛистыОжиданияЗаписи");

    НастройкиОСКД = ОСКД.НастройкиПоУмолчанию;
        
    ПараметрыДанныхОСКД = НастройкиОСКД.ПараметрыДанных.Элементы;
    КомпоновщикМакетаОСКД = Новый КомпоновщикМакетаКомпоновкиДанных;

    ДанныеРасшифровки1 = Неопределено;
    Макет = КомпоновщикМакетаОСКД.Выполнить(ОСКД, НастройкиОСКД, ДанныеРасшифровки1);

    ПроцессорКомпоновкиОСКД = Новый ПроцессорКомпоновкиДанных;

    ПроцессорКомпоновкиОСКД.Инициализировать(Макет,,ДанныеРасшифровки1);
    
    ДанныеРасшифровкиОжиданиеЗаписиURL = ПоместитьВоВременноеХранилище(ДанныеРасшифровки1,ЭтаФорма.УникальныйИдентификатор);
    
    ТабличныйДокументОжиданиеЗаписи.Очистить();

    ПроцессорВыводаОСКД = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;

    ПроцессорВыводаОСКД.УстановитьДокумент(ТабличныйДокументОжиданиеЗаписи);

    ПроцессорВыводаОСКД.Вывести(ПроцессорКомпоновкиОСКД);    
    
    ТабличныйДокументОжиданиеЗаписи.ОтображатьСетку = Ложь;
    ТабличныйДокументОжиданиеЗаписи.ТолькоПросмотр = Истина;
    ТабличныйДокументОжиданиеЗаписи.ОтображатьЗаголовки = Ложь;
    
КонецПроцедуры

Тут все хорошо и на форме отчет формируется как надо.
Проблема с его расшифровкой. Расшифровка организована так:

&НаКлиенте
Процедура ТабличныйДокументОжиданиеЗаписиОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;
    
    ОбработкаРасшифровки = Новый ОбработкаРасшифровкиКомпоновкиДанных(ДанныеРасшифровкиОжиданиеЗаписиURL, Новый ИсточникДоступныхНастроекКомпоновкиДанных(ПолучитьИсточникДоступныхНастроекКомпоновкиДанных()));

    МассивДоступныхДействий = Новый Массив;
    МассивДоступныхДействий.Добавить(ДействиеОбработкиРасшифровкиКомпоновкиДанных.ОткрытьЗначение);

    НастройкиРасшифровки = ОбработкаРасшифровки.Выполнить(Расшифровка,, МассивДоступныхДействий);
    
КонецПроцедуры

&НаСервере
Функция ПолучитьИсточникДоступныхНастроекКомпоновкиДанных()
    
    Возврат ПоместитьВоВременноеХранилище(РеквизитФормыВЗначение("Отчет").ПолучитьМакет("ЛистыОжиданияЗаписи"));
    
КонецФункции

При попытке расшифровать значение в отчете я получаю:
Ошибка при вызове метода контекста (Выполнить)
    НастройкиРасшифровки = ОбработкаРасшифровки.Выполнить(Расшифровка,, МассивДоступныхДействий);
по причине:
Метод контекста недоступен.
Отладчик говорит, что ОбработкаРасшифровки есть.
https://i.ibb.co/q7S9c2N/2020-11-30-180250.png

Не соображу куда еще копнуть. Подскажите.
   vicof
 
1 - 30.11.20 - 16:14
ОбработкаРасшифровкиКомпоновкиДанных (DataCompositionDetailsProcess)
Выполнить (Execute)
....
Доступность:
Толстый клиент.
   PuhUfa
 
2 - 30.11.20 - 16:16
(1) Блин... а я еще голову ломаю, что у меня в СП не выводит его. Спс
   PuhUfa
 
3 - 30.11.20 - 16:27
Переделал через: ОбработкаРасшифровки.ВыбратьДействие(
Теперь все как надо. Еще раз СПС!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.