Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Расширения &Перед и &После одновременно

Расширения &Перед  и &После  одновременно
Я
   folo
 
26.11.20 - 13:51
Добрый день.
Есть ли хитрая возможность задать в расширении одновременно &Перед и &После для одной и той же процедуры.
В лоб - программа ругается на дублирование процедуры в расширении.
Делать &вместо не хочется, нужна пара строк до и после а не запихивать сотни строк типовой процедуры.
Кто нибудь сталкивался ?
   Timon1405
 
1 - 26.11.20 - 13:53
можно сделать в двух расширениях)
   folo
 
2 - 26.11.20 - 13:55
Догадался, но думал есть более красивое решение
   singlych
 
3 - 26.11.20 - 13:56
&Вместо("Процедура")
Процедура Расш_Процедура(Параметр)

    // твой код до


    ПродолжитьВызов(Параметр);

    // твой код после


КонецПроцедуры
   folo
 
4 - 26.11.20 - 13:58
(3) Спасибо. Хорошая идея. Ща протестим.
   Жан Пердежон
 
5 - 26.11.20 - 14:01
(0) штатная возможность, ничего не ругается
   Жан Пердежон
 
6 - 26.11.20 - 14:01
&Перед("ТвояПроцедура")
Процедура Расш1_ТвояПроцедура(Параметр)
    // Вставить содержимое метода.

КонецПроцедуры

&После("ТвояПроцедура")
Процедура Расш1_ТвояПроцедура1(Параметр)
    // Вставить содержимое метода.

КонецПроцедуры
   Гипервизор
 
7 - 26.11.20 - 14:06
В 8.3.15 появилась аннотация &ИзменениеИКонтроль.
https://its.1c.ru/db/v8315doc#bookmark:dev:TI000002149
   folo
 
8 - 26.11.20 - 14:19
(6) Спасибо. Работает.Век живи, век учись.
   Garykom
 
9 - 26.11.20 - 14:29
(8) Не знал что нельзя дублировать (с одинаковым именем) процедуры в коде 1С?

Не догадался что ссылка на заменяемую процедуру (ее название) находится в аннотации?

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.