Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Внешняя обработка на форме документа, не доступна при установке даты запрета изменения

Внешняя обработка на форме документа, не доступна при установке даты запрета изменения
Я
   slnes
 
25.11.20 - 13:23
В модуле объекта внешней обработки сделал так

Функция СведенияОВнешнейОбработке() Экспорт  
  ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке("3.1.2.0");
  ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиЗаполнениеОбъекта();
  ..........

Установлена дата запрета редактирования.
Если документ позже даты запрета, все норм.
Если документ до даты запрета кнопка вызова обработки на форме не активна.
Обработка отправляет СМС, документ не изменяет.
Как сделать кнопку активной при установленной дате запрета?
   вым
 
1 - 25.11.20 - 13:25
(0) НЕ ВидОбработкиЗаполнениеОбъекта()
   вым
 
2 - 25.11.20 - 13:26
через печать сделай, там чуть другие параметры, но не страшно
   ГдеСобакаЗарыта
 
3 - 25.11.20 - 13:34
Лучше в расширении сделать
   slnes
 
4 - 25.11.20 - 13:45
(3) кнопку придется на форму добавлять, а потом контролировать при обновлении формы поставщиком конфигурации.
или как то по другому можно?
   ГдеСобакаЗарыта
 
5 - 25.11.20 - 14:03
Я так делаю

&НаСервере
Процедура Расш1_ПриСозданииНаСервереПосле(Отказ, СтандартнаяОбработка)
    
    КомандаСгенерироватьПароль = Команды.Добавить("СгенерироватьПароль");
    КомандаСгенерироватьПароль.Действие="СгенерироватьПароль";
    КомандаСгенерироватьПароль.Заголовок="Сгенерировать пароль";
    
    КнопкаГенераторПароля = Элементы.Добавить("ГенераторПароля", Тип("КнопкаФормы"), Элементы.ГруппаДополнительныеРеквизиты);
    КнопкаГенераторПароля.Вид = ВидКнопкиФормы.ОбычнаяКнопка;
    КнопкаГенераторПароля.Отображение = ОтображениеКнопки.Картинка;
    КнопкаГенераторПароля.Картинка = БиблиотекаКартинок.Обновить;
    КнопкаГенераторПароля.ИмяКоманды = "СгенерироватьПароль";
    
    
КонецПроцедуры

&НаКлиенте
Процедура СгенерироватьПароль(Команда)
    
    Если НЕ ПустаяСтрока(ФизическоеЛицо.Пароль) Тогда
        
        Оповещение = Новый ОписаниеОповещения("СгенирироватьПарольВопросЗавершение", ЭтотОбъект);
        
        ПоказатьВопрос(Оповещение, Нстр("ru = 'Пароль уже заполнен. Уверены что нужно сгенерировать новый?'"), РежимДиалогаВопрос.ДаНет, 10);
        
    Иначе
        СгенерироватьНовыйПароль();
    КонецЕсли;
    
КонецПроцедуры

&НаКлиенте
Процедура СгенирироватьПарольВопросЗавершение(Результат, ДополнителныеПараметры) Экспорт
    Если Результат = КодВозвратаДиалога.Да Тогда
        СгенерироватьНовыйПароль();
    КонецЕсли;
КонецПроцедуры
   slnes
 
6 - 25.11.20 - 14:14
Спасибо, так и сделаю, не хотел форму добавлять в расширение, но другого варианта нет похоже, главное если разраб изменит форму не забыть нажать обновить на форме после обновления конфы.

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.