Вход | Регистрация
 

Справочник на форме Список значений в хранилище

Справочник на форме Список значений в хранилище
Я
   Сибиряк_1Ц
 
25.11.20 - 00:36
1с 8.3. Справочник, на форме список значений, сохраняю в реквизит справочника (объекта) тип хранилище значений. Сохраняю, пытаюсь восстановить не получается(((
В модуле формы, записываю список значений в хранилище значений:
&НаСервере
Процедура ПриЗаписиНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
    ХЗ_Акция  = Новый ХранилищеЗначения(ЭтаФорма.СписокТоваров);
КонецПроцедуры
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    ПеремСписокЗначений = Объект.Ссылка.ХЗ_Акция.Получить();
КонецПроцедуры

Возвращает Неопределено((((
 
 Партнерская программа EFSOL Oblako
   youalex
 
1 - 25.11.20 - 01:54
ПередЗаписьюНаСервере

ТекущийОбъект.ТвойРек
   hhhh
 
2 - 25.11.20 - 01:54
(0) потому что записал в ХЗ_Акция, а читаешь совсем из другого места, из Ссылка.ХЗ_Акция ? Это же вообще разные переменные. В каком месте ты свою переменную ХЗ_Акция сохраняешь в реквизит справочника? Здесь не видно.
   Сибиряк_1Ц
 
3 - 26.11.20 - 16:16
(2) да. в справочнике создал реквизит "ХЗ_Акция" (тип значения хранилище), в него и сохраняю.
   Сибиряк_1Ц
 
4 - 26.11.20 - 16:58
(1,2) Спасибо, все Ок.
&НаСервере
Процедура ПриЗаписиНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
    ТекущийОбъект.ХЗ_Акция  = Новый ХранилищеЗначения(ЭтаФорма.СписокТоваров);
КонецПроцедуры
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    ПеремСписокЗначений = Объект.Ссылка.ПолучитьОбъект().ХЗ_Акция.Получить();
КонецПроцедуры

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.