Вход | Регистрация
 

УТ 10.3. Печать этикеток без штрих-кода возможно ?

УТ 10.3. Печать этикеток без штрих-кода возможно ?
Я
   Румата
 
24.11.20 - 15:25
Есть такой код :

Макет                   = ПолучитьОбщийМакет("ГлавнаяЭтикетка");


    Если ЗначениеЗаполнено(СтрокаИзСписка.Номенклатура.ШтрихКодПоставщика) Тогда
            ЭтикеткаОбласть.Рисунки.Штрихкод.Объект.ТипКода   = 1;
            ЭтикеткаОбласть.Рисунки.Штрихкод.Объект.Сообщение =СтрокаИзСписка.Номенклатура.ШтрихКодПоставщика;
        Иначе
    
            //ЭтикеткаОбласть.Рисунки.Штрихкод.Объект.ОтображатьТекст = Ложь;
            //ЭтикеткаОбласть.Рисунки.Штрихкод.Объект.ПрозрачныйФон = Истина;
            //ЭтикеткаОбласть.Рисунки.Штрихкод.Объект.Сообщение ="";
            //ЭтикеткаОбласть.Рисунки.Штрихкод.Объект.ТекстКода = "";
        КонецЕсли;    


Мне надо чтобы штрих код не выводился, если он не заполнен, а он все равно выводится на объекте Active-X. Возможно его не выводить ?
   d4rkmesa
 
1 - 24.11.20 - 15:34
(0) Он не выведется на печать, насколько я помню, если указать ЭтикеткаОбласть.Рисунки.ШтрихКод.ВыводитьНаПечать = Ложь. Но иногда проще просто удалить рисунок из табличного документа программно.
   Румата
 
2 - 24.11.20 - 15:37
(1) Я пробовал так :
ЭтикеткаОбласть.Рисунки.Штрихкод.ВыводитьНаПечать = Ложь;

Все равно выводится, штрих код вида 12345...

А как программно удалить рисунок из табличного документа ?
   d4rkmesa
 
3 - 24.11.20 - 15:42
(2) А просмотр печати смотрели? Не выводится там. Если нужно удалить, то можно удалить указав область рисунка(должна быть в коллекции областей табличного документа). Ну или так:
Процедура УдалитьШтрихКодПередВыводом(ОбластьИлиТабличныйДокумент, ИмяОбъектаЗаполнения = "Barcode") Экспорт    
    Попытка
        ЕстьBarcode = Ложь;        
        Для Каждого Рисунок Из ОбластьИлиТабличныйДокумент.Рисунки Цикл
            Если Не Рисунок.ТипРисунка = ТипРисункаТабличногоДокумента.Объект Тогда
                Продолжить
            КонецЕсли;            
            Если Рисунок.Имя = ИмяОбъектаЗаполнения Тогда
                ОбластьИлиТабличныйДокумент.Рисунки.Удалить(Рисунок);
            КонецЕсли;
        КонецЦикла;        
    Исключение
        Сообщить("Ошибка обработки штрих-кода", СтатусСообщения.Важное);
        Сообщить(ОписаниеОшибки());
    КонецПопытки;    
КонецПроцедуры
   Румата
 
4 - 24.11.20 - 15:49
(3) Спасибо, тупанул, в самом макете выводятся, а при печати пропадают ) Вопрос закрыт ! ;)

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.