Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Передача реквизита в табличной части документа в другой документ

Передача реквизита в табличной части документа в другой документ
Я
   lav151
 
24.11.20 - 10:58
Всем добрый день! Помогите пожалуйста решить задачу.

1С:Предприятие 8.3 (8.3.16.1148)
БСП (3.1.3.276)

Имеется два документа: Рейс и Заявка.
В Рейсе есть табличная часть "Направление" состоит из реквизитов: Заявка (ссылка на заявку) и Суммы.

Нужно чтобы при проведении документа Рейс, реквизит Сумма из табличной части, попадал в реквизит документа Заявки.
   Fish
 
1 - 24.11.20 - 11:01
И что не получается?
   RomanYS
 
2 - 24.11.20 - 11:04
(0) архитектура конечно сомнительная, но проблем с реализацией не видно
   lav151
 
3 - 24.11.20 - 11:05
(1) Передать Сумму из табличной части в документе Рейс, в реквизит документа Заявка
   Василий Алибабаевич
 
4 - 24.11.20 - 11:06
(3) Давай. Не стесняйся. Пиши как пробовал передать.
   Fish
 
5 - 24.11.20 - 11:10
(3) Показывай код, как делал. Судя по (0), всё элементарно должно быть.
   Fish
 
6 - 24.11.20 - 11:11
+(5) Или ты ещё никак не делал, а сразу пришел решение просить?
   lav151
 
7 - 24.11.20 - 14:38
(4) (5) Разобрался сам, все работает.

&НаКлиенте
Процедура ПослеЗаписи(ПараметрыЗаписи)
    Заполнения(Объект.Ссылка);
КонецПроцедуры


Функция Заполнения(Док)
Запрос=Новый Запрос  ("ВЫБРАТЬ
                          |    РейсНаправления.Маршрут КАК Маршрут,
                          |    РейсНаправления.ИтоговаяСтавкаП КАК ИтоговаяСтавкаП
                          |ИЗ
                          |    Документ.Рейс.Направления КАК РейсНаправления
                          |ГДЕ
                          |    РейсНаправления.Ссылка = &Ссылка");
Запрос.Параметры.Вставить("Ссылка", Док);
Выборка = Запрос.Выполнить().Выбрать();

Пока Выборка.Следующий() Цикл
        ТекущийДокумент= Выборка.Маршрут.ПолучитьОбъект();
        ТекущийДокумент.ИтСтавкаПерев=Выборка.ИтоговаяСтавкаП;
        ТекущийДокумент.Проведен = Истина;
        ТекущийДокумент.Записать();
КонецЦикла;

Возврат истина;

КонецФункции

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.