Вход | Регистрация
 

График на форме

График на форме
Я
   ArturDoo
 
24.11.20 - 10:47
Доброго времени суток! Строю график на форме, а эта заразо вместо того, что оборвать график, где нет точек, ставит дочки с нулевым значение и доводит его до конца оси ОХ. Как это пофиксить?
Код:
    РезультатЗапроса = Запрос.Выполнить();
    Выборка = РезультатЗапроса.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
    Пока Выборка.Следующий() Цикл
        //Серия = График.Серии.Добавить(ВыборкаДатаПериода.ЭтапПроцесса);    
        //Серия.Значение = ВыборкаДатаПериода.ЭтапПроцесса;
        //Серия.Текст = ВыборкаДатаПериода.ЭтапПроцесса.Наименование;
        Серия = График.Серии.Добавить(Выборка.Сделка);
        //Серия = Выборка.Сделка;
        Серия.Значение = Выборка.Сделка.Ссылка;
        Серия.Текст = Выборка.Сделка.Наименование;
        
        ВыборкаТочки = Выборка.Выбрать();
        Пока ВыборкаТочки.Следующий() Цикл
            Точка = График.УстановитьТочку(ВыборкаТочки.ЭтапПроцесса);
            //Точка = График.УстановитьТочку(ВыборкаДатаПериода.Продолжительность);
            Если ВыборкаТочки.ДатаОкончания <> ДАТА(1, 1, 1, 0, 0, 0) Тогда                      
                График.УстановитьЗначение(Точка, Серия, ВыборкаТочки.Продолжительность);      {Есть варианты, когда мы попадаем сюда один раз, но по этой серии строится дальше 0 по всей оси}
            КонецЕсли;
            //Сообщить("");    
        КонецЦикла;
    КонецЦикла;
   ArturDoo
 
1 - 24.11.20 - 12:15
Всем спасибо, решение найдено: График.ПропускатьБазовоеЗначение = Истина;

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.