Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

ERP/КА2: Списание безналичных денежных средств Статья расходов/активов

ERP/КА2: Списание безналичных денежных средств Статья расходов/активов
Я
   Mikhail Volkov
 
22.11.20 - 15:14
В ERP/КА2 есть документ СписаниеБезналичныхДенежныхСредств, при хоз. операции Прочий расход ДС (может и при другой?) в расшифровке платежа появляется реквизит СтатьяРасходов. Если он не заполнен, то пишет ошибку: Поле "Статья расходов/активов" не заполнено. Пока в КА2 не работаем, данные загружаю из КА1 из ПлатежноеПоручениеИсходящее. В нем нет статьи расходов, бухгалтера плечами пожимают. Может есть возможность как-то ее определить? Пока при загрузке, чтобы ошибок не было, взял ее наугад:
Для каждого Строка Из Объект.РасшифровкаПлатежа Цикл    //+МВ 21.11.2020 Для одной строки расшифровки платежа
    Если Не ЗначениеЗаполнено(Строка.СтатьяРасходов) И Объект.ХозяйственнаяОперация = Перечисления.ХозяйственныеОперации.ПрочаяВыдачаДенежныхСредств Тогда
        СтатьяРасходов = ПланыВидовХарактеристик.СтатьиРасходов.НайтиПоНаименованию("ОХР Прочие");    //+МВ ???
        АналитикаРасходов = Неопределено;
        Если ОбъектНайден Тогда
            Для каждого СтрокаСсылка Из Объект.Ссылка.РасшифровкаПлатежа Цикл
                Если ЗначениеЗаполнено(СтрокаСсылка.СтатьяРасходов) Тогда
                    СтатьяРасходов = СтрокаСсылка.СтатьяРасходов;
                    Если ЗначениеЗаполнено(СтрокаСсылка.АналитикаРасходов) Тогда
                        АналитикаРасходов = СтрокаСсылка.АналитикаРасходов;
                    КонецЕсли;
                КонецЕсли;
            КонецЦикла;
        КонецЕсли;
        Строка.СтатьяРасходов = СтатьяРасходов;
        Если ЗначениеЗаполнено(АналитикаРасходов) Тогда
            Строка.АналитикаРасходов = АналитикаРасходов;
        КонецЕсли;
    КонецЕсли;
КонецЦикла;

Там еще появляется реквизит АналитикаРасходов, но если он не заполнен, то ошибку не пишет. Желательно его тоже определять, если есть возможность?
И еще: возможно СтатьяРасходов и АналитикаРасходов появляются при каких-то других хоз. операциях. Хотел определить по массиву ПроверяемыеРеквизиты, но где он формируется в документе, что-то не нашел?
   shuhard
 
1 - 22.11.20 - 15:32
(0)[бухгалтера плечами пожимают. Может есть возможность как-то ее определить]
это справочник прочие расходы УПП/КА, т.е. субконто 91 счета, с ним у ГБ нет проблем
   Mikhail Volkov
 
2 - 22.11.20 - 16:21
(1) Статьи расходов пришли их УПП/КА1 Статьи затрат. Но как выбрать нужную? А счета в ПлатежноеПоручениеИсходящее используют: 76.05, 76.41.
   Mikhail Volkov
 
3 - 22.11.20 - 16:22
...из УПП/КА1
   РБ
 
4 - 23.11.20 - 09:00
если у вас счета 76-ые, зачем вам там статья расходов?
в появившемся реквизите выбираете Статью активов/пассивов, типо Прочие пассивы и тогда появится возможность проставить счет и аналитику к нему
   Михаил Козлов
 
5 - 23.11.20 - 12:22
Посмотрел, как оформляют ППИ по прочим расходам (КА 2):
- много ППИ по услугам банков. С них статья расходов (Дт91Кт51);
- присутствуют ППИ за аренду авто у сотрудников. В них Статья актива/пассива (Дт73Кт51).
Может, действительно, (4)?
   РБ
 
6 - 23.11.20 - 12:30
(5) что значит "может действительно"?))))
я в ERP 3 года проработала)))
   Mikhail Volkov
 
7 - 23.11.20 - 13:46
Обычно шли выплаты ИП по статье ДДС: Выплата предпринимателю на потребительские цели, когда надо ставить статью расходов. А тут начались выплаты УФК со статьей ДДС: Оплата по претензии расход. Может ее как-то можно определить из других реквизитов? Посмотрите что у Вас ставят.
Статья расходов ладно, начнут работать - поставят что-то, главное чтоб не затиралось повторной выгрузкой. Вроде Статья расходов обязательна при хоз. операции ПрочаяВыдачаДенежныхСредств. Еще в каких случаях? Хотел определить по массиву ПроверяемыеРеквизиты, но где он формируется в документе, что-то не нашел?
   Михаил Козлов
 
8 - 23.11.20 - 16:49
(7) "... но где он формируется в документе, что-то не нашел". Если не ошибаюсь, в модуле менеджера документа.
Сначала, вроде как, все проверяемые реквизиты, а потом из них в зависимости от операции какие-то исключаются.
   Mikhail Volkov
 
9 - 24.11.20 - 09:04
(8) Нашел в модуле объекта:
    Если ХозяйственнаяОперация = Перечисления.ХозяйственныеОперации.ПеречислениеВБюджет
        И Не ПолучитьФункциональнуюОпцию("ИспользоватьУчетПрочихАктивовПассивов") Тогда
        
        МассивНепроверяемыхРеквизитов.Добавить("РасшифровкаПлатежа.СтатьяРасходов");
        МассивНепроверяемыхРеквизитов.Добавить("РасшифровкаПлатежа.АналитикаРасходов");
        МассивНепроверяемыхРеквизитов.Добавить("РасшифровкаПлатежа.АналитикаАктивовПассивов");
    КонецЕсли;
Значит тогда в (0) надо добавить ПолучитьФункциональнуюОпцию("ИспользоватьУчетПрочихАктивовПассивов")? Никогда этой функцией не пользовался.
   Mikhail Volkov
 
10 - 24.11.20 - 10:28
А нет, фрагмент (9) в данном случае не используется. Где же формируются массивы ПроверяемыеРеквизиты и МассивНепроверяемыхРеквизитов?
   Михаил Козлов
 
11 - 24.11.20 - 11:13
(10) Непроверяемые реквизиты в модуле объекта (списание ДС) в ОбработкаПроверкиЗаполнения.
   Mikhail Volkov
 
12 - 24.11.20 - 11:49
В процедуре ОбработкаПроверкиЗаполнения(), где конкретно? Фрагмент (9) оттуда, но в моем случае (Объект.ХозяйственнаяОперация = Перечисления.ХозяйственныеОперации.ПрочаяВыдачаДенежныхСредств) не используется.
   Михаил Козлов
 
13 - 24.11.20 - 12:06
(12) Что-то я запутался. Вам нужно исключить проверку заполненности реквизита "РасшифровкаПлатежа.СтатьяРасходов" (и др.) для хоз. операции ПрочаяВыдачаДенежныхСредств?
Если да, можно эти реквизиты исключить из массива проверяемых в СписаниеБезналичныхДенежныхСредствЛокализация.ОбработкаПроверкиЗаполнения(ЭтотОбъект, Отказ, ПроверяемыеРеквизиты) или в расширении.
   Mikhail Volkov
 
14 - 24.11.20 - 12:22
(13) Нет, конфигурацию менять не собираюсь. Хочу поправить правила обмена (0), чтобы работали не только в случаях, которые у меня возникали, а во всех возможных. См. (0).
   Mikhail Volkov
 
15 - 24.11.20 - 14:23
Еще как-то прячут статьи расходов на форме, в УстановитьУсловноеОформление() есть фрагмент:
    // Видимость статьи расходов


    Элемент = УсловноеОформление.Элементы.Добавить();

    ПолеЭлемента = Элемент.Поля.Элементы.Добавить();
    ПолеЭлемента.Поле = Новый ПолеКомпоновкиДанных(Элементы.РасшифровкаПлатежаСтатьяРасходов.Имя);
    
    ОтборЭлемента = Элемент.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    ОтборЭлемента.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Объект.ХозяйственнаяОперация");
    ОтборЭлемента.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
    ОтборЭлемента.ПравоеЗначение = Перечисления.ХозяйственныеОперации.ПеречислениеВБюджет;
    
    ОтборЭлемента = Элемент.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    ОтборЭлемента.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("ИспользоватьУчетПрочихАктивовПассивов");
    ОтборЭлемента.ВидСравнения = ВидСравненияКомпоновкиДанных.НеРавно;
    ОтборЭлемента.ПравоеЗначение = Истина;

    Элемент.Оформление.УстановитьЗначениеПараметра("Видимость", Ложь);
Но как мз него определить нужна ли СтатьяРасходов?
   РазДва
 
16 - 24.11.20 - 14:40
(6) А в акт сверки, например, поэтому контрагенту и договору на 76, как эти документы в эти три года попадали при использовании статьи активов и пассивов?
   Mikhail Volkov
 
17 - 24.11.20 - 19:06
Не пойму как, откуда запускается ОбработкаПроверкиЗаполнения() в документе?
   Mikhail Volkov
 
18 - 25.11.20 - 12:20
Кажется разобрался: кроме МассивНепроверяемыхРеквизитов еще существует МассивРеквизитовОперации, который заполняется в ОбработкаПроверкиЗаполнения()
    Документы.СписаниеБезналичныхДенежныхСредств.ЗаполнитьИменаРеквизитовПоХозяйственнойОперации(
        ХозяйственнаяОперация,
        ПеречислениеВБюджет,
        МассивВсехРеквизитов,
        МассивРеквизитовОперации);
Она находится в модуле менеджера документа, и "РасшифровкаПлатежа.СтатьяРасходов" добавляется в МассивРеквизитовОперации только при ХозяйственнаяОперация = Перечисления.ХозяйственныеОперации.ПрочаяВыдачаДенежныхСредств. При ее наличии в МассивРеквизитовОперации она не добавляется в МассивНепроверяемыхРеквизитов, и проверяется ее заполненность. В общем все правильно в (0) написал, поправок не надо. Хотелось бы конкретную статью расходов указать в зависимости от других реквизитов документа...
Да, сложно в УФ после обычных форм... так и не понял (17) и с (15) не разобрался...

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.