Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Передача данных запроса с сервера на клиент

Передача данных запроса с сервера на клиент
Я
   ArturDoo
 
18.11.20 - 15:46
Доброго времени суток! Создаю эту тему для тех, кто столкнется с такой же проблемой, как и я.

&НаСервере
Функция ()
    
    МассивДрКонтактныхЛиц = Новый Массив;
    
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    ,
        |    ,
        |    
        |ИЗ
        |    
        |ГДЕ
        |    
            |УПОРЯДОЧИТЬ ПО
        |    ";
    РезультатЗапроса = Запрос.Выполнить();
    
    Выборка=РезультатЗапроса.Выбрать();
    ТаблицаЗначений = Запрос.Выполнить().Выгрузить();
    ////////////////////////////////////////////
    
    Массив = Новый Массив();
        СтруктураСтрокой = "";
        НужнаЗапятая = Ложь;
        
        Для Каждого Колонка Из ТаблицаЗначений.Колонки Цикл
           Если НужнаЗапятая Тогда
              СтруктураСтрокой = СтруктураСтрокой + ",";
           КонецЕсли;
           СтруктураСтрокой = СтруктураСтрокой + Колонка.Имя;
           НужнаЗапятая = Истина;
        КонецЦикла;
        Для Каждого Строка Из ТаблицаЗначений Цикл
           НоваяСтрока = Новый Структура(СтруктураСтрокой);
           ЗаполнитьЗначенияСвойств(НоваяСтрока, Строка);
           Массив.Добавить(НоваяСтрока);
        КонецЦикла;
    
    ////////////////////////////////////////////////
    Возврат Массив
    
КонецФункции
   mistеr
 
1 - 18.11.20 - 15:47
(0) >для тех, кто столкнется с такой же проблемой, как и я

И что за проблема?
   Eiffil123
 
2 - 18.11.20 - 16:01
А зачем результат передавать с сервера на клиент?
   Бычье сердце
 
3 - 18.11.20 - 16:01
(1)
Полагаю автор нашел способ передать таблицу значений на клиент в виде массива структур
   ArturDoo
 
4 - 18.11.20 - 16:05
(1) См тему
(3) +
(2) Чтоб использовать его при работе с формой
   Кир Пластелинин
 
5 - 18.11.20 - 16:07
вау
   mistеr
 
6 - 18.11.20 - 16:10
(3) А, кажктся понял. Интересно, сколько времени на это понадобилось, по сравнению с чтением документации?
   Бычье сердце
 
7 - 18.11.20 - 16:11
(6)
Или хотя бы погуглить
   Бычье сердце
 
8 - 18.11.20 - 16:11
Но на всякий случай добавил в закладки
   VladZ
 
9 - 18.11.20 - 16:23
(0) Ну молодец. Идешь по дороге, которую уже основательно "протоптали".

Посмотри код типовых. Там есть всё, что тебе нужно.

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.