Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Обновление 1с ERP УП 2.0

Обновление 1с ERP УП 2.0
Я
   Flempy
 
17.11.20 - 10:02
релиз 2.4.13.57. После обновления при печати любой счет-фактуры возникает ошибка

{(69, 5)}: Не задано значение параметра "НоваяАрхитектураВзаиморасчетов"
И <<?>>&НоваяАрхитектураВзаиморасчетов) КАК ВложенныйЗапрос

Мб кто знает в чем может быть проблема?
   lodger
 
1 - 17.11.20 - 10:05
проблема в том, что не задано значение параметра "НоваяАрхитектураВзаиморасчетов"
   Flempy
 
2 - 17.11.20 - 10:07
(1) логично, а где его задать?
   lodger
 
3 - 17.11.20 - 10:12
(2) если вы задаёте такие вопросы... по колесу попинать пробовали?
что лежит в константе НоваяАрхитектураВзаиморасчетов ?
   Flempy
 
4 - 17.11.20 - 10:16
(3) параметр
   Flempy
 
5 - 17.11.20 - 10:20
   РБ
 
6 - 17.11.20 - 10:49
(5) Все функции-поищите константу, откройте-должна стоять галка
   Flempy
 
7 - 17.11.20 - 12:01
(6) нашел, галочка стоит, там есть еще "не Новая Архитектура Взаиморасчетов", у нее галочки нет
   РБ
 
8 - 17.11.20 - 12:55
(7) у не новой и не должно быть.
тогда, возможно, ошибка релиза.
   Flempy
 
9 - 17.11.20 - 12:56
(8) в демке все нормально открывает, так что вряд ли
   РБ
 
10 - 17.11.20 - 13:02
(9) вы в демке пример сами делали или открывали имеющуюся СФ?
   Flempy
 
11 - 17.11.20 - 13:10
(10) открыл имеющуюся
   Flempy
 
12 - 17.11.20 - 14:08
ап
   РБ
 
13 - 18.11.20 - 07:15
(12) не увидела сообщения, что смоделировали СФ с нуля по образу и подобию рабочей базы
   Flempy
 
14 - 18.11.20 - 10:09
(13) смоделировал, все так же открывает на печать
   РБ
 
15 - 18.11.20 - 11:17
(14) согласись, что чудес не бывает?
если в демке того же релиза все верно, а в рабочей нет, то одно из двух:
1. ваш база нетиповая и дописки криво легли на новое обновление
2. что-то в настройках у вас отличается от демки.

в любом случае отладчик вам в помощь.
хрустальный шар не всемогущ))
   Flempy
 
16 - 18.11.20 - 11:57
(15) Пробежал отладчиком в демке и в своей базе, ошибка возникает в данном куске кода
https://ibb.co/ZJcLfWD
   Flempy
 
17 - 18.11.20 - 12:02
(16) Думаю, что проблема в параметре печати, потому что, в демке в него передается гораздо больше параметров, нежели в моей базе
   Flempy
 
18 - 18.11.20 - 12:04
Вот например, что передает в Объект печати демки
https://ibb.co/0ysq0xm

А это моя база
https://ibb.co/9YnNzcW
   Flempy
 
19 - 18.11.20 - 12:07
(16) В момент открытия формы
   Flempy
 
20 - 18.11.20 - 12:19
хотя другие печатные формы проходят отладку и открывают печатную форму, например тот же торг-12
   Flempy
 
21 - 18.11.20 - 12:38
Крч, когда происходить событие "ОткрытьФорму", демка выполняет сначала процедуру "ПриСозданииНаСервере", а моя база - "ПриОткрытии". Очень странно
   Flempy
 
22 - 18.11.20 - 12:59
либо это отладчик некорректно работает, не отображает серверные процедуры
   РБ
 
23 - 18.11.20 - 13:20
(22) я в этом не очень разбираюсь, но помню, что программисты как-то по-особому отладку серверных процедур делали.
вот что-то такое писали:
Не работает отладка серверных процедур в одной из баз на сервере приложений.
   Flempy
 
24 - 18.11.20 - 14:47
(23) Не помогло, но все равно спасибо. Сейчас отлаживаю демку и анализирую, где могла бы возникнуть эта ошибка
   Flempy
 
25 - 19.11.20 - 12:26
(23) Каким-то чудом удалось запустить серверную отладку. В общем, проблема была в расширении...


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.