Вход | Регистрация
 

комплект документов при приеме

комплект документов при приеме
Я
   first_may
 
16.11.20 - 16:22
Добрый.

Конфигурация Зарплата и управление персоналом, редакция 3.1 (3.1.15.96) .

Подскажите пож, как можно сделать что бы в документе ПриемНаРаботу
можно было сформировать сразу несколько форм (договор, приказ ..),
как это сделано в увольнении?
   dka80
 
1 - 16.11.20 - 16:39
Внешняя печатная форма с вызовом типовых? Только формировать нужно не в одном табличном документе, а отдельно и выводить на печать комплект документов
   first_may
 
2 - 16.11.20 - 16:53
(1) да, для увольнения вот так выводится https://yadi.sk/i/yfryIzInLW4yug
   ДенисЧ
 
3 - 16.11.20 - 17:05
(2) Ну так сделай так же...
Отдельная ПФ. В ней галки по необходимости. Унутре неон^W выбор по галкам и вызов нужных встроенных..

Или ты бухгалтер? ))
   first_may
 
4 - 16.11.20 - 22:41
(3) нашел описание http://catalog.mista.ru/1c/articles/633085/

для внешних получилось, а вот для встроенной ПФ_MXL_Т1 не получается.
   first_may
 
5 - 16.11.20 - 22:44
то есть пишу

Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
    ПечатнаяФорма = УправлениеПечатью.СведенияОПечатнойФорме(КоллекцияПечатныхФорм, "впфТрудовойДоговорОсновной");
    Если ПечатнаяФорма <> Неопределено Тогда
        ВПФ = СоздатьВПФ("впфТрудовойДоговорОсновной");
        ВПФ.Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода);
        ПечатнаяФорма.СинонимМакета = НСтр("ru = 'впф Трудовой договор (основной)'");
    КонецЕсли;
    
    
    ПечатнаяФорма = УправлениеПечатью.СведенияОПечатнойФорме(КоллекцияПечатныхФорм, "впфТрудовойДоговорМатериальнойОтветственности");
    Если ПечатнаяФорма <> Неопределено Тогда
        ВПФ = СоздатьВПФ("впфТрудовойДоговорМатериальнойОтветственности");
        ВПФ.Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода);
        ПечатнаяФорма.СинонимМакета = НСтр("ru = 'впф Трудовой договор (материальной ответственности)'");
    КонецЕсли;
    
    
    ПараметрыПечати = Новый Структура;
    ПараметрыПечати.Вставить("ДополнитьКомплектВнешнимиПечатнымиФормами", Ложь);
    ПараметрыПечати.Вставить("ТребуетсяЧтениеБезОграничений", Истина);
    
    ЗарплатаКадрыОтчеты.ВывестиВКоллекциюПечатнуюФорму("ПФ_MXL_Т1",
        МассивОбъектов, ПараметрыПечати, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода, , Неопределено);
КонецПроцедуры



первые две выводятся, а для третьей ошибка
В обработчике печати не был сформирован табличный документ для: ПриказОПриеме
{ОбщийМодуль.УправлениеПечатью.Модуль(1637)}:            ВызватьИсключение(ТекстСообщенияОбОшибке);
{ОбщаяФорма.ПечатьДокументов.Форма(488)}:        УправлениеПечатью.ПечатьПоВнешнемуИсточнику(
{ОбщаяФорма.ПечатьДокументов.Форма(43)}:        КоллекцияПечатныхФорм = СформироватьПечатныеФормы(Параметры.ИменаМакетов, Отказ);
{ОбщийМодуль.УправлениеПечатьюСлужебныйКлиент.Модуль(240)}:    ОткрытьФорму("ОбщаяФорма.ПечатьДокументов", ПараметрыОткрытия, Форма);
{ОбщийМодуль.УправлениеПечатьюКлиент.Модуль(127)}:        ВыполнитьОбработкуОповещения(ОписаниеПроцедурыЗавершения, СписокДокументов);
{ОбщийМодуль.УправлениеПечатьюСлужебныйКлиент.Модуль(38)}:        УправлениеПечатьюКлиент.ПроверитьПроведенностьДокументов(ОписаниеОповещения, ОбъектыНазначения, Форма);
{ОбщийМодуль.ДополнительныеОтчетыИОбработкиКлиент.Модуль(488)}:        МодульУправлениеПечатьюСлужебныйКлиент.ВыполнитьОткрытиеПечатнойФормы(
{ОбщийМодуль.ДополнительныеОтчетыИОбработкиКлиент.Модуль(258)}:        ВыполнитьОткрытиеПечатнойФормы(ВыполняемаяКоманда, Форма, ВыполняемаяКоманда.ОбъектыПечати);
{ОбщийМодуль.УправлениеПечатьюСлужебныйКлиент.Модуль(101)}:            МодульДополнительныеОтчетыИОбработкиКлиент.ВыполнитьНазначаемуюКомандуПечати(ОписаниеКоманды, Форма);
{ОбщийМодуль.УправлениеПечатьюСлужебныйКлиент.Модуль(26)}:    ВыполнитьПодключаемуюКомандуПечатиЗавершение(Истина, ПараметрыВыполнения);
{ОбщийМодуль.ПодключаемыеКомандыКлиент.Модуль(190)}:            ВыполнитьОбработкуОповещения(Обработчик, ПараметрКоманды);
{ОбщийМодуль.ПодключаемыеКомандыКлиент.Модуль(60)}:    ПродолжитьВыполнениеКоманды(Контекст);
{ЖурналДокументов.ПриемыПереводыУвольнения.Форма.ФормаСписка.Форма(114)}:    ПодключаемыеКомандыКлиент.ВыполнитьКоманду(ЭтотОбъект, Команда, Элементы.Список);
   first_may
 
6 - 16.11.20 - 22:58
Получилось!
   first_may
 
7 - 16.11.20 - 22:58
ПечатнаяФорма = УправлениеПечатью.СведенияОПечатнойФорме(КоллекцияПечатныхФорм, "впфТрудовойДоговорОсновной");
    Если ПечатнаяФорма <> Неопределено Тогда
        ВПФ = СоздатьВПФ("впфТрудовойДоговорОсновной");
        ВПФ.Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода);
        ПечатнаяФорма.СинонимМакета = НСтр("ru = 'впф Трудовой договор (основной)'");
    КонецЕсли;
    
    
    ПечатнаяФорма = УправлениеПечатью.СведенияОПечатнойФорме(КоллекцияПечатныхФорм, "впфТрудовойДоговорМатериальнойОтветственности");
    Если ПечатнаяФорма <> Неопределено Тогда
        ВПФ = СоздатьВПФ("впфТрудовойДоговорМатериальнойОтветственности");
        ВПФ.Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода);
        ПечатнаяФорма.СинонимМакета = НСтр("ru = 'впф Трудовой договор (материальной ответственности)'");
    КонецЕсли;
    
    
    ПараметрыПечати = Новый Структура;
    ПараметрыПечати.Вставить("ДополнитьКомплектВнешнимиПечатнымиФормами", Ложь);
    ПараметрыПечати.Вставить("ТребуетсяЧтениеБезОграничений", Истина);
    
    ПечатнаяФорма = УправлениеПечатью.СведенияОПечатнойФорме(КоллекцияПечатныхФорм, "ПриказОПриеме");
    ПечатнаяФорма.ИмяВРЕГ = "ПФ_MXL_Т1";
    Отчеты.ПечатнаяФормаТ1.Печать(МассивОбъектов, ПараметрыПечати, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода);
    ПечатнаяФорма.СинонимМакета = НСтр("ru = 'Приказ о приеме (Т-1)'");

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.