Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Отмена проведения сразу после проведения

v7: Отмена проведения сразу после проведения
Я
   Mafiozaa
 
16.11.20 - 03:02
Доброе утро, могу ли я как то отменить проводку, сразу же после проводки, тоесть, оформляю чек, нажимаю провести, все вылазит чек, и сразу чек становится не проведенным, остановился на ошибке данный объект заблокирован (имя объекта) я так понимаю покуда его форма открыта, он заблокирован
   Mafiozaa
 
1 - 16.11.20 - 03:07
(0) А точнее не чек продажи сделать не проведенным, а чек возврата, тоесть жму ввод на основании и при нажатии на провести,после проводки отменяется проводка
   Mafiozaa
 
2 - 16.11.20 - 03:27
(1)

Если ВидОперации = Перечисление.ВидыОперацийЧекККМ.ЧекНаВозврат Тогда
    Провести();
    Чек = СоздатьОбъект("Документ.ЧекККМ");
    Чек.НайтиДокумент(ТекущийДокумент());
    Чек.СделатьНеПроведенным();
   Bigbro
 
3 - 16.11.20 - 04:07
после Провести();
СделатьНеПроведенным();

неясно зачем.
   Mafiozaa
 
4 - 16.11.20 - 04:13
(3) Все равно остается проведенным.
Сам в шоке, магазин делает возврат без чека, а на основании расходника + документ возврат от покупателя
   Mafiozaa
 
5 - 16.11.20 - 04:14
(3) А моим способом пишет объект заблокирован, но если я это делаю внешней обработкой то все хорошо
   Mafiozaa
 
6 - 16.11.20 - 04:16
(3) При том при всем, и форму закрывал, и нашел метод Блокировка(0), все равно 0 эмоций
   Mafiozaa
 
7 - 16.11.20 - 06:57
Решил, вместо провести, просто чек выкатываю
   Kigo_Kigo
 
8 - 16.11.20 - 08:05
(7) Так чек ККМ выводится на ККТ из модуля документа,  тебе в процедуру

Процедура ВыполнитьНажатиеНаКнопку(ИмяКнопки)//"Ок" или провести

Если ВидОперации = Перечисление.ВидыОперацийЧекККМ.ЧекНаВозврат Тогда
Если Касса.РежимККМ = Перечисление.РежимыККМ.ФР Тогда
             Если глФРВкл = 1 Тогда
                 Если ЧекПробитККМ = 0 Тогда
                     Если ПробитьЧекНаККМ() = 0 Тогда
                         
                         // по каким-то причинам Чек не пробит

                        Сообщить("Чек ККМ не пробит!");
                         //Возврат;

                     Иначе
                     ЧекПробитККМ = 1;
                     Записать();
                    КонецЕсли;
                 КонецЕсли;
             КонецЕсли;
КонецЕсли

и далее анализуруй- если Чек на зоврат, просто не давай команду Провести() и все
   Mafiozaa
 
9 - 16.11.20 - 08:13
(8) Именно так и сделал, если чек возвратный то печать чека без проводки

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.