Вход | Регистрация
 

Подсчитать количество повторений элементов

Подсчитать количество повторений элементов
Я
   YamEgor
 
15.11.20 - 13:33
Добрый день ! подскажите как можно Подсчитать количество повторений элементов, заданного множества символов, во введенной строке?
   RomanYS
 
1 - 15.11.20 - 13:39
(0) переведи или пример дай
   Ненавижу 1С
 
2 - 15.11.20 - 13:43
Решил сделать здесь онлайн решебник?
https://forum.mista.ru/index.php?user_id=123356
   ДНН
 
3 - 15.11.20 - 13:55
(0) СтрЧислоВхождений
   YamEgor
 
4 - 15.11.20 - 14:13
(1) Честно говоря сам немного не понял, только интуитивно догадываюсь что это такое поэтому и спросил..))
   Asmody
 
5 - 15.11.20 - 14:15
(0) у тебя зачёт ли собеседование?
   Ненавижу 1С
 
6 - 15.11.20 - 14:17
извините, как понял условие:
Процедура Тест() Экспорт

    СоответствиеСимволов = Новый Соответствие;
    Для й=1 По СтрДлина(СтрокаСимволов) Цикл
        
        ТекСимвол = Сред(СтрокаСимволов,й,1);
        Значение = СоответствиеСимволов.Получить(ТекСимвол);
        СоответствиеСимволов.Вставить(ТекСимвол,?(Значение=Неопределено,0,Значение+1));
        
    КонецЦикла; 
    
    Для каждого Эл Из СоответствиеСимволов Цикл
        Сообщить(Эл.Ключ+" "+Эл.Значение);    
    КонецЦикла; 

КонецПроцедуры
   YamEgor
 
7 - 15.11.20 - 14:17
(5) Собеседование
   Ненавижу 1С
 
8 - 15.11.20 - 14:18
(7) огласите весь список вопросов!
   YamEgor
 
9 - 15.11.20 - 14:19
хорошо сейчас
   YamEgor
 
10 - 15.11.20 - 14:27
вопрос1: В пробирке есть 1 амеба. Предположим, что амебы делятся пополам каждую минуту. Сколько будет амёб через 1 час

вопрос2: Нахождение факториала от числа, заданного в переменной N

вопрос3: Объявить массив из 10 произвольных чисел. Вывести в порядке возрастания.

вопрос4: Вводятся целые числа a и b. Гарантируется, что a не превосходит b. Выведите (через пробел) все четные числа от a до b (включительно).

вопрос5: Сделать матрицу случайных чисел 5 x 5. Вывести пользователю. Получить по исходной матрице транспонированную матрицу. Вывести пользователю.

вопрос6: Сгенерировать последовательность из 20 случайных чисел в диапазоне от 0 до 30, при условии, чтобы в последовательности числа не повторялись.

вопрос7: В переменную Текст задать произвольное предложение (из любой книжки). Разработать функцию, в которую передаем переменную Текст, а функция возвращает то же самое предложение, но с зеркальными словами
Н/р, Текст = "Рыжий кот живет за углом".
Результат = "йижыР ток тевиж аз молгу"

вопрос8: Убрать условный оператор «Если» из следующего блока (А может принимать значение 0 или Если (А = 0) Тогда
    B = 2;
Иначе
    В = 1;
КонецЕсли;

вопрос9: Объявлены две числовые переменные a и b. Необходимо сделать так, чтобы без объявления других переменных в результате работы алгоритма значения переменных поменялись местами. Например, если изначально a = 4, b = 5, то в результате алгоритма стало a = 5, b = 4. Применять можно только операции присваивания и арифметические операции с числами и значениями переменных.

вопрос10: Подсчитать количество повторений элементов, заданного множества символов, во введенной строке.

вопрос11: В шапке отчета стандартный период, в котором пользователь указывает интервал дат. Результатом формирования отчета должна быть одна колонка, с выводом всех дат из этого интервала. Н/р, пользователь указал 01.01.2020 – 31.01.2020, отчет вывел в одну колонку 01.01.2020
02.01.2020
…..
31.01.2020
   YamEgor
 
11 - 15.11.20 - 14:33
(6) Спасибо!
   Ненавижу 1С
 
12 - 15.11.20 - 14:38
(10) в 8 вопросе фраза затерта: Убрать условный оператор «Если» из следующего блока (А может принимать значение 0 или ????? Если (А = 0) Тогда
   YamEgor
 
13 - 15.11.20 - 14:39
(12) да возможно ..
   Ёпрст
 
14 - 15.11.20 - 14:54
(10) скучно.. какой вопрос вызывает затруднение?
   YamEgor
 
15 - 15.11.20 - 15:04
(14) Вопрос 11 и вопрос 5
   rphosts
 
16 - 15.11.20 - 15:06
(6) может проще резать и писать в ТЗ с колонками Символ и Количество этот символ и 1, а потом свернуть по группировке Символ, по суммированию Количество. До кучи можно и отсортировать.
   YamEgor
 
17 - 15.11.20 - 15:07
(14) еще вопрос 4 не пойму
   YamEgor
 
18 - 15.11.20 - 15:08
(16) да тоже хорошая идея..
   Ёпрст
 
19 - 15.11.20 - 15:12
(15)
11.  Пока ДатаНачала<ДатаКонца Цикл
         ДатаНачала = ДатаНачала + 86400//добавили 1 день в секундах: 24 часа*60 минут*60 секунд

         И добаляешь датаначала куда тебе там надо
   rphosts
 
20 - 15.11.20 - 15:13
(15) 11 - можно запросом, http://catalog.mista.ru/1c/articles/158617/ пункт 7

ну или так:
тмп_дата = НачалоДня(ДатаНачала);
Пока тмп_Дата<=НачалоДня(ДатаОкончания) Цикл
     Сообщить(тмп_Дата);
     тмп_дата = тмп_Дата + 86400;
КонецЦикла;


какая по вакухе вилка?
   Ёпрст
 
21 - 15.11.20 - 15:30
4. Пока а<=б цикл
      а=а+1;
      Если а%2=0 тогда
         Сообщить(а);
   acht
 
22 - 15.11.20 - 15:35
(21)
а = а + а%2;
Пока а <= б Цикл
    Сообщитьа);
    а = а + 2;
КонецЦикла;

Хотя не, через пробел же выводить надо =)
   acht
 
23 - 15.11.20 - 15:35
(0) Ну смотри, облажаешся на собеседовании, обратно не возвращайся =)
   YamEgor
 
24 - 15.11.20 - 15:41
(23) хорошо спасибо!
   YamEgor
 
25 - 15.11.20 - 15:43
(20) пока не говорили, смотрят , это в Казахстане
   Ёпрст
 
26 - 15.11.20 - 15:44
Остальное надо или сам осилил? С телефона тоскливо писать
   YamEgor
 
27 - 15.11.20 - 15:47
(26) пока наверно все сейчас еще подумаю, спасибо всем большое за помощь!!  
если вдруг конечно у кого то какие нибудь идеи есть....
   Ненавижу 1С
 
28 - 15.11.20 - 16:02
Подозреваю очнпя часть пройдет в разборе этой ветки


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.