Вход | Регистрация
 

Расшифровка Отчета

Расшифровка Отчета
Я
   Peshalkin
 
15.11.20 - 08:12
Добрый день, подскажите пожалуйста, есть отчет в котором по нажатию на филиал открывается другой отчет с детальными данными, после добавления расшифровки по Группе товара, у меня перестала выводиться вся информация в втором отчете, не важно нажимаешь на филиал или же на группу товара, ниже блок кода который отвечает за расшифровку



Пока ВыборкаНоменклатураРодитель.Следующий() Цикл
        нмкРасшифровка = Новый Структура("НоменклатураРодитель, Филиал");
        ОбластьНоменклатураРодитель.Параметры.Заполнить(ВыборкаНоменклатураРодитель);
        
        нмкРасшифровка.НоменклатураРодитель = ВыборкаНоменклатураРодитель.НоменклатураРодитель;
        нмкРасшифровка.Филиал = ВыборкаНоменклатураРодитель.Филиал;
        ОбластьНоменклатураРодитель.Параметры.нмкРасшифровка = нмкРасшифровка;
        ТабДок.Вывести(ОбластьНоменклатураРодитель, ВыборкаНоменклатураРодитель.Уровень());
    
        ВыборкаФилиал = ВыборкаНоменклатураРодитель.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
        Пока ВыборкаФилиал.Следующий() Цикл
            сткРасшифровка = Новый Структура("Филиал, НоменклатураРодитель");
            
            ОбластьФилиал.Параметры.Заполнить(ВыборкаФилиал);
            
            сткРасшифровка.Филиал = ВыборкаФилиал.Филиал;
            сткРасшифровка.НоменклатураРодитель = ВыборкаФилиал.НоменклатураРодитель;
            ОбластьФилиал.Параметры.сткРасшифровка = сткРасшифровка;
            ТабДок.Вывести(ОбластьФилиал, ВыборкаФилиал.Уровень());
        КонецЦикла;
    КонецЦикла;
   Peshalkin
 
1 - 15.11.20 - 08:27
&НаКлиенте
 Процедура ТабДокОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка, ДополнительныеПараметры)
    
    СтандартнаяОбработка = Ложь;
    Если ТипЗнч(Расшифровка) = Тип("Структура") Тогда
        Расшифровка.Вставить("ДатаН", Период.ДатаНачала);
        Расшифровка.Вставить("ДатаО", Период.ДатаОкончания);
        СтруктураОтчета = новый Структура("СтруктураДляОтчета", Расшифровка);
        ОткрытьФорму("Отчет.ОтчетПоГруппамТовара.Форма.ФормаРасшифровки", СтруктураОтчета);
    КонецЕсли;
    
    
КонецПроцедуры
   Peshalkin
 
2 - 15.11.20 - 08:28
Подскажите пожалуйста, если кто-то понимает в чем проблема, не могу разобраться ((
   Peshalkin
 
3 - 15.11.20 - 09:23
Не актуально

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.