Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Ширина колонок Excel и макета

Ширина колонок Excel и макета
Я
   CrtlC
 
13.11.20 - 12:59
Здравствуйте!
Помогите, плз, решить проблему. Сохраняю отчеты через табличный документ в формате Excel. В макете задана одна высота и ширина колонок, а в файле Excel другие цифры. Закономерности не увидил. Если высота в макете 20, то в файле 21. Если поставить 19, тогда совпадает. Ширина может на 5 пунктов отличатся.

1С:Предприятие 8.3 (8.3.14.1694) и BAF. База УТП.
   mistеr
 
1 - 13.11.20 - 13:44
Если нужна миллиметровая точность, сохраняй в PDF.
   kobzon2
 
2 - 13.11.20 - 14:01
Есть такой глюк. Тоже при сохранение в excel, он начинает выстраивать ячейки по своему и часто режет текст, хотя в табличном документе или в pdf всё норм.
   CrtlC
 
3 - 13.11.20 - 14:17
(2) Беда, клиент попался требовательный, все до буковки должно быть как в ТЗ, в том числе и ширина колонок в Excel... Я к такому не был готов)
   mistеr
 
4 - 13.11.20 - 14:34
(3) Ну раз требует, пусть платит за вывод отчета через COM.
   ДенисЧ
 
5 - 13.11.20 - 14:40
(3) Поставь ему PageMaker и рисуй туда с точностью dpi принтера...
   CrtlC
 
6 - 16.11.20 - 11:02
Сделал так, извините за вставку кода в таком виде, не разобрался как оформлять...
        Всем спасибо!
        Горизонталь    = 0;
    Вертикаль    = 1;
    
    Пока Вертикаль <> 23 Цикл
        Горизонталь = Горизонталь +1;
        Ячейка = Лист.Cells(Вертикаль, Горизонталь);
        Если Горизонталь = 1 Тогда
            Ячейка.ColumnWidth = 54,5;
        ИначеЕсли Горизонталь = 2 Тогда 
            Ячейка.ColumnWidth = 10.5;
        Иначе
            Ячейка.ColumnWidth = 13;
        КонецЕсли;
        Ячейка.RowHeight  = 20;
        
        Если Горизонталь = 10 Тогда
            Горизонталь = 0;
            Вертикаль = Вертикаль + 1;
        КонецЕсли;
    КонецЦикла;
   CrtlC
 
7 - 16.11.20 - 11:03
(6) Круто, само оформляет :)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.