Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Как правильно реализовать отображение журнала документов в ТЗ формы обработки?

v7: Как правильно реализовать отображение журнала документов в ТЗ формы обработки?
Я
   jah1111
 
11.11.20 - 23:07
Хочу чтобы в форме обработки была таблица, в которой отображались последние документы
Химичу так:
//*******************************************
Функция Журнал()
Док = СоздатьОбъект("Документ");
Док.ИспользоватьЖурнал("ПолныййЖурнал", 1);
ном = 0;
Док.ВыбратьДокументы();

Пока Док.ПолучитьДокумент()=1 Цикл
ном=ном+1;
ТабЖур.НоваяСтрока();
ТабЖур.документ = док;

КонецЦикла;


КонецФункции

но чепуха выходит. Как правильн сделать? есть методы работы з журналами?
   Lazy Stranger
 
1 - 11.11.20 - 23:17
если в ВыбратьДокументы() не указать даты начала и конца выборки, то она вернет все документы в базе
ИспользоватьЖурнал() не даст ничего, что так что эдак все документы попадут в выборку
   tgu82
 
2 - 11.11.20 - 23:17
(0) Что значит последние?
Когда-то делал такое для путевых листов - с закладками по типу путевого листа
   jah1111
 
3 - 11.11.20 - 23:44
(2) вроде как работает,  одну секунду в таблице значений на форме  (ТабЖур) бегут названия документов и пропадают, таблица остается пустой.
Точнее не пустой, в ней появляются строки, но пустые.
ищу сбособ выгрузки журнала в ТЗ.

или подскажите как правильно реализовать.
   Ёпрст
 
4 - 12.11.20 - 00:07
(1) ИспользоватьЖурнал даст фильтр.

(0) .ТекущийДокумент() добавь
   Ёпрст
 
5 - 12.11.20 - 00:08
ну и врят ли у тебя есть "ПолныййЖурнал" ййййййййййй
   Ёпрст
 
6 - 12.11.20 - 00:10
ну и..ТабЖур твоя как создана ? Где объявлены колонки хоть и какого они типа ?
   jah1111
 
7 - 12.11.20 - 00:12
(5) ну это уже исправлено!
   jah1111
 
8 - 12.11.20 - 00:16
(4) все заработало, появились доки 
(6) приоткрытии
спасибо ЕПРСТ!!!!

ну, дело сдвинулось, если что буду спрашивать
   Ёпрст
 
9 - 12.11.20 - 00:23
Если что, лепить свой журнал на форме, по-уму нужно использовать 1cpp и его ТабличноеПоле..где поставщиком будет запрос.
От там и редактирование и сортировка и рюшечки и всё-всё всё..
   Злопчинский
 
10 - 12.11.20 - 01:18
А зачем такой изврат у автора? получить последние документы - открой общий журнал, поставь интервал видимости и все. дополнительно и фильтры можно штатные - смотри ТиС как сделан общий журнал (фильтры вообще можно все вынести в плавающие закладки)
   jah1111
 
11 - 12.11.20 - 01:56
(10) переделываю конфу под сенсор, уже многое получилось, выписка на складе уже на планшете + термопринтер, все довольны, процесс ускорился в несколько раз.

сейчас идея такая - обработка на весь екран типа рабочий стол, открывается ПриНачалеРаботыСистемы. На форме кнопки для доступа к самым востребованым документам функциям и отчетам (большие такие, удобные кнопки). Внизу  - таблица с последними документами, для горячего доступа к ним. Все с формексом, все большое, удобное.

(9) Вроде ТЗ Документами заполнил, разобрался.... а вот как их теперь открывать из этой ТЗ - хрен его знает

может действительно придется курить 1срр
   Builder
 
12 - 12.11.20 - 02:13
(11) Есть штатная обработка клика на ТЗ и там делай что хочешь.
   Cthulhu
 
13 - 12.11.20 - 02:59
1) в свойствах ТЗ на закладке "Дополнительно" Формула: ВыбДокумТЗ()
2) в модуле формы обработки:
Процедура ВыбДокумТЗ()
  Перем тСтр;
  тСтр=Мин(Макс(ТабЖур.ТекущаяСтрока(),1),ТабЖур.КоличествоСтрок());
  Если тСтр<>0 Тогда ОткрытьФорму(ТабЖур.ПолучитьЗначение(тСтр,"документ") КонецЕсли;
КонецПроцедуры//ВыбДокумТЗ
   Cthulhu
 
14 - 12.11.20 - 03:01
(12): чо "штатное" ???
   Mikeware
 
15 - 12.11.20 - 07:38
(9)+100500
(11) в таблице "последние документы" будут на момент заполнения этой таблицы, а не реально последние.
   jah1111
 
16 - 12.11.20 - 08:44
(13) Спасибо! Приблизительно так и сделал!
(15) да, но яреализовал так, чтобы таблица обновлялась при каждом сохранении документа.
   Mikeware
 
17 - 12.11.20 - 08:53
(16) да, но сохранять документы может не только обладатель данного планшета, но и другие
   dimm7310
 
18 - 12.11.20 - 09:31
советую посмотреть в сторону класса "ПоставщикДанных" (вроде так назывался ) на основе 1С++. там есть готовые механизмы для создания журнала документов на любой форме (в том числе и обработки) с любыми отборами.
   Builder
 
19 - 12.11.20 - 09:35
(14) Ну я имел ввиду (13), это же "штатно", без ВК :)
   Mikeware
 
20 - 12.11.20 - 09:45
(18) их несколько.
Да, ПоставщикДанных делает как раз таблицы по типу динамического запроса в снеговике... со всеми отборами а-ля снеговик, и прочими  плюшками.
и не только "журнала документов", но любого журнала/списка/отчета
   victuan1
 
21 - 13.11.20 - 05:38
(18) Хорошая штука, поставлю в закладку...


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.