Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Модифицируемость в наборе записей регистра

Модифицируемость в наборе записей регистра
Я
   FrostBite101
 
11.11.20 - 11:51
Готовлюсь к 1с Специалист, в документе операции увидел данный код
    НаборЗаписей = Движения.Управленческий;
    
    Если Не НаборЗаписей.Модифицированность() И НЕ ЭтоНовый() Тогда
        НаборЗаписей.Прочитать();
    КонецЕсли;
    
    Если НаборЗаписей.Количество() > 0 Тогда
        Для Каждого Запись Из НаборЗаписей Цикл
            Запись.Период = Дата;
        КонецЦикла;
        НаборЗаписей.УстановитьАктивность(Не ПометкаУдаления);
    КонецЕсли;
    
    НаборЗаписей.Записывать = Истина;

Проблема в том, что Модиф - всегда истина, я и меняю в форме движения, но это условие не отрабатывает. В чем может быть проблема?
   vicof
 
1 - 11.11.20 - 11:54
Галку Сохраняемые данные убери
   FrostBite101
 
2 - 11.11.20 - 12:12
Да, но зачем это в документе операция, если там поставлена эта галка?
   FrostBite101
 
3 - 11.11.20 - 12:22
(1) ?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.