Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Выдернуть все кассовые чеки за определенную дату

v7: Выдернуть все кассовые чеки за определенную дату
Я
   Mafiozaa
 
11.11.20 - 05:57
Приветствую, возникла трудность, магазин проводил продажи в хре* знает какой базе, следственно в их рабочей базе нет продаж за определенную дату, но чеки были, и Z отчет показывает что были продажи, пытался востановить из лога чеков, но и там пусто, может есть какой то способ выдернуть все продажи за определенную дату, из самой фрки, читал что если 30 дней не прошло с момента, то можно дернуть, полазил не нашел, может кто сталкивался
   JeHer
 
1 - 11.11.20 - 05:59
С ОФД дёрнуть не проще?
   Mafiozaa
 
2 - 11.11.20 - 06:59
(1) Щас буду этим и заниматься)
   Mikhail Volkov
 
3 - 11.11.20 - 07:50
(1) А как? Хотел выдернуть с ФР, не получилось X-отчет в 1С возможен?. На оборот с ФР сделал в Альфа-Авто:
Функция СуммаОборотаПоФР(GUID_ФР = "", ТаймаутФР = 0, СтрОборот = "")   Экспорт
    SafeArrayСтатусыФР = глРарус_Компонента.СоздатьПараметры(,);
    КодОшибки = глРарус_Компонента.ЗаказатьВыполнениеДействияСинхронно(GUID_ФР,"ПолучитьСтатус",SafeArrayСтатусыФР,ТаймаутФР);
    Если КодОшибки <> 0 Тогда    Возврат 0;    КонецЕсли;
    Попытка    
        SafeArrayСчетчикиФР = SafeArrayСтатусыФР.GetValue(0, 0);
        СуммаПродаж    = Окр(Число(SafeArrayСчетчикиФР.GetValue(5, 0)),2);
        СуммаВозвратов    = Окр(Число(SafeArrayСчетчикиФР.GetValue(6, 0)),2);
    Исключение
        Возврат 0;
    КонецПопытки;
    СуммаОборотаПоФР = СуммаПродаж - СуммаВозвратов;
    Если СуммаОборотаПоФР = 0 Тогда    Возврат 0;    КонецЕсли;
    СтрОборот = "Оборот по ФР: " + Формат(СуммаОборотаПоФР,"ЧДЦ=2") + " руб.";
    Возврат СуммаОборотаПоФР;
КонецФункции
   Mikhail Volkov
 
4 - 11.11.20 - 08:39
Посмотреть конкретный чек на ОФД из 1С могу:
// Возращает ссылку на чек на сайте ОФД Такском-Касса

//
Функция СсылкаНаЧекОФД(Документ) Экспорт
    Если (ТипЗнч(Документ) = Тип("ДокументСсылка.ЧекНаОплату")
      Или ТипЗнч(Документ) = Тип("ДокументСсылка.ПриходныйКассовыйОрдер")
      Или ТипЗнч(Документ) = Тип("ДокументСсылка.РасходныйКассовыйОрдер"))
      И Не ПустаяСтрока(Документ.НомерФПД) И Документ.СуммаДокумента > 0 Тогда
        Возврат "https://receipt.taxcom.ru/v01/show?fp="; + СокрЛП(Документ.НомерФПД) + "&s=" + Формат(Документ.СуммаДокумента,"ЧГ=0") + "&sf=False&sfn=False";
    КонецЕсли;
    Возврат "";
КонецФункции // СсылкаНаЧекОФД()

(1) А как посмотреть все чеки на ОФД в 1С, такое возможно?
   Mikhail Volkov
 
5 - 11.11.20 - 10:18
Не понял обработка Контроль онлайн ККМ (онлайн ККТ) (для платформы 7.7) http://catalog.mista.ru/public/639829/ показывает какие чеки, которые переданы в ОФД, или в базе 1С?
   serpentt
 
6 - 11.11.20 - 10:23
(0) есть шаблон(набор методов) для работы с Такском. http://catalog.mista.ru/public/1305664/
   Mafiozaa
 
7 - 11.11.20 - 10:45
Разобрался, влез в офд и оттуда выцепил что нужно
   Mafiozaa
 
8 - 11.11.20 - 10:52
Вопрос в другом как теперь продавцу догнать зетку за нужные даты, для отчета перед бухгалтерией
   Mafiozaa
 
9 - 11.11.20 - 10:52
Ибо половина тех зеток что они сдали, неправильные
   Mikhail Volkov
 
10 - 11.11.20 - 10:57
(6) У меня была ситуация: отбивали чек, но в Альфа-Авто он не создался по причине: Ошибка получения фискальных реквизитов пробитого чека (в журнале регистрации действий кассира). А в ФР АТОЛ-11Ф чек записался, и был отправлен в ОФД. Ошибку не заметили повторили чек, в ОФД он уже лишний. Хотелось бы из Альфа-Авто получить отчет по чекам переданным в ОФД. Возможно? (ответ желательно в X-отчет в 1С возможен?))

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.