Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Настройка апача 2.2

Настройка апача 2.2
Я
   xteam777
 
10.11.20 - 21:53
Установил апач 2.2.
Опубликовал базу 1С. Она успешно прописалась в конфигах апача.
Мне нужно сделать чтобы при вводе ип-адреса сразу открывалась статичная веб страница, а не веб клиент 1С.
Как это сделать?
   Asmody
 
1 - 10.11.20 - 22:50
(0) прописать в конфиге апача
   xteam777
 
2 - 10.11.20 - 22:56
Я не знаю что именно прописать, поэтому и спрашиваю тут. Есть домен 1ctest.ru. я создал поддомен app.1ctest.ru. оба они указывают на один ip адрес апача.

Прописал vhosts:
<VirtualHost *:80>
    DocumentRoot "C:/Program Files (x86)/Apache Software Foundation/Apache2.2/htdocs/app/"
    ServerName http://www.app.1ctest.ru
    ServerAlias app.1ctest.ru
</VirtualHost>

<VirtualHost *:80>
    DocumentRoot "C:/Program Files (x86)/Apache Software Foundation/Apache2.2/htdocs/"
    ServerName http://www.1ctest.ru
    ServerAlias 1ctest.ru
</VirtualHost>

Вот кусок из httpd:
# 1c publication
Alias "/app" "C:/Program Files (x86)/Apache Software Foundation/Apache2.2/htdocs/app/"
<Directory "C:/Program Files (x86)/Apache Software Foundation/Apache2.2/htdocs/app/">
    AllowOverride All
    Options None
    Order allow,deny
    Allow from all
    SetHandler 1c-application
    ManagedApplicationDescriptor "C:/Program Files (x86)/Apache Software Foundation/Apache2.2/htdocs/app/default.vrd"
</Directory>

При заходе через домен и через поддомен открывается 1С. А надо чтобы при заходе на домен открывался index.html. Что я не так делаю?
   Asmody
 
3 - 10.11.20 - 23:14
NameVirtualHost *:80
   Asmody
 
4 - 10.11.20 - 23:15
И в DocumentRoot лучше последний слеш в имени пути не ставить
   xteam777
 
5 - 11.11.20 - 11:02
Сейчас так:

Alias "/app" "C:/Program Files (x86)/Apache Software Foundation/Apache2.2/htdocs/"
<Directory "C:/Program Files (x86)/Apache Software Foundation/Apache2.2/htdocs/">
    AllowOverride All
    Options None
    Order allow,deny
    Allow from all
    SetHandler 1c-application
    ManagedApplicationDescriptor "C:/Program Files (x86)/Apache Software Foundation/Apache2.2/htdocs/default.vrd"
</Directory>

<NameVirtualHost *:80>
    DocumentRoot "C:/Program Files (x86)/Apache Software Foundation/Apache2.2/htdocs"
    ServerName http://www.app.1ctest.ru
    ServerAlias app.1ctest.ru
</VirtualHost>

<NameVirtualHost *:80>
    DocumentRoot "C:/Program Files (x86)/Apache Software Foundation/Apache2.2/htdocs2"
    ServerName http://www.1ctest.ru
    ServerAlias 1ctest.ru
</VirtualHost>

Перезапустил апач. Все равно при заходе на http://www.1ctest.ru открывается 1С. Попробовал убрать файл Apache2.2/htdocs/default.vrd. При заходе на http://www.1ctest.ru пишет ошибку, что не может найти этот файл.
   NeiTRoN4ik
 
6 - 11.11.20 - 11:51
Знаю только как через порты разные.

#Listen 12.34.56.78:80

Listen localhost:20999 - это для 1С

#ServerName http://www.example.com:80
ServerName localhost:80 - это для стандартного обращения
   xteam777
 
7 - 11.11.20 - 12:15
(6) Домен можно настроить только на 80 порт. Не подходит
   Asmody
 
8 - 11.11.20 - 12:25
(5) И апач не ругнулся на такое?
Опция NameVirtualHost *:80 должна быть до секций VirtualHost
И без скобок
   Asmody
 
9 - 11.11.20 - 12:25
   xteam777
 
10 - 11.11.20 - 14:35
Короче сделал двумя разными ip

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.