Вход | Регистрация
 

В новой КД3 нет AdditionalInfo

В новой КД3 нет AdditionalInfo
Я
   pumba055
 
09.11.20 - 14:18
Коллеги, в новой версии КД3 нет AdditionalInfo, кто сталкивался? Как бороться?
   spiller26
 
1 - 09.11.20 - 14:44
(0) Да нет.
   spiller26
 
2 - 09.11.20 - 14:50
Вместо AdditionalInfo можно попробовать воспользоватся ДополнительныеРеквизиты или использовать флаг Используется алгоритм конвертации, и описать заполнения вручную

https://forum.infostart.ru/forum15/topic190942/
   spiller26
 
3 - 09.11.20 - 14:59
//Вот кусочек кода


//отправка ПКО_Справочник_Номенклатура_Отправка_ПриОтправкеДанных

Если Выборка.Следующий() И Выборка.АлкогольнаяПродукция Тогда
    
    ЗаполнитьЗначенияСвойств(ДанныеXDTO, Выборка);
    ДанныеВидАК = Новый Структура("Код, Наименование, ВидЛицензии",
                Выборка.ВидАлкогольнойПродукции_Код,
                Выборка.ВидАлкогольнойПродукции_Наименование,
                Выборка.ВидАлкогольнойПродукции_ВидЛицензии);
    ДанныеXDTO.Вставить("ВидАлкогольнойПродукции", ДанныеВидАК);
    
КонецЕсли;

//получение ПКО_Справочник_Номенклатура_Получение_ПриКонвертацииДанныхXDTO

Если ДанныеXDTO.Свойство("АлкогольнаяПродукция") И ДанныеXDTO.АлкогольнаяПродукция Тогда
    Если ДанныеXDTO.Свойство("ВидАлкогольнойПродукции") Тогда
        ПолученныеДанные.ДополнительныеСвойства.Вставить("ВидАлкогольнойПродукции", ДанныеXDTO.ВидАлкогольнойПродукции);
    КонецЕсли;        
КонецЕсли;

//и здесь присвоение ПКО_Справочник_Номенклатура_Получение_ПередЗаписьюПолученныхДанных
   spiller26
 
4 - 09.11.20 - 14:59
ПолученныеДанные_ВидАлкогольнойПродукции = ПолученныеДанные.ДополнительныеСвойства.ВидАлкогольнойПродукции;
    
    ВидАлкогольнойПродукции_Код = "";
    Если ПолученныеДанные_ВидАлкогольнойПродукции.Свойство("Код") Тогда
        ВидАлкогольнойПродукции_Код = ПолученныеДанные_ВидАлкогольнойПродукции.Код;
    КонецЕсли;
   zippygrill
 
5 - 10.11.20 - 12:37
В дополнительныеСвойства а не Реквизиты
   mikecool
 
6 - 10.11.20 - 12:57
а кд3 то еще сырая...
   rozer76
 
7 - 10.11.20 - 13:16
в смысле в "новой" КД3? 

3.0.5.3     27.04.17 

Три года это "новая"?

Или в формате очередном убрали AdditionalInfo?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.