Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Сравнение ячеек таблицы

Сравнение ячеек таблицы
Я
   Lone HermiT
 
05.11.20 - 13:28
Есть таблица. в таблице есть колонка "НомерСтроки".
эту всю таблицу я записываю в текстовый файл.
нужно сделать так, чтобы если НомерСтроки изменился, в файл записывало какую-то разделяющую строку. не могу додуматься, как это сделать
   asady
 
1 - 05.11.20 - 13:38
(0) Если текущийНомерСтроки <> стр.НомерСтроки Тогда
ВывестиРазделитель(твойФайл);
текущийномерСтроки = стр.НомерСтроки;
   Lone HermiT
 
2 - 05.11.20 - 13:43
а для счетчика как быть? я вывожу строки при помощи счетчика:
Для  Счетчик = 0 по МассивСтрокДанных.Количество() - 1  Цикл
        
            ТекстЗапись.ЗаписатьСтроку("ОписаниеРеквизитовТЧ" + ";"
            + Строка.ИмяТЧ + ";"
            + МассивСтрокДанных[Счетчик].Тип + ";"
            + МассивСтрокДанных[Счетчик].Имя + ";"    
            + МассивСтрокДанных[Счетчик].ТипОбъекта + ";"
            + МассивСтрокДанных[Счетчик].Значение + ";"
            + МассивСтрокДанных[Счетчик].Дата + ";"
            + МассивСтрокДанных[Счетчик].Номер + ";"
            + МассивСтрокДанных[Счетчик].НомерСтроки + ";"
            
            ); 
                    КонецЦикла;
   vova1122
 
3 - 05.11.20 - 13:57
Вопрос непонятен. У тебя и так в файле каждая строка Массива будет в новой строке
   vova1122
 
4 - 05.11.20 - 14:04
НомерСтрокиОлд="";
Для  Счетчик = 0 по МассивСтрокДанных.Количество() - 1  Цикл
СформированнаяСтрока="ОписаниеРеквизитовТЧ" + ";"
            + Строка.ИмяТЧ + ";"
            + МассивСтрокДанных[Счетчик].Тип + ";"
            + МассивСтрокДанных[Счетчик].Имя + ";"    
            + МассивСтрокДанных[Счетчик].ТипОбъекта + ";"
            + МассивСтрокДанных[Счетчик].Значение + ";"
            + МассивСтрокДанных[Счетчик].Дата + ";"
            + МассивСтрокДанных[Счетчик].Номер + ";"
            + МассивСтрокДанных[Счетчик].НомерСтроки + ";"
                     ; 
Если МассивСтрокДанных[Счетчик].НомерСтроки<>НомерСтрокиОлд тогда
СформированнаяСтрока=СформированнаяСтрока+Символы.ПС+"-------------------------------;
КонецЕсли;
ТекстЗапись.ЗаписатьСтроку(СформированнаяСтрока);
НомерСтрокиОлд=МассивСтрокДанных[Счетчик].НомерСтроки;
КонецЦикла;

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.