Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Отключение печати отчета о открытии/закрытии смены на уровне 1с.

Отключение печати отчета о открытии/закрытии смены на уровне 1с.
Я
   JohnDevis
 
03.11.20 - 12:29
Нужно отключить печать чеков о закрытии/открытии смены через 1с. Пытались передавать параметр electronically вместе с xml пакетом который уходит на драйвер, не помогает. Может кто сталкивался?
   JohnDevis
 
1 - 03.11.20 - 14:04
ап
   JohnDevis
 
2 - 03.11.20 - 14:38
Неужели никто не реализовывал?
Извиняюсь, что забыл указать!
Касса АТОЛ 22Ф на 5-ой платформе. Конфигурация 1С:Розница 2.3.6.17. Переделанная для работы без кассира. Соответственно нужно, чтобы открытие и закрытие смены происходило без печати их на кассе.
Несколько магазинов работают отлично, на них АТОЛ 22Ф на платформе 2.5, в которой отключалось что нужно в самом драйвере.
На новых прошивках данную функцию убрали. Техподдержка АТОЛа сказали решать средствами учетного ПО.
Попытка с нижеописанным листингом результата не дала:
Функция ПолучитьXMLПакетДляОперации(ОбщиеПараметры, РевизияИнтерфейса = 0) Экспорт
    
    ЗаписьXML = Новый ЗаписьXML();
    ЗаписьXML.УстановитьСтроку("UTF-8");
    ЗаписьXML.ЗаписатьОбъявлениеXML();
    ЗаписьXML.ЗаписатьНачалоЭлемента("InputParameters");
    ЗаписьXML.ЗаписатьНачалоЭлемента("Parameters");

    Если РевизияИнтерфейса >= 3000 Тогда  // Версия стандарта 3.0 (ОФД 1.1)

        ЗаписьXML.ЗаписатьАтрибут("CashierName", ?(ОбщиеПараметры.Свойство("Кассир"), XMLСтрока(ОбщиеПараметры.Кассир), НСтр("ru='Администратор'")));
        ЗаписьXML.ЗаписатьАтрибут("CashierINN" , ?(ОбщиеПараметры.Свойство("КассирИНН"), XMLСтрока(ОбщиеПараметры.КассирИНН), ""));
        Если ОбщиеПараметры.Свойство("АдресРасчетов") И НЕ ПустаяСтрока(ОбщиеПараметры.АдресРасчетов) Тогда   
            ЗаписьXML.ЗаписатьАтрибут("SaleAddress", XMLСтрока(ОбщиеПараметры.АдресРасчетов));
        КонецЕсли;
        Если ОбщиеПараметры.Свойство("МестоРасчетов") И НЕ ПустаяСтрока(ОбщиеПараметры.МестоРасчетов) Тогда  
            ЗаписьXML.ЗаписатьАтрибут("SaleLocation", XMLСтрока(ОбщиеПараметры.МестоРасчетов));
        КонецЕсли;
    Иначе
        ЗаписьXML.ЗаписатьАтрибут("CashierName" , ?(ОбщиеПараметры.Свойство("Кассир"), XMLСтрока(ОбщиеПараметры.Кассир), НСтр("ru='Администратор'")));
        ЗаписьXML.ЗаписатьАтрибут("CashierVATIN", ?(ОбщиеПараметры.Свойство("КассирИНН"), XMLСтрока(ОбщиеПараметры.КассирИНН), ""));
                //

        ЗаписьXML.ЗаписатьАтрибут("electronically", "true");
        //

    КонецЕсли;
    
    ЗаписьXML.ЗаписатьКонецЭлемента();
    ЗаписьXML.ЗаписатьКонецЭлемента();
    
    Возврат ЗаписьXML.Закрыть();
    
КонецФункции
   JohnDevis
 
3 - 03.11.20 - 16:28
Людиииии, ну помогите же кто-нибудь!
   Kondarat
 
4 - 03.11.20 - 17:25
В общих модулях управления ТО ищем:

Функция ВыполнитьКоманду(Команда, ВходныеПараметры = Неопределено, ВыходныеПараметры = Неопределено,
                         ОбъектДрайвера, Параметры, ПараметрыПодключения) Экспорт

.
.
.
    // Открыть смену

    ИначеЕсли Команда = "OpenShift" ИЛИ Команда = "ОткрытьСмену" Тогда
        Результат = ОткрытьСмену(ОбъектДрайвера, Параметры, ПараметрыПодключения, ВходныеПараметры, ВыходныеПараметры);
        
    // Закрыть кассовую смену

    ИначеЕсли Команда = "CloseShift" ИЛИ Команда = "ЗакрытьСмену" Тогда
        Результат = ЗакрытьСмену(ОбъектДрайвера, Параметры, ПараметрыПодключения, ВходныеПараметры, ВыходныеПараметры);
.
.



КонецФункции
   Aleksey
 
5 - 03.11.20 - 17:30
   JohnDevis
 
6 - 04.11.20 - 13:20
(5) Убрали это на 5 платформе.
   JohnDevis
 
7 - 04.11.20 - 13:23
(4) Я подставлял elecronically, true во "ВходныеПараметры", это не помогло. Никакой реакции от кассы, она как печатала так и печатает отчеты о закрытии/открытии смены.
   Aleksey
 
8 - 04.11.20 - 14:14
(6) Что такое 5 платформа?
   Aleksey
 
9 - 04.11.20 - 14:15
Если ты про 10 драйевра , то там немного параметр другой, нужна передавать не 2, а 02
Т2Р1П98=02
   JohnDevis
 
10 - 05.11.20 - 09:41
(8) Пятая платформа это поколение внутреннего ПО кассы, раньше была 2.5 и на ней работало программирование таблиц в кассе, вот это вот Т2Р1П98=02, но на пятой платформе это убрали. Как написано в базе знаний службы технической поддержки Атол: "В отличии от касс на платформе 2.5 в 5.0 нет таблиц, рядов, полей и т.д. Номера, описание, тип и значения настроек описаны в документации ". Но такой параметр как отключение печати Z-отчета убрали из списка параметров. И теперь это надо реализовывать как то через 1с.
   Aleksey
 
11 - 05.11.20 - 11:50
   JohnDevis
 
12 - 05.11.20 - 12:00
(11) я читал эту статью. Этот пример который там показан для Тест драйвера ККТ. И он не убирает печать отчетов, он используется для единовременного закрытия или открытия кассы без печати отчета, а мне нужно автоматизировать этот процесс и добавить параметр в пакет данных уходящих в драйвер и с него в кассу.
   JohnDevis
 
13 - 05.11.20 - 17:02
Помогите кто нибудь!
   JohnDevis
 
14 - 10.11.20 - 17:24
Помогите, пожалуйста, не могу решить.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.