Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Просмотр обработки ожидания формекс

v7: Просмотр обработки ожидания формекс
Я
   kupec
 
03.11.20 - 11:44
Добрый день. Ситуация такая....
Использую ОбработкуОжидания() от FormEx. Почему то не могу получить запущенную на данный момент обработку в виде строки.

Вот код:
Перем ФормаРасш;
Процедура ПослеСозданияФормы()
ФормаРасш = СоздатьОбъект("РасширениеФормы");
ФормаРасш.УстановитьФорму(Форма);
Конецроцедуры

Процедура Мониторинг()
//включается по нажатию кнопки на форме
ФормаРасш.ОбработкаОжидания("МояОбработка",МойИнтервал);
КонецПроцедуры

Процедура МояОбработка()
Сообщить("Сработало");
КонецПроцедуры

Процедура СообщитьТекущуюОбработку()
НашаПроцедура=ФормаРасш.ОбработкаОжидания()
Сообщить(НашаПроцедура);//всегда ПУСТАЯ строка, хотя сообщить("сработало") вылезает
КонецПроцедуры

Как добиться информации о запущенной процедуре?
   kupec
 
1 - 03.11.20 - 11:49
НашаПроцедура=ФормаРасш.ОбработкаОжидания()

При таком варианте ругается на то, что не все параметры заданы

НашаПроцедура=ФормаРасш.ОбработкаОжидания(,)
НашаПроцедура=ФормаРасш.ОбработкаОжидания("","")

Эти два варианта тоже не помогают
   kupec
 
2 - 03.11.20 - 13:17
Неужели никто с такой штукой не сталкивался?
   kupec
 
3 - 03.11.20 - 13:17
Стандартная процедура ОбработкаОжидания() выдает текущую запущенную процедуру, а вот формексовская не хочет
   Mikeware
 
4 - 03.11.20 - 13:19
(2) а ранее-то была установлена?
   kupec
 
5 - 03.11.20 - 13:22
(4) естественно была, так как процедура МояОбработка() выдает периодически сообщения
   kupec
 
6 - 03.11.20 - 13:28
Версия FormEx 2.0.5.123
   kupec
 
7 - 03.11.20 - 13:40
Поменял на версию 2.0.5.148 - Результат тот же самый
   Ёпрст
 
8 - 03.11.20 - 21:15
(0) а зачем знать то ?
Пользуй объект Таймер.. там точно знаешь, что запущаешь
   АЛьФ
 
9 - 05.11.20 - 09:12
Поправил в 151.
   Arbuz
 
10 - 05.11.20 - 14:18
(9) Спрошу здесь. Уважаемый АЛьФ, а в эту версию (151) включены исправления, предложенный Djelf'ом на 1с++ форуме, по вылетам при завершении сеанса и вылет при Окна.ВидимостьМеню("Любое значение",0) с контекстным меню?
   Злопчинский
 
11 - 05.11.20 - 17:59
такс, надо новый формекс качнуть
   АЛьФ
 
12 - 06.11.20 - 09:35
2(10) Включены.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.