Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

X-отчет в 1С возможен?

X-отчет в 1С возможен?
Я
   Mikhail Volkov
 
01.11.20 - 11:48
Например, в Альфа-Авто во Фронт-кассира есть кнопка Х-отчета, по которой ФР его выводит в виде чека. А в саму Альфа-Авто его вывести можно, как? (в 7-ке в ТиС вроде делал, не помню) Сейчас в Альфа-Авто:
// Печать Х отчета
Функция ДействиеХОтчет(ЭтаФорма) Экспорт
    
    Если УстановленРежим("Блокировка") Тогда  Возврат 0; КонецЕсли;
    
    //проверим право
    Если НЕ фкСмотретьФискальныеСчетчики Тогда
        ОткрытьДиалог("Вам запрещено выполнять эту операцию", СтатусСообщения.Важное);
        Возврат 0;
    КонецЕсли;
    
    Если ПустаяСтрока(GUID_ФР) Тогда
        ОткрытьДиалог("Фискальный регистратор не установлен. X-отчет снят быть не может.", СтатусСообщения.Важное);
        Возврат 0;
    КонецЕсли;
    
    //Снимем отчет
    КодОшибки=Рарус_Компонента.ЗаказатьВыполнениеДействияСинхронно(GUID_ФР,"Х_Отчет",,ТаймаутФР);
    Если НЕ РезультатРаботыСОборудованием("Фискальный регистратор",КодОшибки,Рарус_Компонента.ОписаниеОшибки) Тогда
        ЗаписатьВФайлЛога("Снять X-отчет",КодОшибки,"Операция не выполнена",GUID_ФР,1);
        Возврат 0;
    Иначе
        ЗаписатьВФайлЛога("Снять X-отчет",КодОшибки,Рарус_Компонента.ОписаниеОшибки);
    КонецЕсли;
    
КонецФункции

Функция РезультатРаботыСОборудованием только КодОшибки анализирует.
При закрытии кассовой смены выдало ошибку разности оборотов ККМ (в Альфа-Авто) и ФР. Обслуживаю Альфа-Авто удалено, Х-отчет не видел. Оказывается ФР не записал в Альфа-Авто возвратный чек (выдал в ЖР: Ошибка компиляции при вычислении выражения или выполнении фрагмента кода: {(1,1)}: Неправильная константа типа Дата), а в себя записал, и отправил в ОФД. Если бы у меня был Х-отчет на тот момент, то разобрался бы, и ошибку бы исправил до закрытия смены.
Смену то закрыл, теперь спустя неделю выяснилось по отчету ОФД, что по одному чеку отбито 2 возвратных чека, вроде как скрыли часть своей выручки. И главное: надо ли для исправления отчетности отбивать еще такой же чек на оплату, чтобы отправить его в ОФД? После чего удалить его в Альфа-Авто, или сделать возвратный чек без его отправки в ОФД.
   МимохожийОднако
 
1 - 01.11.20 - 12:11
Возможен.
   Mikhail Volkov
 
2 - 01.11.20 - 12:27
(1) В какой конфигурации код X-отчета открытый, или пример?
   МимохожийОднако
 
3 - 01.11.20 - 12:40
Посмотри в УТ11 или библиотеку подключ. оборудования
   Mikhail Volkov
 
4 - 01.11.20 - 13:27
Смотрю УПП/КА1, не понимаю...
Функция ОтчетБезГашения(Идентификатор, Пароль) Экспорт
    
    Обработка = Неопределено;
    Объект    = Неопределено;
    Результат = ПолучитьОбъектДрайвера(Идентификатор, Обработка, Объект);

    Если НЕ ЗначениеЗаполнено(Результат) Тогда
        Результат = Обработка.XОтчет(Объект, Пароль, Неопределено, Неопределено);
        мОписаниеОшибки = Объект.ОписаниеОшибки;
    Иначе
        мОписаниеОшибки = ПолучитьТекстОшибкиПодключенияТО("ФР");
    КонецЕсли;

    Возврат Результат;

КонецФункции// ОтчетБезГашения()


(3) В УТ11 так же?
   Mikhail Volkov
 
5 - 01.11.20 - 14:14
Наверное вопрос не точно задал: возможен ли вывод X-отчета на экран компьютера (или на принтер), или только в виде чека ФР/кассы ККМ?
   Mikhail Volkov
 
6 - 01.11.20 - 15:23
В модели оборудования выдрано: ФР FPrint-22K (1С-обработка + драйвер "Атол"). Как посмотреть эту 1С-обработку?
   Сияющий Асинхраль
 
7 - 01.11.20 - 20:02
Вообще-то сам по себе Х-Отчет, это как раз и есть отчет, который строит именно кассовый аппарат, так что теоретически нечто подобное на экране соорудить можно, но учитывая, что строить отчет должен именно кассовый аппарат, а не учетная система, то не факт, что отчет на экране всегда будет совпадать с отчетом на кассовом аппарате, потому что для учетных систем кассовый аппарат в большинстве своем представляет собой черный ящик, который просто реагирует на команды поступающие из учетной системы...
   Mikhail Volkov
 
8 - 01.11.20 - 20:37
Вроде помню в ТиС в 90-х делал X-отчет по ставкам НДС, по отделам... данные именно из кассы ККМ, но не помню как!? Сейчас это невозможно?
   МимохожийОднако
 
9 - 01.11.20 - 20:52
Возможно. Если есть желание\умение программировать в 1С. Определись, какой нужен отчет и сделай аналогичный по чекам за день. Этот фактически тот же Х-Отчет. Но проще выполнить с ККМ. Нет смысла экономить на рулонах
   johnnik
 
10 - 02.11.20 - 00:18
В Рознице2, УТ11, УНФ и БП 3.0 есть отчет без гашения - это и есть Х-отчет. Спрятан обычно в менюхах "Продажи" или "Финансы" - опция "Управление фискальным устройством".
   Сияющий Асинхраль
 
11 - 02.11.20 - 00:33
(8) Еще раз, X-Отчет - это и есть отчет, который строиться на фискальном устройстве. Если нечто подобное строится с помощью команды из 1С, то 1С просто выдает команду на фискальник о построении отчета, фискальник его и делает.
Да, как сказал (9) в принципе можно нечто подобное соорудить по данным чеков из учетной системы, НО нет никакой гарантии, что чеку в учетной системе однозначно соответствует чек на ФР. Может случиться что угодно, фискальник отвалится, сеть отвалится, 1С заглючит и не сможет передать на фискальник данные и много-много других бяк. Иными словами, можешь попытаться создать отчет, соответствующий отчет по чекам за день, но сто процентов верный Х-отчет будет только на фискальнике...
   Mikhail Volkov
 
12 - 02.11.20 - 07:25
(9) Это все сделано, есть, но они работают по данным учетной системы самой Альфа-Авто, не ФР/кассы ККМ. А тут ситуация такая: чек в ФР записался, отправился в ОФД, а в Альфа-Авто нет! Раньше работали кассовыми документами, делали ПКО или РКО, и отбивали их фронт-кассира. А теперь освоили документ Чек на оплату, который создается по основанию фронт-кассира. И даже не записывается в случае ошибки. Работаю удаленно, мне бы сразу запросить прислать чек Х-отчета, или отчет из ОФД, когда пошли ошибки будь то в кассе денег нет. Наверное понял в чем дело. После чеков набили, набралась по чекам нужная сумма, отбили возвратный чек, оказалось он уже 2-й!
(10) Х-отчет только в виде чека из ФР, на экран выводит?
(11) Видимо с тех пор (8) драйвера АТОЛ качественно изменились, и вывести на экран 1С X-отчет невозможно... А это точно, или предположил?
   Kongo2019
 
13 - 02.11.20 - 08:06
X-отчет никогда на экран не выводится. Он строится средствами самого ККМ, и вывод только на рулон.
Все остальное это эмуляция.
   Mikhail Volkov
 
14 - 02.11.20 - 08:31
А 2-й не технический вопрос: надо ли для исправления отчетности ОФД отбивать еще такой же чек на оплату, чтобы отправить его в ОФД? После чего удалить его в Альфа-Авто, или сделать возвратный чек без его отправки в ОФД. Сейчас по данным ОФД у нас чеков на меньшую сумму, получается мы скрыли часть выручки.
   Масянька
 
15 - 02.11.20 - 08:33
(0) А смысл (на экран)?
Х-отчет и сделан для проверки кассы: сколько пробили vs сколько в программе.
   Kongo2019
 
16 - 02.11.20 - 09:08
(14) Это надо у вашего буха спрашивать, вопрос больше организационный чем технический.
   Mikhail Volkov
 
17 - 02.11.20 - 11:25
(15) Работаю удаленно, кассу ККМ в глаза не видел!
(16) Да, вопрос больше организационный чем технический, они у меня спрашивают. Если сделают исправительный чек, то что потом с ним делать: удалить (пометить на удаление), распровести, или сделать ему возвратный чек без его отправки в ОФД? Боюсь: только поставлю галочку для отбития чека на ФР, и он отправит в ОФД!?
   Масянька
 
18 - 02.11.20 - 11:34
(17) Ты не понял.
Х-отчет, как правило, делают перед закрытием смены (перед гашением кассы), чтобы проверить соответствие нала в кассе (пробитые чеки) и денежном ящике. Еще при некоторых проверках делали.
Поэтому нет смысла делать этот отчет в программе.
   Mikhail Volkov
 
19 - 02.11.20 - 12:38
Нашел в архивах 7.7:
Процедура СформироватьX()
    
    ФР = СоздатьОбъект("AddIn.FprnM45");
    // занимаем порт

    ФР.DeviceEnabled = 1;
    Если ФР.ResultCode <> 0 тогда
        Сообщить("Не удалось занять порт", "!");
            Возврат;
    КонецЕсли;

    // если смена открыта снимаем отчет

      Если ФР.SessionOpened = 1 тогда

        // Отчет по секциям

        ФР.Mode = 2;
        Если ФР.SetMode() <> 0 тогда
            Сообщить("Не удалось войти в режим регистрации", "!");
            Возврат;
        КонецЕсли;
        ФР.ReportType = 7;
        ФР.Report();
    
        // снимаем X-отчет

        ФР.Mode = 2;
        ФР.SetMode();
        ФР.ReportType = 2;
        ФР.Report();
    Иначе
        Предупреждение("Не открыта кассовая смена!",60);
      КонецЕсли;

    // освобождаем порт

    ФР.DeviceEnabled=0;   
КонецПроцедуры

Да, не на экран, а на чек кассы ККМ - значит вывод на экран X-отчета в 1С невозможен.

(18) Еще раз: работаю удаленно, кассу ККМ в глаза не видел! Чтобы посмотреть X-отчет мне надо просить пользователя у кассы (кассир тоже может работать удаленно) его сканировать, и мне прислать. Запрашивать отчет в ОФД тоже бесполезно, высылают только на эл. адрес кассира.

Остался только без ответа вопрос (14), но технари вряд ли помогут... Всем спс.
   Mikhail Volkov
 
20 - 03.11.20 - 06:58
Вроде нашел Кассовый чек коррекции по 54-ФЗ [http://www.kassa-online.su/2017/09/19/chek-korrekcii-pod-54-fz/] - знакомая картинка, но не пользовался. Только не понял: какой ставить тип чека (Коррекция прихода или возврата прихода), и где в нем писать причину (на какой вкладке)?
   Масянька
 
21 - 03.11.20 - 08:15
(20) Ты как с луны свалился...
В кассе (ККМ) какая сумма? Какая сумма в ОФД?
   Mikhail Volkov
 
22 - 03.11.20 - 10:17
(21) В ОФД сумма меньше на сумму возвратного чека, который не записался в Альфа-Авто: Ошибка получения фискальных реквизитов пробитого чека (в журнале регистрации действий кассира). Вроде как скрыли эту сумму от налоговой. А Альфа-Авто все нормально, не хочется ничего менять.
   Масянька
 
23 - 03.11.20 - 11:05
(22) Я спрашивала про кассу (ККМ), а не про программу.
В кассе (ККМ) сколько?
   Mikhail Volkov
 
24 - 03.11.20 - 11:49
(23) На тот момент они равны были, обе меньше чем на самом деле (на сумму лишнего возвратного чека). А зачем это? Вопрос про Кассовый чек коррекции по 54-ФЗ. Как его правильно сделать, чем?
   Масянька
 
25 - 03.11.20 - 11:56
(24) Затем.
Чек (в Альфа-авто) - продажа или возврат?
   Mikhail Volkov
 
26 - 03.11.20 - 12:32
(25) И тот, и другой. А в ФР (и ОФД) 2 возврата по одному чеку продажи.
   Kongo2019
 
27 - 03.11.20 - 13:25
Ну так зайди в утилиту управления АТОЛ и пробей нужный чек. проблема то? И все выровняется.
   Масянька
 
28 - 03.11.20 - 13:42
(26) Не фига не поняла...
Давай на пальцах:
есть продажа (чек1) = 10 рэ.
есть возврат (чек2) = 10 рэ.
В программе: чек1, чек2, а в ККМ и ОФД - чек1 и 2 (два) чек2?
   Mikhail Volkov
 
29 - 03.11.20 - 14:17
(28) Да, так.
(27) Что за утилита, Тест драйвера ККТ? В нем нужно писать причину коррекции. Куда писать, в какое поле (вкладка)? И какой ставить тип чека: Коррекция прихода или возврата прихода?
   Масянька
 
30 - 03.11.20 - 14:25
(29) Открой и посмотри. По-моему, в тесте драйвера бьется.
Коррекция расхода.
 
 Рекламное место пустует
   Mikhail Volkov
 
31 - 03.11.20 - 14:41
(30) Без причины коррекции?
   Масянька
 
32 - 03.11.20 - 15:37
(31) https://onlinekassa.guru/instrukcii/vozvrat-oshibochno-probitogo-cheka.html
Мы делали по инструкции: акт, чеки и в книгу кассира. Пока не проверяли и вопросов (у налоговой) не было. Хотя...
   Mikhail Volkov
 
33 - 03.11.20 - 15:51
(32) Там все исправления делаются обычными (не коррекции) чеками до закрытия смены. У нас обнаружили, что лишний возврат более недели назад.
   Mikhail Volkov
 
34 - 03.11.20 - 17:38
А на сайте ОФД (где отчеты запрашиваем) кассовый чек коррекции не сделать? В базе Альфа-Авто (и в ФР) он же не нужен.
   Mikhail Volkov
 
35 - 05.11.20 - 07:51
В статье Как исправить ошибки в чеках с помощью чека коррекции? (https://its.1c.ru/db/kkt/content/112/hdoc) написано:
Чек коррекции для исправления ошибки в кассовом чеке применяется, только если используется ФФД 1.1. Если речь идет о ФФД 1.0 или 1.05, то чек коррекции для исправления ошибок не применяется.
В Тест драйвера ККТ можно увидеть версию ФФД, или только в чеке? Мне чек присылали только в апреле с ФФД ККТ 1.05, не знаю обновлялись ли...
   Mikhail Volkov
 
36 - 07.11.20 - 19:27
Тест драйвера ККТ при включении галкой ошибку дает: (-14) Порт занят. Почему?
   МимохожийОднако
 
37 - 08.11.20 - 17:37
(36) 1С закрой
   Mikhail Volkov
 
38 - 08.11.20 - 18:00
(37) Дождался пока все выйдут из Альфа-Авто, даже сервер перезагрузил... все равно: (-14) Порт занят!?
   Kongo2019
 
39 - 08.11.20 - 18:10
   Mikhail Volkov
 
40 - 08.11.20 - 18:56
(39) В Диспетчере устройств Windows сервера терминала вообще не вижу портов. Где смотреть службу EthernetOverUSB? На локальном компе, к которому подключен ФР АТОЛ-11Ф. Сейчас он выключен, его не вижу.
Не знаю, нужно ли делать Кассовый чек коррекции? В ОФД лишний чек возврата, который не записался в Альфа-Авто. По нашим отчетам больше выручки, чем по данным ОФД, т.е. выручку мы не скрываем, наоборот... может достаточно объяснительной в налоговую?
   Mikhail Volkov
 
41 - 08.11.20 - 19:18
+ (-3) 10060 Попытка установить соединение была безуспешной, т.к. от другого компьютера за требуемое время не получен нужный отклик, или было разорвано уже установленное соединение из-за неверного отклика уже подключенного компьютера
   Mikhail Volkov
 
42 - 09.11.20 - 06:33
А сегодня нет ошибок, вроде пробил!? Надо проверить в ОФД...
   Mikhail Volkov
 
43 - 09.11.20 - 12:30
Обычный чек https://receipt.taxcom.ru/v01/show?fp=405595841&s=5900.05&sf=False&sfn=False, ни где не указано, что Чек коррекции и тип Коррекция возврата расхода!? Такой чек мог отбить сам кассир из Альфа-Авто, а после закрытия смены удалить из Альфа-Авто. Наверняка с этим чеком будут проблемы при закрытии смены?
   Mikhail Volkov
 
44 - 09.11.20 - 18:00
Или чек коррекции возможен только с ФФД 1.1 (35)?
   Mikhail Volkov
 
45 - 11.11.20 - 10:16
Не понял Обработка для контроля онлайн ККМ (онлайн ККТ) http://catalog.mista.ru/public/628800/ показывает какие чеки, которые переданы в ОФД, или в базе 1С?
   Mikhail Volkov
 
46 - 11.11.20 - 12:36
+ > Обработка позволяет получать список зарегистрированных ККМ по договору, получать список z-отчетов по каждой ККМ или по всем ККМ по договору за период, получать список чеков по z-отчету или по конкретной ККМ за период, получать состав конкретного чека. Данные, которые обработка может получить, должны быть уже переданы онлайн-ККМ оператору фискальных данных
Вроде как чеки с сайта ОФД!?
   Mikhail Volkov
 
47 - 11.11.20 - 13:21
+ > ...если ваш ОФД - sbis.ru (СБИС)
Что это такое, как определить какой у нас ОФД (Такском-Касса)?
   VaDukE
 
48 - 11.11.20 - 13:39
можно получить суммы денежных регистров из ФР и вывести на экран
у штриха так:
Объект.RegisterNumber    = НомерРегистра;
Объект.GetCashReg(); 
СуммаПоРегистру        = Объект.ContentsOfCashRegister;
   Mikhail Volkov
 
49 - 11.11.20 - 13:45
(48) Откуда этот фрагмент кода, можно пополнее?
   Mikhail Volkov
 
50 - 11.11.20 - 14:22
(47) СБИС ОФД – больше чем терминал для передачи фискальных данных в ФНС... https://sbis.ru/ofd/service. А как определить какой у нас ОФД (Такском-Касса)?
   Mikhail Volkov
 
51 - 11.11.20 - 15:25
+ СБИС ОФД для обработки http://catalog.mista.ru/public/665846/, а для http://catalog.mista.ru/public/628800/ ОФД ofd.ru (Общество с ограниченной ответственностью «ПЕТЕР-СЕРВИС Спецтехнологии»). Что принципиальная разница?
   Mikhail Volkov
 
52 - 11.11.20 - 17:13
Как понял: на сайте ОФД должен бать инструментарий API, и для каждого он разный. Как это определить?
   Mikhail Volkov
 
53 - 11.11.20 - 17:23
На http://oblaqo.com/service/ofd-takskom/ стоит галка API для интеграций. И что дальше?
   Mikhail Volkov
 
54 - 12.11.20 - 06:20
(48) Неужели X-отчет с ФР в 1С возможен? Откуда этот фрагмент кода, можно пополнее?


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.