Вход | Регистрация
 

Установить иерархический режим просмотра списка.

Установить иерархический режим просмотра списка.
Я
   Zombi
 
30.10.20 - 14:25
Открываю форму выбора справочника, там режим просмотра = список.. Пишу в модуле формы выбора:

&НаКлиенте
Процедура ПриОткрытии(Отказ)

    Элементы.Список.Отображение = ОтображениеТаблицы.ИерархическийСписок;
    
КонецПроцедуры

Все равно открывается с режимом "Список". Как победить ее?
   Zombi
 
1 - 30.10.20 - 14:36
Еще и недоступно для изменения почему то:

https://yadi.sk/i/Fan-VdjpQ_Ofhg
   acht
 
2 - 30.10.20 - 14:37
Отбор по владельцу установи
   Zombi
 
3 - 30.10.20 - 14:40
(2) Установлен
   Zombi
 
4 - 30.10.20 - 14:41
Вот весь модуль формы выбора:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
    Список.Параметры.УстановитьЗначениеПараметра("Владелец", Параметры.Владелец);
    Элементы.Список.Отображение = ОтображениеТаблицы.Дерево;
    
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)

    Элементы.Список.Отображение = ОтображениеТаблицы.Дерево;
    
КонецПроцедуры
   hhhh
 
5 - 30.10.20 - 14:43
(4) может список запросом формируется. А в запросе нет дерева.
   Zombi
 
6 - 30.10.20 - 14:46
(5) Да, запросом. А как в запросе дерево сформировать?
   acht
 
7 - 30.10.20 - 14:47
(6) Настроить группировки динамического списика, или если нужна иерархия, указать основную таблицу
   Zombi
 
8 - 30.10.20 - 14:51
(7) Основная таблица указана:

https://yadi.sk/i/OIFv1MKJ3WZeog
   Zombi
 
9 - 30.10.20 - 14:59
Убрал произвольный запрос, все равно недоступно переключение режима просмотра.
   acht
 
10 - 30.10.20 - 15:01
(9) Если ты думаешь, что отбор по владельцу делается в запросе в секции ГДЕ, ты ошибаешся.
   Zombi
 
11 - 30.10.20 - 15:07
(10) Да я чтобы проверить, вообще из за запроса иерархия не работает или нет. Произвольный запрос у формы убрал галку, не помогло, иерархия недоступна все равно.
   hhhh
 
12 - 30.10.20 - 15:09
(11) там в запросе и РОдителя нет. КАкая иерархия?
   hhhh
 
13 - 30.10.20 - 15:10
(11) ИТОГИ ПО попробуй
   Zombi
 
14 - 30.10.20 - 15:11
(12) Сейчас вообще без запроса форма:

https://yadi.sk/i/sjRDU3EJ1cPLhA
   Zombi
 
15 - 30.10.20 - 15:16
Форма в расширении, думаю может в этом проблема. Сейчас справочник "Ячейки" даже когда через "Все функции" открываю, он без иерархии, и переключение режима недоступно.
   Zombi
 
16 - 30.10.20 - 15:18
Хотя в расширении настройки иерархии так же стоят:

https://yadi.sk/i/IAowUH3Jvo9J6g
   hhhh
 
17 - 30.10.20 - 15:33
(15) может убрать форму и по-новой загрузить. в общем, обновить как-то

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.