Вход | Регистрация
 

Запуск в режиме Отладка внешней печатной формы

Запуск в режиме Отладка внешней печатной формы
Я
   Alexs_set
 
28.10.20 - 13:52
//Уважаемые знатоки, подскажите пожалуйста, что делаю не верно?!
//В модуле объекта есть процедура:
Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода,ПараметрыПечати = Неопределено) Экспорт
    
    СтруктураТипов = ОбщегоНазначенияУТ.СоответствиеМассивовПоТипамОбъектов(МассивОбъектов);
    
    Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "ЗаказКлиента") Тогда
        
        УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(
            КоллекцияПечатныхФорм,
            "ЗаказКлиента",
            НСтр("ru = 'Заказ клиента'"),
            СформироватьПечатнуюФормуЗаказаКлиента(СтруктураТипов, ОбъектыПечати,ПараметрыПечати));
        
    КонецЕсли;
    
    Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "ЗаказПоставщику") Тогда
        
        УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(
            КоллекцияПечатныхФорм,
            "ЗаказПоставщику",
            НСтр("ru = 'Заказ поставщику'"),
            СформироватьПечатнуюФормуЗаказаПоставщику(СтруктураТипов, ОбъектыПечати, ПараметрыПечати));
        
    КонецЕсли;
        
    ФормированиеПечатныхФорм.ЗаполнитьПараметрыОтправки(ПараметрыВывода.ПараметрыОтправки, СтруктураТипов, КоллекцияПечатныхФорм);
    
КонецПроцедуры

// нужно запустить печатную форму в режиме Отладка
// Создаю форму, ссылку на документ - ЗаказКлиента и кнопку Печать
//По нажатию кнопки пишу след. код:

&НаСервере
функция ПечатьНаСервере()
    
    ОбъектФормы = РеквизитФормыВЗначение("Объект");
    МассивОбъектов = Новый Массив;
    МассивОбъектов.Добавить(Объект.ЗаказКлиента);
    ОбъектФормы.Печать(МассивОбъектов);      // ругается Недостаточно фактических параметров
    
Конецфункции

&НаКлиенте
Процедура Печать(Команда)
    ПечатьНаСервере();
КонецПроцедуры

//При проверке ошибок нет, но при запуске Файл -открыть, выбираю заказ и нажимаю кнопку - выходит ошибка Недостаточно фактических параметров
// ОбъектФормы.Печать(МассивОбъектов); - ругается на эту строчку.
// Подскажите, пожалуйста где и что не так!
   kobzon2
 
1 - 28.10.20 - 13:59
(0) Так передаешь 1 параметр, а там в процедуре печать их 5 просят.
   Kigo_Kigo
 
2 - 28.10.20 - 14:09
Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода,ПараметрыПечати = Неопределено)

ОбъектФормы.Печать(МассивОбъектов); 

Почувствуй разницу )))
   Alexs_set
 
3 - 28.10.20 - 14:16
//Да я согласен, но тогда получается в функции 

&НаСервере
функция ПечатьНаСервере() 

.................

// нужно опять прописывать и все остальные 4 параметра?
// чет я уже не соображаю.
   Kigo_Kigo
 
4 - 28.10.20 - 14:21
(3) Их туда надо по ментшей мере предать, а где вы их уж будете определять, дело ваше
   Alexs_set
 
5 - 28.10.20 - 14:33
&НаСервере
функция ПечатьНаСервере()
    ОбъектФормы = РеквизитФормыВЗначение("Объект");
    МассивОбъектов = Новый Массив;
    МассивОбъектов.Добавить(Объект.ЗаказКлиента);
    ОбъектФормы.Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода,ПараметрыПечати = Неопределено);      
Конецфункции
// ошибки по всем параметрам - Переменная не определена (КоллекцияПечатныхФорм)....
   Alexs_set
 
6 - 28.10.20 - 14:35
Чет я вообще туплю - по страшному. Объясните по русски, простым языком, а если можно то покажите как правильно, уже мозг кипит...
   kobzon2
 
7 - 28.10.20 - 14:43
(6) Набери в яндекс или гугл: Отладка внешних печатных форм для тонкого клиента

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.