Вход | Регистрация
 

ЗУП КОРП. Произвольный кадровый приказ и фильтр на поле

ЗУП КОРП. Произвольный кадровый приказ и фильтр на поле
Я
   егаис
 
27.10.20 - 12:57
Добавлен реквизит шапки с типом Справочникю.ВидыИспользованияРабочегоВремени.
Как наложить фильтр на данный реквизит. Нужно из общего списка ограничить выбор несколькими значениями.
   егаис
 
1 - 27.10.20 - 13:04
форма строится ОтобразитьДополнительныеРеквизитыШапки
Не придумаю, как наложить условия выбора
   егаис
 
2 - 27.10.20 - 13:11
вроде достучался до поляформы, иденификатор можно получить через функцию документа ПолучитьРеквизиты()
Осталось наложить параметрыотбора.
Интересно пообщаться с умным человеком :)
   SleepyHead
 
3 - 27.10.20 - 13:45
(2) в (0) непонятно, как именно и куда добавлен реквизит. Умные боятся показаться дураками и молчат, но я не очень умный и спрашиваю.
   SleepyHead
 
4 - 27.10.20 - 13:46
Если это реквизит документа, так в динамическом списке отборы легко накладываются.
   егаис
 
5 - 27.10.20 - 13:49
(3) привет
в том то и дело, что динамический реквизит
Если интересно, стукнись в скайп, напишу решение
   егаис
 
6 - 27.10.20 - 13:52
+(5) добавлен реквизит через шаблон произвольного приказа, это не реквизит документа.
   SleepyHead
 
7 - 27.10.20 - 13:53
(6) пиши, чего стесняешься, можно и сюда. Я думаю, интересно не мне одному.
   егаис
 
8 - 27.10.20 - 13:58
(7) да легко, код несложный

//ОБРАБОТЧКИ СОЬЫТИЯ

&НаКлиенте
Процедура ВидВремениНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;
    ВидВремениНачалоВыбораСервер(ДанныеВыбора);
    
КонецПроцедуры

&НаСервере
Процедура ВидВремениНачалоВыбораСервер(ДанныеВыбора)
    
    ДанныеВыбора = Новый СписокЗначений;
    //добавляем свой список данных выбора

    
КонецПроцедуры

//ВЫЗЫВАЕТСЯ ИЗ ОтобразитьДополнительныеРеквизитыШапки() ГДЕ ОПРЕДЕЛЯЕТСЯ ИМЯ НУЖНОГО НАМ РЕКВИЗИТА

&НаСервере
Процедура ОписатьСобытияЭлементовФормы(ИмяРеквизитаВидаВремени)
    
    Если ИмяРеквизитаВидаВремени = "" Тогда
        Возврат;
    КонецЕсли;    
    
    РеквизитВидаВремени = ЭтаФорма.Элементы.Найти(ИмяРеквизитаВидаВремени);
    РеквизитВидаВремени.УстановитьДействие("НачалоВыбора", "ВидВремениНачалоВыбора"); 
    
КонецПроцедуры
   SleepyHead
 
9 - 27.10.20 - 14:00
(8) Спасибо, интересно, с КОРП я не работал. В Обычном ЗУП приходится добавлять просто допреквизиты, если нужно.
   _Batoo
 
10 - 27.10.20 - 14:02
интересно что будет если заполнить это поле вводом по строке)
   егаис
 
11 - 27.10.20 - 14:02
(10) упс )
   егаис
 
12 - 27.10.20 - 14:17
добавить     РеквизитВидаВремени.РежимВыбораИзСписка = Истина;

Список тем форума
Рекламное место пустует  Рекламное место пустует
Компьютеры — прекрасное средство для решения проблем, которых до их появления не было.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.