Вход | Регистрация
 

Движения документа корректировка реализации по регистру бухгалтерии.

Движения документа корректировка реализации по регистру бухгалтерии.
Я
   NaRaz
 
27.10.20 - 11:09
Всем привет.
УПП 1.3, вопрос, где формируются движения по регистру бухгалтерия Хозрасчетный, при проведении документа Корректировка реализации.
В модуле документа указано: "// Проводки формируются и в модуле документа, и при списании партий"

Кто нибудь знает в каком ОМ партии списываются, а лучше ОМ ГДЕ по хозрасчетному движения делаются?

Не могу найти ни через подписки на события, точку останова перед записью набора РБ ставил, но походу движения пишутся через движения документа, а не через набор. Буду рад советам.
   NaRaz
 
1 - 27.10.20 - 11:16
Ваще капец какой то, ссылки на объекты смотрел, найти не смог, модуль смотрел, набор по РБ пишется пустой, подписки на события просмотрел все.
Результата нет. Сейчас буду смотреть проведение реализации
   NaRaz
 
2 - 27.10.20 - 11:34
Процедура ЗаполнитьКолонкиРегистраСписанныеТоварыПоТоварамРегл(ТаблицаДвижений, СтруктураШапкиДокумента, ТаблицаПоТоварам)
    
    Перем КэшПоСчетам;
    
    ТаблицаДвижений.ЗаполнитьЗначения(СтруктураШапкиДокумента.ОтражатьВБухгалтерскомУчете, "ОтражатьВБухгалтерскомУчете");
    ТаблицаДвижений.ЗаполнитьЗначения(СтруктураШапкиДокумента.ОтражатьВНалоговомУчете,     "ОтражатьВНалоговомУчете");
    ТаблицаДвижений.ЗаполнитьЗначения(СтруктураШапкиДокумента.Организация,                 "Организация");
    
    // Кор.Счет для начисления задолженности перед комитентом, если вдруг продадим комиссионный товар

    ТаблицаДвижений.ЗаполнитьЗначения(СчетУчетаРасчетовСКонтрагентом,                        "КорСчетЗадолженностиБУ");
    
    Если СтруктураШапкиДокумента.ВидДоговора = Перечисления.ВидыДоговоровКонтрагентов.СПокупателем Тогда
        
        ТаблицаДвижений.ЗаполнитьЗначения(ПланыСчетов.Налоговый.ПоступлениеИВыбытиеИмуществаРаботУслугПрав, "КорСчетНУ");
        ТаблицаДвижений.ЗаполнитьЗначения(Перечисления.УсловияПоступленияИВыбытияИмущества.ЗаПлату,         "КорСубконтоНУ1");
        
        Если НЕ СтруктураШапкиДокумента.Свойство("КэшПоСчетам", КэшПоСчетам) Тогда
            КэшПоСчетам = Новый Соответствие;
        КонецЕсли;
        
        Для Каждого Строка Из ТаблицаДвижений Цикл
            
            ЭтоВозврат = (Строка.КодОперацииПартииТоваров = Перечисления.КодыОперацийПартииТоваров.ВозвратОтКомиссионера)
                ИЛИ (Строка.КодОперацииПартииТоваров = Перечисления.КодыОперацийПартииТоваров.ВозвратОтПокупателя);
            
            СтрокаТЧ = ТаблицаПоТоварам.Получить(Строка.НомерСтроки);
            
            Строка.КорСчетБУ      = СтрокаТЧ.СчетРасходовБУ;
            Строка.КорСчетНУ      = СтрокаТЧ.СчетРасходовНУ;
            Строка.КорСубконтоБУ2 = СтрокаТЧ.СубконтоБУ;
            Строка.КорСубконтоНУ2 = СтрокаТЧ.СубконтоНУ;
            
            // Доход от продажи может облагаться ЕНВД (что определяется по бух. счету учета)

            Если ЗначениеЗаполнено(СтрокаТЧ.СчетДоходовБУ) Тогда
                
                СчетДоходовБУОтноситсяКДеятельностиЕНВД = КэшПоСчетам[СтрокаТЧ.СчетДоходовБУ];
                Если СчетДоходовБУОтноситсяКДеятельностиЕНВД = Неопределено Тогда
                    СчетДоходовБУОтноситсяКДеятельностиЕНВД = НалоговыйУчетУСН.ОтноситсяКДеятельностиЕНВД(СтрокаТЧ.СчетДоходовБУ);
                    КэшПоСчетам.Вставить(СтрокаТЧ.СчетДоходовБУ, СчетДоходовБУОтноситсяКДеятельностиЕНВД);
                КонецЕсли;
                
                Если СчетДоходовБУОтноситсяКДеятельностиЕНВД Тогда                
                    // в этом случае товар списывается на счет расходов по ЕНВД

                    Строка.КорСчетНУ = ПланыСчетов.Налоговый.РасходыПоДеятельностиЕНВД;
                КонецЕсли;
                
            КонецЕсли;
            
            // Принятые на комиссию товары не учитываются в налоговом учете:

            Если НЕ ЗначениеЗаполнено(СтрокаТЧ.СчетУчетаНУ) Тогда
                Строка.ОтражатьВНалоговомУчете = Ложь;
            Иначе
                Строка.ОтражатьВНалоговомУчете = СтруктураШапкиДокумента.ОтражатьВНалоговомУчете;
            КонецЕсли;
            
            Строка.ПринятыеКорСчетБУ        = СтрокаТЧ.ПринятыеСчетУчетаБУ;
            Строка.ПринятыеКорСчетНУ        = СтрокаТЧ.ПринятыеСчетУчетаНУ;
            
            Если СтруктураШапкиДокумента.ОтражатьВНалоговомУчетеУСН Тогда
                Строка.ОтражатьВНалоговомУчете = Истина;
                Строка.СчетУчетаНУ                = СтрокаТЧ.СчетУчетаБУ;
                Строка.ПринятыеСчетУчетаНУ        = СтрокаТЧ.ПринятыеСчетУчетаБУ;
                Строка.ПринятыеКорСчетНУ          = Строка.ПринятыеКорСчетБУ;
            КонецЕсли;
            
            // Субконто кор.счета для начисления задолженности перед комитентом, если вдруг продадим комиссионный товар

            Строка.КорСубконтоЗадолженностиБУ1 = Контрагент;
            Строка.КорСубконтоЗадолженностиБУ2 = ДоговорКонтрагента;
            
            Строка.СчетДоходовБУ                = СтрокаТЧ.СчетДоходовБУ;
            Строка.СчетДоходовНУ                = СтрокаТЧ.СчетДоходовНУ;
            
            Строка.СуммаЗадолженностиБУ        = ?(ЭтоВозврат, -(СтрокаТЧ.СуммаБезНДС + СтрокаТЧ.НДС), СтрокаТЧ.СуммаБезНДС + СтрокаТЧ.НДС);
            Строка.СуммаНДС                    = ?(ЭтоВозврат, -СтрокаТЧ.НДС, СтрокаТЧ.НДС);
            
            Если НЕ СтруктураШапкиДокумента.ВалютаВзаиморасчетов = СтруктураШапкиДокумента.ВалютаРегламентированногоУчета Тогда
                
                Строка.КорВалютаЗадолженностиБУ        = СтруктураШапкиДокумента.ВалютаВзаиморасчетов;
                Строка.КорВалютнаяСуммаЗадолженностиБУ = СтрокаТЧ.СуммаВал;
                
                Если СтруктураШапкиДокумента.ОтражатьВБухгалтерскомУчете и СтруктураШапкиДокумента.УчитыватьНДС Тогда
                    Строка.КорВалютнаяСуммаНДСЗадолженностиБУ = СтрокаТЧ.НДСВал;
                КонецЕсли; 
                
            КонецЕсли;
            
        КонецЦикла;
        
        ТаблицаДвижений.ЗаполнитьЗначения(ДоговорКонтрагента, "КорСубконтоБУ3");
        
        
        //Зинаков

        ТаблицаДвижений.Очистить();
        //Зинаков

        
    ИначеЕсли СтруктураШапкиДокумента.ВидДоговора = Перечисления.ВидыДоговоровКонтрагентов.СКомиссионером Тогда
        
        Для Каждого Строка Из ТаблицаДвижений Цикл
            
            СтрокаТЧ = ТаблицаПоТоварам.Получить(Строка.НомерСтроки);
            
            Строка.КорСчетБУ           = СтрокаТЧ.ПереданныеСобственныеБУ;
            Строка.КорСчетНУ           = СтрокаТЧ.ПереданныеСобственныеНУ;
            
            Строка.ПринятыеКорСчетБУ = СтрокаТЧ.ПереданныеПринятыеБУ;
            Строка.ПринятыеКорСчетНУ = СтрокаТЧ.ПереданныеПринятыеНУ;
            
            Если СтруктураШапкиДокумента.ОтражатьВНалоговомУчетеУСН Тогда
                Строка.ОтражатьВНалоговомУчете     = Истина;
                Строка.СчетУчетаНУ                    = СтрокаТЧ.СчетУчетаБУ;
                Строка.КорСчетНУ                   = СтрокаТЧ.ПереданныеСобственныеБУ;
                Строка.ПринятыеСчетУчетаНУ         = СтрокаТЧ.ПринятыеСчетУчетаБУ;
                Строка.ПринятыеКорСчетНУ         = СтрокаТЧ.ПереданныеПринятыеБУ;
            КонецЕсли;
            
        КонецЦикла;
        
    КонецЕсли;
    
КонецПроцедуры
   NaRaz
 
3 - 27.10.20 - 11:35
(2) Админы удалите пожалуйста фамилию из сообщения (2)
   NaRaz
 
4 - 27.10.20 - 11:57
Так в (2) формируется только таблица значений, по которой будут сделаны проводки.
   NaRaz
 
5 - 27.10.20 - 12:16
Запись проводки идет тут: УправлениеЗапасамиПартионныйУчет.ЗаписатьДвижения
   NaRaz
 
6 - 27.10.20 - 13:22
Формирование проводки идет тут Документы.КорректировкаРеализаций.СформироватьПроводкиПоТовару() - Это ММ документа. Нашел!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.