Вход | Регистрация
 

xddTest Кто пользовался, подскажите

xddTest Кто пользовался, подскажите
Я
   osa1C
 
25.10.20 - 10:24
Доброго всем!
    Ситуация такая: Один из наших разработчиков косячнул немного. Задача стояла в том, что при проведении документов оплаты для ФЛ, должны автоматически создаваться реализации, заполняясь из ЗаказаКлиента. Механизм по созданию и заполнению прописан в нашем ОбщемМодуле. В общем он обрезал скидку из ЗаказаКлиента, перемножив цену*количество в реализации.
    Вроде мелочь, быстро поправил, но это было уже на продуктиве и нам пришел инцидент, что не есть хорошо.
И тут мне пришла директива из центра "Алекс Юстасу сверх срочно, сверх секретно" о том, что надо создать проверку чтобы такие косячки не могли попасть в продуктив из хранилища.
Выдали обработку xddTestRunner, которая проверяет ошибки. И дали пару тестовых шаблонов для нее.
   Сам вопрос кто знаком с этим механизмом подскажите как мне создать проверку, которая будет имитировать проведение документа оплаты + создание реализации. А потом я сверю суммы по документам ЗаказКлиента и Реализация
   Полован
 
1 - 25.10.20 - 10:29
(0) Это модульное тестирование а тебе сценарное надо.
   osa1C
 
2 - 25.10.20 - 10:37
(1) Хочешь сказать что сценарное из этой обработки не получу?
   osa1C
 
3 - 25.10.20 - 11:05
,
   Полован
 
4 - 25.10.20 - 13:17
(2) Нет, это только часть фреймворка тестирования Ванесса.
   Вафель
 
5 - 25.10.20 - 13:28
(1) модульного для такой задачи вполне норм.
единственное что теперь разработка будет в 1.5-3 раза дольше. ибо нужно будет еще и тесты писать
   Полован
 
6 - 25.10.20 - 13:31
(5) Ты предлагаешь ТС покрыть тестами существующий функционал? Иначе в модульном тестировании как-то не очень много смысла.
   shuhard
 
7 - 25.10.20 - 13:42
(2)[как мне создать проверку] http://catalog.mista.ru/1c/articles/418168/
   Вафель
 
8 - 25.10.20 - 14:01
(6) ну это тоже нужно. но можно и начать с покрытия новых доработок
   osa1C
 
9 - 25.10.20 - 16:22
(6) в том и дело что надо покрыть тестами функционал, но не я один этим страдать буду.
Сейчас СонарКуб определяет говнокод и вылает разработчику его косяки... Теперь решили не пускать в продуктив ошибки любого рода, а если они и с инцидентом тогда вообще ваааааааааааауууууууууууууууууууу поэтому изучаю функционал этой обработины
   osa1C
 
10 - 25.10.20 - 16:36
уже кое что нашел)))
   osa1C
 
11 - 25.10.20 - 16:37
расскажу как победЮ :))
   Сияющий в темноте
 
12 - 25.10.20 - 16:47
во-перввх,перемножил цену на количество в принципе неправильно,есть стандартные процедуры заполнения табличных частей,которые для этого и делались.
к сожалению,подобные ошибки при тестировании можно выявить только если знать,что тестировать.
соответственно,если про скидку забыли,то она в тест точно также не попадет.
к сожалению,глубинные ошибки в алгоритме могут выявить только люди,машина здесь пока не поможет.
   osa1C
 
13 - 25.10.20 - 20:27
(12) Сравнение Заказа и Реализации можно даже построчно в моем случае поможет
   Вафель
 
14 - 25.10.20 - 21:50
(13) это ты знаешь какую ошибку ты ищешь.
а обычно не знаешь
   vi0
 
15 - 26.10.20 - 06:06
(13) в этом механизме есть функция сравнения таблиц
   vi0
 
16 - 26.10.20 - 06:23
приципиально так можено сделать:

Перем ПроверкаТаблиц;

Процедура Инициализация(КонтекстЯдра) Экспорт

    ПроверкаТаблиц = КонтекстЯдра.Плагин("УтвержденияПроверкаТаблиц");
    
КонецПроцедуры

Процедура ЗаполнитьНаборТестов(НаборТестов, КонтекстЯдра) Экспорт
    
    НаборТестов.Добавить("Тест1");
    
КонецПроцедуры

Процедура Тест1() экспорт

    //...

    ПроверкаТаблиц.ПроверитьРавенствоТаблиц(ТаблицаРеализации, ТаблицаЗаказа, , Новый Структура("НечеткоеСравнение"));
    
КонецПроцедуры
   Chameleon1980
 
17 - 26.10.20 - 08:04
есть  места, где "я художник - я так вижу" и что скажут ваши тесты?
   osa1C
 
18 - 26.10.20 - 09:46
(17) Они не скажут, а не дадут залить код с ошибками в продуктив из хранилища. Соответственно не будут остановки предприятия из за того что у отдела продаж документы не проводятся или проводятся с ошибкой создателя

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.