Вход | Регистрация
 

Печать из списка нового вида документа

Печать из списка нового вида документа
Я
   Juliette_Juliette
 
24.10.20 - 15:47
в ЗУП добавлен новый документ со своими макетами.
Из формы печатает, из списка ошибка "Команда не может быть выполнена для указанного объекта."
вот здесь возвращает Неопределено
Функция СвойствоСтруктуры(Структура, Ключ, ЗначениеПоУмолчанию = Неопределено) Экспорт
    
    Если Структура = Неопределено Тогда
        Возврат ЗначениеПоУмолчанию;
    КонецЕсли;
    
    Результат = ЗначениеПоУмолчанию;
    Если Структура.Свойство(Ключ, Результат) Тогда
        Возврат Результат;
    Иначе
        Возврат ЗначениеПоУмолчанию;
    КонецЕсли;
    
КонецФункции


Что забыла сделать?
   lodger
 
1 - 24.10.20 - 15:52
а как Функция СвойствоСтруктуры связана с Печать из списка?
   Juliette_Juliette
 
2 - 24.10.20 - 15:53
из подключаемых команд через
Процедура ДобавитьСсылкуВСписок(ДанныеФормыСтруктура, МассивСсылок, ТипПараметра)
   Juliette_Juliette
 
3 - 24.10.20 - 15:58
блииин, решено :)
динамический список криво сделан, не добавила Ссылку

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.