Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

проведение справочника по регистру сведений

проведение справочника по регистру сведений
Я
   Эльчин
 
22.10.20 - 12:11
привет. есть такая задача. при записи элемента справочника нужно добавить записи в независимую периодическую регистру. и при удалении очистить записи. написал такой код. хочу спросить, правильно ли сделал или есть другой какое то более оптимальный вариант?

Процедура ПриЗаписи(Отказ)
    
    Если Ссылка.ПометкаУдаления Тогда
        Для Каждого стр Из Список Цикл
            НаборЗаписей = РегистрыСведений.СурвГрафикиРаботы.СоздатьНаборЗаписей();
            НаборЗаписей.Отбор.ГрафикРаботы.Установить(Ссылка);    
            НаборЗаписей.Отбор.Дата.Установить(стр.Дата);
            НаборЗаписей.Записать();
        КонецЦикла;
    Иначе    
        Для Каждого стр Из Список Цикл
            НаборЗаписей = РегистрыСведений.СурвГрафикиРаботы.СоздатьНаборЗаписей();
            НаборЗаписей.Отбор.ГрафикРаботы.Установить(Ссылка);    
            НаборЗаписей.Отбор.Дата.Установить(стр.Дата);
            НовЗапись = НаборЗаписей.Добавить();
            НовЗапись.Период    = НачалоМесяца(Период);
            НовЗапись.Дата    = стр.Дата;
            НовЗапись.ГрафикРаботы    = Ссылка;
            НовЗапись.ВремяВхода    = стр.ВремяВхода;
            НовЗапись.ВремяВыхода = стр.ВремяВыхода;
            НовЗапись.СтавкаЗарплаты = стр.СтавкаЗарплаты;
            НовЗапись.ТипДняПоРаботе = стр.ТипДняПоРаботе;
            НаборЗаписей.Записать();
        КонецЦикла;
    КонецЕсли;
    
КонецПроцедуры
   Эльчин
 
1 - 22.10.20 - 12:12
(0) "Список" это табличная часть в справочние
   mistеr
 
2 - 22.10.20 - 12:22
(0) Вроде правильно. Но возникает вопрос, а нужна ли ТЧ? В форме справочника можно показывать сразу региста и редактировать там же.
   БаксПо90
 
3 - 22.10.20 - 12:22
не касаясь кода, с записью набора записей в цикле .. вообще с независимы регистрами сведений надо работать только понимая где ты с ним закончишь работать и все ле будет хорошо
   БаксПо90
 
4 - 22.10.20 - 12:25
т.е. минимальная ошибка в использовании независимого регистра или возвращение к нему в будущем с другими задачами может все очень усложнить.
Ну и да, все что существует само по себе может в какой то момент отдельно быть отредактировано и это вызовет ошибки .. но опять таки если кто то куда то полезет, удалит и т.п.
   Эльчин
 
5 - 22.10.20 - 12:25
(2) да, этот тч нужна. это тч заполняется автоматически, а потом по нем добавляю записи в регистр
(3)
спасибо всем
   mistеr
 
6 - 22.10.20 - 12:32
(5) Тем более. Регистр тоже можно заполнять автоматически. Зачем дублировать одинаковые данные в двух местах. Рано или поздно они разойдутся и начнутся проблемы.
   Жан Пердежон
 
7 - 22.10.20 - 12:37
что будет с РС при изменении ТЧ в справочнике и перезаписи?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.