Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Ошибка при установке TCP-соединения

Ошибка при установке TCP-соединения
Я
   rabbidX
 
22.10.20 - 09:19
1С:Предприятие 8.3 (8.3.16.1224) режим совместимости с Версия 8.2.16
Пытаюсь подключиться к локалхосту, используя winsocket. Ошибок при подключении не возникает, но код состояния сокета (9) говорит об ошибке. Обработчик события ошибки не срабатывает. Ниже будет листинг тестовой обработки. В чем может быть проблема?

Перем ws;

Процедура КнопкаВыполнитьНажатие(Кнопка)
    Попытка
        ws = Новый COMОбъект("mswinsock.winsock");
        ws.LocalPort = 8080;
        ws.Connect();
        Сообщить("ОК");
        
    Исключение
        Сообщить(ОписаниеОшибки());
    КонецПопытки;
    
    Попытка
        ДобавитьОбработчик ws.Close, Close1;
        ДобавитьОбработчик ws.Connect, Connect;
        ДобавитьОбработчик ws.ConnectionRequest, ConnectionRequest;
        ДобавитьОбработчик ws.DataArrival, DataArrival;
        ДобавитьОбработчик ws.Error, Error;
        ДобавитьОбработчик ws.SendComplete, SendComplete;
        ДобавитьОбработчик ws.SendProgress, SendProgress;
    Исключение
        Сообщить(ОписаниеОшибки());
    КонецПопытки;
    ПодключитьОбработчикОжидания("ПоказатьСтатус", 3);
КонецПроцедуры

Процедура ПоказатьСтатус()
    Сообщить(ws.State);
    ОтключитьОбработчикОжидания("ПоказатьСтатус");
КонецПроцедуры

Процедура Close1()
    Сообщить("Close");
КонецПроцедуры

Процедура Connect()
    Сообщить("Connect");
КонецПроцедуры

Процедура ConnectionRequest(requestID)
    Сообщить("ConnectionRequest");
КонецПроцедуры

Процедура DataArrival(bytesTotal)
    Сообщить("DataArrival");
КонецПроцедуры
    
Процедура Error(Number, Description, Scode, Source, HelpFile,HelpContext, CancelDisplay)
    Сообщить("Error");
КонецПроцедуры

Процедура SendComplete()
    Сообщить("SendComplete");
КонецПроцедуры

Процедура SendProgress(bytesSent, bytesRemaining)
    Сообщить("SendProgress");
КонецПроцедуры

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.