Вход | Регистрация
 

Как в коде сослаться на кнопку ДобавитьЛоготип

Как в коде сослаться на кнопку ДобавитьЛоготип
Я
   NIGHTHUNTER
 
20.10.20 - 08:59
Хочу изменять видимость кнопки, при переходе по вкладкам. Но не пойму как сослаться на неё в коде, что бы управлять видимостью. Подскажите пожалуйста ?

http://joxi.ru/8An130OCyq9Xx2


&НаКлиенте
Процедура ОсновнаяПанельКППриСменеСтраницы(Элемент, ТекущаяСтраница)
    Если ТекущаяСтраница.Имя = "ЛоготипКП" Тогда
        Элементы.
    КонецЕсли;
КонецПроцедуры
   Радим1987
 
1 - 20.10.20 - 09:02
Элементы.ФормаДобавитьЛоготип.Видимость = (ТекущаяСтраница.Имя = "ЛоготипКП")
   Радим1987
 
2 - 20.10.20 - 09:04
Правильнее

&НаКлиенте
Процедура ОсновнаяПанельКППриСменеСтраницы(Элемент, ТекущаяСтраница)
    Элементы.ФормаДобавитьЛоготип.Видимость = (ТекущаяСтраница = Элементы.ЛоготипКП)
КонецПроцедуры

Список тем форума
Рекламное место пустует  Рекламное место пустует
Я не хочу быть самым богатым человеком на кладбище. Засыпать с чувством, что за день я сделал какую-нибудь потрясающую вещь — вот что меня интересует. Стив Джобс, 1996 г.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.