Вход | Регистрация
 

Вопрос по загрузке из Excel

Вопрос по загрузке из Excel
Я
   Snail
 
19.10.20 - 13:08
Есть файл хлс, в нем строки - товары (100шт), колонки - магазины (50 шт). Задача в том, чтобы создать документы в котором реквизит - контрагент, а таб часть это товары по строке.
Как это организовать?
Загрузить данные с файла в ТаблицуЗначений? (как ее вывести на УФ форму документа)
Или Создать Табличную часть с 200 строками и 100 колонками и загружать напрямую?
   Snail
 
1 - 19.10.20 - 13:13
ТекЛист = Док.Application.Workbooks(ИмяКниги).Worksheets(1);
    КолСтрок = ТекЛист.UsedRange.Rows.Count;
    КолСтолбцов = ТекЛист.UsedRange.Columns.Count;
    
    СомОбластьДанных = ТекЛист.Range(ТекЛист.Cells(1,1),ТекЛист.Cells(КолСтрок,КолСтолбцов));
    Данные = СомОбластьДанных.Value.Выгрузить();
    
    ТЗ2 = Новый ТаблицаЗначений;  
    Для Сч = 0 По КолСтолбцов - 1 Цикл
        ТЗ2.Колонки.Добавить("Колонка" + Сч);   
    КонецЦикла;    
    Для Сч=1 По КолСтрок Цикл   
        ТЗ2.Добавить();    
    КонецЦикла;    
    Для Сч=0 По КолСтолбцов-1 Цикл  
        ТЗ2.ЗагрузитьКолонку(Данные[Сч], "Колонка"+Сч);       
    КонецЦикла;
   Snail
 
2 - 19.10.20 - 13:14
Так получаю ТаблицуЗначений
   Snail
 
3 - 19.10.20 - 13:15
Как ее всунуть на форму?
   ДенисЧ
 
4 - 19.10.20 - 13:15
"товары ... магазины ... контрагент"...

Не стыкуется
   ДенисЧ
 
5 - 19.10.20 - 13:15
(3) Со сметанкой пробовал?
А просто в табличное поле Загрузить() ?
   Snail
 
6 - 19.10.20 - 13:16
товар/магаз 1 2 3 4 5 6 7
товар
Товар 1
Товар 2
,,,
   arsik
 
7 - 19.10.20 - 13:16
Загрузи в таблицу "Магазин, Товар, Количество"
Выводи в виде дерева "Магазин - Товар"
   Snail
 
8 - 19.10.20 - 13:22
ДенисЧ, Объект.ТабличнаяЧасть.Загрузить(ТЗ2); ?
Но тогда мне нужно создать табличную часть на форме 100/200
   ДенисЧ
 
9 - 19.10.20 - 13:23
(8) 100/200 будет 0.5
А к чему этот вопрос?
   Snail
 
10 - 19.10.20 - 13:24
)) это 100 колонок с наименование магазина и 200 с наимнованием товара
   ДенисЧ
 
11 - 19.10.20 - 13:25
(10) Ты их уже создал же в (1)
   Snail
 
12 - 19.10.20 - 13:27
Да, но в ТаблицеЗначений
   ДенисЧ
 
13 - 19.10.20 - 13:30
И? Загрузить() почитай...
И да, табличному полю после этого не забудь сказать СоздатьКолонки()
   Snail
 
14 - 19.10.20 - 13:52
Как эту "ТЗ2" вывести на форму я так и не понял (
   arsik
 
15 - 19.10.20 - 13:58
(8) Зачем тебе 100 на 200
Создай ТЗ с колонками Товар, магазин, количество
Строк в ней у тебя будет 20000
   ДенисЧ
 
16 - 19.10.20 - 14:00
(14) У тебя есть табличное поле.
У тебя есть готовая ТЗ.
Первую выводи (загружай в первую).
Всё. И (13) прочитай внимательно
   Snail
 
17 - 19.10.20 - 15:30
Это обработка, на форме есть только кнопка и ТабличнаяЧасть, что за "Табличное поле"?
   ДенисЧ
 
18 - 19.10.20 - 15:34
(17) Элемент управления формы. Который ты туда поместил и в котором хочешь показать свои даннные
   Snail
 
19 - 19.10.20 - 16:04
Я хочу поместить ТЗ в Табличную часть, но, видимо, не судьба :( 

Объект.ТабличнаяЧасть.Загрузить(ТЗ2); Загружает только если вручную создавать колонки с именем "Колонка1", "Колонка2"...

Где использовать СоздатьКолонки()?  Печаль ((
   ДенисЧ
 
20 - 19.10.20 - 16:09
В табличную часть - не загрузишь. В табличное поле - запросто.
   Snail
 
21 - 19.10.20 - 16:14
Я немогу найти это табличное поле, где оно? Поле табличного документа есть, а где табличное поле? Изини, что так туплю )
   Snail
 
22 - 19.10.20 - 17:16
Табличное поле точно есть на управляемых формах?


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.