Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Пожалуйста, помогите с заполнением печатной формы реквизитами

Пожалуйста, помогите с заполнением печатной формы реквизитами
Я
   Vit4567
 
19.10.20 - 06:58
Ребята, прошу помощи.
Требуется вывести в виде таблицы значения всех реквизитов документа.
В документе есть табличная часть со ссылочными реквизитами.
Пытался сделать конструктором, не получилось.
Процедура Печать(ТабДок, Ссылка) Экспорт
    //{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
    Макет = Документы.СписокОтгрузки.ПолучитьМакет("Печать");
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    |    СписокОтгрузки.Дата,
    |    СписокОтгрузки.Номер,
    |    СписокОтгрузки.ПолучательАгент,
    |    СписокОтгрузки.ТабличнаяЧасть1.(
    |        НомерСтроки,
    |        Номенклатура,
    |        Количество,
    |        ТипПарфюмерии,
    |        СодержаниеСпирта,
    |        ТорговаяМарка,
    |        Артикул,
    |        Производитель,
    |        СтранаПроизводителя,
    |        ОбъемЕдиницы,
    |        ДополнительнаяИнформация
    |    )
    |ИЗ
    |    Документ.СписокОтгрузки КАК СписокОтгрузки
    |ГДЕ
    |    СписокОтгрузки.Ссылка В (&Ссылка)";
    Запрос.Параметры.Вставить("Ссылка", Ссылка);
    Выборка = Запрос.Выполнить().Выбрать();

    ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
    Шапка = Макет.ПолучитьОбласть("Шапка");
    ОбластьТабличнаяЧасть1Шапка = Макет.ПолучитьОбласть("ТабличнаяЧасть1Шапка");
    ОбластьТабличнаяЧасть1 = Макет.ПолучитьОбласть("ТабличнаяЧасть1");
    ТабДок.Очистить();
    ВставлятьРазделительСтраниц = Ложь;
    
    Пока Выборка.Следующий() Цикл
        Если ВставлятьРазделительСтраниц Тогда
            ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
        КонецЕсли;

        ТабДок.Вывести(ОбластьЗаголовок);

        Шапка.Параметры.Заполнить(Выборка);
        ТабДок.Вывести(Шапка, Выборка.Уровень());

        ТабДок.Вывести(ОбластьТабличнаяЧасть1Шапка);
        ВыборкаТабличнаяЧасть1 = Выборка.ТабличнаяЧасть1.Выбрать();
        Пока ВыборкаТабличнаяЧасть1.Следующий() Цикл
            ОбластьТабличнаяЧасть1.Параметры.Заполнить(ВыборкаТабличнаяЧасть1);             
            ТабДок.Вывести(ОбластьТабличнаяЧасть1, ВыборкаТабличнаяЧасть1.Уровень());
        КонецЦикла;

        ВставлятьРазделительСтраниц = Истина;
    КонецЦикла;
    //}}
КонецПроцедуры
   Vit4567
 
1 - 19.10.20 - 07:02
В табличной части 
Артикул и ДополнительнаяИнформация 
Строковые значения остальные ссылочные на справочник
   Chameleon1980
 
2 - 19.10.20 - 07:03
а что не получилось то?
   Vit4567
 
3 - 19.10.20 - 07:04
Не выводится таблица
   Vit4567
 
4 - 19.10.20 - 07:06
Номер строки и Количество это тоже строковые реквизиты
   Vit4567
 
5 - 19.10.20 - 07:07
Для спецов думаю задача минутная.
   SleepyHead
 
6 - 19.10.20 - 07:11
(5) Дешевая манипуляция.
   Vit4567
 
7 - 19.10.20 - 07:14
В выборке присутствуют только три значения почему нет остальных, мне не понятно.
   Vit4567
 
8 - 19.10.20 - 07:14
ВыборкаТабличнаяЧасть1    содержит только три значения.
   Галахад
 
9 - 19.10.20 - 07:17
ВыборкаТабличнаяЧасть1 = Выборка.ТабличнаяЧасть1.Выбрать();
Заменить на: 
 ВыборкаТабличнаяЧасть1 = Выборка.Выбрать();
   Vit4567
 
10 - 19.10.20 - 07:18
Из значений табличной части есть только НомерСтроки, Название и Количество
   Vit4567
 
11 - 19.10.20 - 07:20
ВыборкаТабличнаяЧасть1 = Выборка.ТабличнаяЧасть1.Выбрать();
Заменить на: 
 ВыборкаТабличнаяЧасть1 = Выборка.Выбрать();

Тогда выводятся только заголовки колонок
   Vit4567
 
12 - 19.10.20 - 07:27
Проблема в том что 
ОбластьТабличнаяЧасть1.Параметры.Заполнить(ВыборкаТабличнаяЧасть1);
выводит циклом всего три значения, хотя в  ВыборкаТабличнаяЧасть1 присутствуют все нужные.
   Vit4567
 
13 - 19.10.20 - 07:29
Как извлечь эти значения не догоняю просто.
   hhhh
 
14 - 19.10.20 - 08:11
(13) наверно в ОбластьТабличнаяЧасть1.Параметры забыл остальные параметры включить.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.