Вход | Регистрация
 

Предупреждение: 8.3.18 и postgres-pro12.1 не совместимы

Предупреждение: 8.3.18 и postgres-pro12.1 не совместимы
Я
   g00d
 
15.10.20 - 17:11
привет коллеги
после обновления с 8.3.16 до 8.3.18.1128 c базами на postgrespro 12.1 получил "Ошибка СУБД: DATABASE не пригоден для использования.", в логах постгреса пусто.
проверил работу 8.3.18 с базами на postgres9.6 все работает.
Откатился до 8.3.16 и с postgrespro 12.1 все заработало.

пока собираем стенд для поиска решения, если кто знает как решить, буду очень признателен
   Lama12
 
1 - 15.10.20 - 17:16
(0) Версию Postgre -pro 12.4.1 пробовал?
   g00d
 
2 - 15.10.20 - 17:17
(1) сразу как соберем тестовый стенд с текущими версиями -  попробуем
   rphosts
 
3 - 15.10.20 - 17:22
сделаю-ка закладочку...
   ansh15
 
4 - 16.10.20 - 10:12
9.6 есть в списке https://v8.1c.ru/tekhnologii/sistemnye-trebovaniya-1s-predpriyatiya-8/
12.1 в списке отсутствует. Здесь ее https://v8.1c.ru/tekhnologii/postgrespro/ тоже нет.
12.4 работает с 8.3.18.
   arsik
 
5 - 16.10.20 - 10:45
(0) А если через dt базу залить?
   Krendel
 
6 - 16.10.20 - 11:16
(0) Официальной поддержкий 12 релиза пг под 1С нет
   Krendel
 
7 - 16.10.20 - 11:16
конф требующих 18 релиз тоже, смысл заниматься непонятным делом?
   Krendel
 
8 - 16.10.20 - 11:17
хоя 16 релиз под ПГ тоже запустили
   HeKrendel
 
9 - 16.10.20 - 11:19
до 50 пользаков отличное решение
   kzot
 
10 - 16.10.20 - 11:24
значит автор топика всё таки работал под postgrespro 12.1
   ansh15
 
11 - 16.10.20 - 12:36
(7) Требующие 17-й релиз есть? Для ДО КОРП/ГУ(например) предпочтительна 8.3.16, но и на 14-й тоже работает.
Однако, люди ставят 8.3.17, не хотят стоять на месте.
   g00d
 
12 - 16.10.20 - 12:39
(10) не просто работал, но и продолжает работать
   g00d
 
13 - 16.10.20 - 12:49
(7) сейчас на 8.3.16 главная проблема у тормоза баз и серверов после дин обновлений.
в 8.3.18 хочется верить исправили
   kzot
 
14 - 16.10.20 - 12:53
(12) если верить https://v8.1c.ru/tekhnologii/postgrespro/ там нет postgrespro 12.1

полет нормальный ?
   HeKrendel
 
15 - 16.10.20 - 12:54
(10) ТАм слишком много плюх добавили чтобы ее не смотреть ;-)
   g00d
 
16 - 16.10.20 - 14:18
(14) в феврале когда собирали этот сервер тут была инфа про 12.1
   HeKrendel
 
17 - 16.10.20 - 14:20
PostgresPro Enterprise 12.4.1 поддержка заявлена
   g00d
 
18 - 16.10.20 - 14:56
в общем решение найдено и если кратно, то установка 12.4.1 поверх 12.1 решила проблему и проверено 8.3.16 и 8.3.18 работают с 12.4.1
интересно что  
- 8.3.16 + 12.1 работает
- 8.3.18 + 12.1 НЕ работает
- 8.3.18 + 12.4.1 после обновлением работает
- 8.3.18 + с той же базой после обновления с откатом субд до 12.1 РАБОТАЕТ!, но при этом вновь создаваемые базы не работают.
вероятно изменения касаются самой структуры таблиц база данных
еще немного потестируем и будем планировать обновление рабочего сервера.
   ДенисЧ
 
19 - 16.10.20 - 15:08
(18) А если 12.4 чистую поставить?
   g00d
 
20 - 16.10.20 - 15:15
(19) работает
   g00d
 
21 - 20.10.20 - 15:02
если кому интересно
обновление рабочего сервера с большим количество вам баз прошло безболезненно, поменяли ветку репозитария в
vim /etc/apt/sources.list.d/postgrespro-1c.list
на
deb http://repo.postgrespro.ru//pg1c-archive/pg1c-12.4/ubuntu/ xenial main
и выполнили
#sudo  apt install postgrespro-1c-12


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.