Вход | Регистрация
 

Вот эта печатная форма должна работать из унф в док расходная накладная

Вот эта печатная форма должна работать из унф в док расходная накладная
Я
   н7ер
 
15.10.20 - 08:51
Ошибка  



{ВнешняяОбработка.ПечатьСП31.МодульОбъекта(63,31)}: Переменная не определена (БухгалтерскийУчетПереопределяемый)
        СведенияОПоставщике       = <<?>>БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Организация, Шапка.Дата); (Проверка: Сервер)
{ВнешняяОбработка.ПечатьСП31.МодульОбъекта(64,31)}: Переменная не определена (БухгалтерскийУчетПереопределяемый)
        СведенияОГрузоотправителе = <<?>>БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Организация, Шапка.Дата); (Проверка: Сервер)
{ВнешняяОбработка.ПечатьСП31.МодульОбъекта(65,31)}: Переменная не определена (БухгалтерскийУчетПереопределяемый)
        СведенияОПокупателе       = <<?>>БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Контрагент, Шапка.Дата); (Проверка: Сервер)
{ВнешняяОбработка.ПечатьСП31.МодульОбъекта(66,31)}: Переменная не определена (БухгалтерскийУчетПереопределяемый)
        СведенияОГрузополучателе  = <<?>>БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Контрагент, Шапка.Дата); (Проверка: Сервер)
{ВнешняяОбработка.ПечатьСП31.МодульОбъекта(100,23)}: Переменная не определена (ОтветственныеЛицаБП)
        ОтветственныеЛица = <<?>>ОтветственныеЛицаБП.ОтветственныеЛица(Шапка.Организация, Шапка.Дата); (Проверка: Сервер)









Функция СведенияОВнешнейОбработке() Экспорт
    ПараметрыРегистрации = Новый Структура;
    ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма");     
    МассивНазначений = Новый Массив;
    МассивНазначений.Добавить("Документ.РеализацияТоваровУслуг");
    ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
    ПараметрыРегистрации.Вставить("Наименование", "ТТН СП31");
    ПараметрыРегистрации.Вставить("Версия", "1.0");    
    ПараметрыРегистрации.Вставить("БезопасныйРежим", Ложь);
    ПараметрыРегистрации.Вставить("Информация", "Дополнительная печатная форма");
    
    //Команды
    ТаблицаКоманд = Новый ТаблицаЗначений;
    ТаблицаКоманд.Колонки.Добавить("Представление");
    ТаблицаКоманд.Колонки.Добавить("Идентификатор");
    ТаблицаКоманд.Колонки.Добавить("Использование");
    ТаблицаКоманд.Колонки.Добавить("ПоказыватьОповещение");
    ТаблицаКоманд.Колонки.Добавить("Модификатор");
    
    НоваяКоманда = ТаблицаКоманд.Добавить();
    НоваяКоманда.Представление = "ТТН СП-31";
    НоваяКоманда.Идентификатор = "ТТН СП-31";
    НоваяКоманда.Использование = "ВызовКлиентскогоМетода";
    НоваяКоманда.ПоказыватьОповещение = Истина;
    НоваяКоманда.Модификатор = "ПечатьMXL";
    
    ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
    
    Возврат ПараметрыРегистрации;
КонецФункции

Функция Печать(МассивОбъектов,КоллекцияПечатныхФорм, ОбъектыПечати) Экспорт
    
    Перем ПодразделениеОтветственныхЛиц;
    
    ТабличныйДокумент = Новый ТабличныйДокумент;
    ТабличныйДокумент.АвтоМасштаб            = Истина;
    ТабличныйДокумент.ОриентацияСтраницы    = ОриентацияСтраницы.Портрет;
    ТабличныйДокумент.ИмяПараметровПечати    = "ПАРАМЕТРЫ_ПЕЧАТИ_СП31";
    
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("МассивОбъектов", МассивОбъектов);
    Запрос.Текст = ТекстЗапроса();
    Шапка = Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
    
    Пока Шапка.Следующий() Цикл
        
        
        Макет = ПолучитьМакет("СП_31_1");
        
        ОбластьМакета = Макет.ПолучитьОбласть("Стр1");
        
        ОбластьМакета.Параметры.Заполнить(Шапка);
        ОбластьМакета.Параметры.Номер = ПрефиксацияОбъектовКлиентСервер.НомерНаПечать(Шапка.Номер, Истина, Ложь);
        ОбластьМакета.Параметры.ДатаДок = Формат(Шапка.Дата, "ДЛФ=ДД");
        
        ОбластьМакета.Параметры.ДатаЧисло = Формат(Шапка.Дата, "ДФ=dd");
        ОбластьМакета.Параметры.ДатаМесяц = Формат(Шапка.Дата, "ДФ=MM");
        ОбластьМакета.Параметры.ДатаГод = Формат(Шапка.Дата, "ДФ=yyyy");
        
        
        
        СведенияОПоставщике       = БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Организация, Шапка.Дата);
        СведенияОГрузоотправителе = БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Организация, Шапка.Дата);
        СведенияОПокупателе       = БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Контрагент, Шапка.Дата);
        СведенияОГрузополучателе  = БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Контрагент, Шапка.Дата);
        
        
        
        ДокументСсылка = Шапка.Ссылка;
        ОбластьМакета.Параметры.АмМарка = ЭтотОбъект.МаркаАвто;
        
        ОбластьМакета.Параметры.АМГосНомер = ЭтотОбъект.НомерАвто;
        
        
        ОбластьМакета.Параметры.Водитель         = ЭтотОбъект.Водитель;;
        ОбластьМакета.Параметры.Плательщик          = СокрЛП(СведенияОПоставщике.НаименованиеДляПечатныхФорм)+", "+СокрЛП(СведенияОПоставщике.ЮридическийАдрес)+", "+СокрЛП(СведенияОПоставщике.Телефоны);
        ОбластьМакета.Параметры.Организация      = СокрЛП(СведенияОГрузоотправителе.НаименованиеДляПечатныхФорм)+", ИНН"+СведенияОГрузоотправителе.ИНН+", "+СокрЛП(СведенияОГрузоотправителе.ЮридическийАдрес)+", "+СокрЛП(СведенияОГрузоотправителе.Телефоны);
        ОбластьМакета.Параметры.Грузополучатель = СокрЛП(СведенияОГрузополучателе.НаименованиеДляПечатныхФорм)+", "+СокрЛП(СведенияОГрузополучателе.ЮридическийАдрес)+", "+СокрЛП(СведенияОГрузополучателе.Телефоны);
        ОбластьМакета.Параметры.ПунктПогрузки     = СокрЛП(СведенияОПоставщике.ЮридическийАдрес);
        ОбластьМакета.Параметры.ПунктРазгрузки  = Шапка.АдресДоставки;
        ОбластьМакета.Параметры.ПрицепГосНомер  = ЭтотОбъект.ПрицепНомер;
        ТоварТекст = "";
        Для каждого Стр из Шапка.Ссылка.Товары цикл
            ТоварТекст = ТоварТекст + ?(ЗначениеЗаполнено(ТоварТекст), ", ", "") + Строка(Стр.Номенклатура) ;
        КонецЦикла;
        
        ОбластьМакета.Параметры.Товар = ТоварТекст;
        
        ОбластьМакета.Параметры.Тара = ЭтотОбъект.Тара;
        ОбластьМакета.Параметры.Брутто = ЭтотОбъект.Брутто;
        ОбластьМакета.Параметры.Нетто = ЭтотОбъект.Нетто;
        
        ОбластьМакета.Параметры.Сумма = Шапка.СуммаДокумента;
        
        мВалютаРегламентированногоУчет = Константы.ВалютаРегламентированногоУчета.Получить();
        ОбластьМакета.Параметры.СуммаПрописью =  ЧислоПрописью(Шапка.СуммаДокумента, "Л = ru_RU", НСтр("ru='рубль, рубля, рублей, м, копейка, копейки, копеек, ж, 2'"));
        ОбластьМакета.Параметры.СуммаКопейки = Формат((Шапка.СуммаДокумента-Цел(Шапка.СуммаДокумента))*100,"ЧЦ=2;ЧВН=");
        
        ОтветственныеЛица = ОтветственныеЛицаБП.ОтветственныеЛица(Шапка.Организация, Шапка.Дата);
        ОбластьМакета.Параметры.ДолжностьРуководителя = ОтветственныеЛица.РуководительДолжность;
        ОбластьМакета.Параметры.ФИОРуководителя       = ОтветственныеЛица.РуководительПредставление;
        
        ОбластьМакета.Параметры.ДолжностьПринял = "";
        
        ОбластьМакета.Параметры.ФИОПринял = ОбластьМакета.Параметры.Водитель;
        
        ОбластьМакета.Параметры.Приложение  = ЭтотОбъект.Приложение;
        
        ТабличныйДокумент.Вывести(ОбластьМакета);
        ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
        
        Макет = ПолучитьМакет("СП_31_2");
        ОбластьМакета = Макет.ПолучитьОбласть("Стр2");
        ТабличныйДокумент.Вывести(ОбластьМакета);
        
        ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
        
    КонецЦикла;
    
    УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "СП_31_1", "Печать СП-31",
    ТабличныйДокумент);
    
    Возврат ТабличныйДокумент;
    
КонецФункции

Функция ТекстЗапроса()
    
    ТекстЗапроса =
    "ВЫБРАТЬ
    |    РеализацияТоваровУслуг.Ссылка КАК Ссылка,
    |    РеализацияТоваровУслуг.Номер КАК Номер,
    |    РеализацияТоваровУслуг.Дата КАК Дата,
    |    РеализацияТоваровУслуг.Организация КАК Организация,
    |    РеализацияТоваровУслуг.Склад КАК Склад,
    |    РеализацияТоваровУслуг.ПодразделениеОрганизации КАК ПодразделениеОрганизации,
    |    РеализацияТоваровУслуг.Контрагент КАК Контрагент,
    |    РеализацияТоваровУслуг.ВалютаДокумента КАК ВалютаДокумента,
    |    РеализацияТоваровУслуг.Грузоотправитель КАК Грузоотправитель,
    |    РеализацияТоваровУслуг.Грузополучатель КАК Грузополучатель,
    |    РеализацияТоваровУслуг.АдресДоставки КАК АдресДоставки,
    |    РеализацияТоваровУслуг.СуммаДокумента КАК СуммаДокумента,
    |    РеализацияТоваровУслуг.Ответственный КАК Ответственный,
    |    РеализацияТоваровУслуг.Комментарий КАК Комментарий,
    |    РеализацияТоваровУслуг.Руководитель КАК Руководитель,
    |    РеализацияТоваровУслуг.ГлавныйБухгалтер КАК ГлавныйБухгалтер,
    |    РеализацияТоваровУслуг.ОтпускПроизвел КАК ОтпускПроизвел,
    |    РеализацияТоваровУслуг.ДоговорКонтрагента КАК ДоговорКонтрагента,
    |    РеализацияТоваровУслуг.Перевозчик КАК Перевозчик,
    |    РеализацияТоваровУслуг.Товары.(
    |        Ссылка КАК Ссылка,
    |        НомерСтроки КАК НомерСтроки,
    |        Номенклатура КАК Номенклатура,
    |        Количество КАК Количество,
    |        Цена КАК Цена,
    |        Сумма КАК Сумма,
    |        СтавкаНДС КАК СтавкаНДС,
    |        СуммаНДС КАК СуммаНДС
    |    ) КАК Товары
    |ИЗ
    |    Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
    |ГДЕ
    |    РеализацияТоваровУслуг.Ссылка В(&МассивОбъектов)
    |
    |УПОРЯДОЧИТЬ ПО
    |    РеализацияТоваровУслуг.Дата,
    |    РеализацияТоваровУслуг.Ссылка,
    |    НомерСтроки
    |ИТОГИ ПО
    |    Ссылка";
    
    Возврат ТекстЗапроса;
    
КонецФункции
   PuhUfa
 
1 - 15.10.20 - 08:56
Кому она должна?
   н7ер
 
2 - 15.10.20 - 08:57
Предприятие
   н7ер
 
3 - 15.10.20 - 08:58
Не могу понять почему эти ошибки вылазят
   Vadim_37
 
4 - 15.10.20 - 08:58
вроде нет в УНФ бухучета, модуль БухгалтерскийУчетПереопределяемый не может найти
   н7ер
 
5 - 15.10.20 - 09:00
Я это поняла, загружаю через УНФ 1с, и она там тоже выдает такие ошибки
   jsmith82
 
6 - 15.10.20 - 09:01
вас ввели в заблуждение
   jsmith82
 
7 - 15.10.20 - 09:01
(4) Там и документа такого нет
   н7ер
 
8 - 15.10.20 - 09:23
Да я поняла, поменяла на УправлениеНебольшойФирмойСервер, и все пошло
   н7ер
 
9 - 15.10.20 - 09:23
еще добавила ссылкунаобъек, на расходную накладную

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.